Adding Zwave device leads to "Found device.. initializing..." message but then nothing

This has happened to me several times for several different devices and it's very frustrating..

Right now it's happening when I'm trying to add a new Yale YRD-210 ZWave Plus lock but recent memory it happened with a switch as well.

The gist of the issue is this..

  1. I put the hub into inclusion mode
  2. I put the device into pairing mode
  3. I wait.. and after a little bit the device times-out.. with the Yale lock it beeps
  4. I see this message below.. which never changes.. ever..

  1. In settings -> Zwave Details I see the new device but there's nothing useful that can be done here.. no delete option which would be really useful.

  2. I try all of the pairing steps again.. sometimes I'll reboot the hub in between.. sometimes I'll factory reset the device..

In my lock case I can't get it paired.. and maybe I'll get this figured out as I already have this same lock elsewhere paired just fine.

But, my real complaint is.. can't the Hub deal with this a little better? It's happened to me enough times that I have to imagine I'm not alone.

Question:

  • Will this 'orphaned' device prevent me from adding it in the future?
  • Is there any issue having multiple orphaned devices?

Have you tried hitting discover on that last node?

I have found many times with locks that they get in the Discover state, 1/2 paired.
My solution has either been to Shutdown and unplug for a Z-Wave power reset (to remove the incomplete pair) or to move HE closer to the lock. Somtimes I find they are able to say "Hi" to the radio but then fail to complete the pairing due to distance.

@jpage4500 , if you have any existing ghosts already when you pair, this can prevent other pairing. You need to get rid of all ghosts first. After you're done doing that, shut down the hub from the settings menu, unplug (at the wall not the hub) for 5 mins. Factory reset the devices themselves. Power hub back up abs attempt to pair again

1 Like

I would say to do the latest Zwave (and hub) update if you haven't already and see if that makes any difference. The Zwave firmware update seems to make the Zwave network act totally different and better.

I have but nothing happens when I do. I recorded a quick video showing this:

https://drive.google.com/file/d/1VSbdOkDcsDW1uLxr7wk9QI0q4Ao1RKBP/view?usp=sharing

What would 'discover' even do? At this point the device itself isn't in pairing mode - would it still be able to find and pair with it? Or, is the idea that you put the device back into pairing mode and then hit 'discover'?

It attempts to match a driver to a node that is included but doesn’t have a driver.

I'm not sure I understood this.. are you talking about updating individual device firmware using the Hub? I've updated firmware on lots of 'smart' devices before but never for any Zwave/Zigbee devices.. a google search doesn't produce any results either.

The Hub is (well, was) on the latest version.. I see there's a new version available but I've run into issues a couple of times updating to the latest right away so I typically wait a few weeks after a hub update is available.

If there's some other zwave update that can be done can you let me know where/how?

I remember going down a rabbit hole before trying to figure out how to do this.. is there an easier way to do it that doesn't require a ZWave USB stick and a laptop? That seemed to be a bridge too far :slight_smile:

I remember trying to follow this thread the last time this happened

If you can power down the device(s) that made the ghost(S) then you have a chance of removing them (possibly after powering down the hub for 5 mins then plugging back in) If not, you have to do this Dropbox - Hubitat UZB Stick How-To.pdf - Simplify your life

I should have mentioned in my original post that I had my lock right next to the hub when trying to pair them.. I learned that lesson a few years ago!

But, the same issue happened a while back with a Zwave switch too.

I haven't tried powering the hub down before.. will this remove ghost nodes? I'm happy to try it if it does

You need to power it down, unplug at the wall (not the hub) for 5 mins, then bring back up and try to remove the ghost (and make sure the device that created the ghost is powered down through all of this)

Nope.

When you update to 2.3.1.xxx hub update, there is a Zwave radio firmware (for the hub) update as well. Did you do that, or are you still back on 2.3.0?

That 2.3.1 plus the Zwave update make a huge difference.

3 Likes

Same here.....initializing......and then nothing. A ghost with no route.

Are you on hub FW 2.3.1, and did you apply the (separate) new Z-Wave FW update after you updated to 2.3.1?

1 Like

I thought I updated the firmware for z-wave. The "update" button in z-wave settings starts a page (progress bar in address bar) load but stalls.

Yeah, if I wait long enough, the progress bar just completes and nothing happens, so I assume its up-to-date.

Is there somewhere that I can see the z-wave version number in settings? I only see hub firmware version.

The "Update" button here is not for Z-Wave firmware update. When you use the Update button below you're updating the Z-Wave Region and Z-Wave Status settings.

image

There is a separate Firmware Update button for the Z-Wave firmware that goes away after it has been applied. it's on the left side of the screen w/the other Z-Wave options.

If you have updated to 2.3.1 and the Firmware Update button isn't showing on the Z-Wave Details page then you must have already done the Z-Wave radio FW update.

2 Likes

So, It looks like I've added two devices. Z-wave settings show them:


and they are in the device list and dashboard:


But as you see on the dashboard, just question marks??
The lights Do not function and the "configure" button in the HSM multi sensor does nothing.

Its like its only partially pairing?

Any ideas?

For the multisensor make sure on your dash you pick multisensor (or a specific attribute) under template

For the outlet, pick switch for the template. Oh and if neither one of those devices are z-wave plus, you will have to use the generic driver and z-wave poller as they won't push status to the dashboard.

1 Like

Download the Hubitat app