Added August Pro and having problems with other zwave devices on network

I added August Pro 3rd gen to C7. It paired as S2 access control or something. Status reports correctly as well. Able to lock and unlock using the hub.

About an hour after installing most of my other Zwave and Zwave plus switches and dimmers started to fail. They are not turning on via the rules or by dashboard or devices page. Tried restarting the hub, works a few minutes after restarts and then becomes unresponsive again. Tried Zwave repair, that didn't work as well.

I removed the August lock and ran zwave repair and my devices are back to normal. Is there any way to add August Lock to the network without crippling other devices.

What firmware version is the lock on?

Lock is on 1.59.0-2.0.1

Were you seeing any errors in the logs?

I removed the lock from the Hub yesterday, I didnt check the logs when I am excluding it.

The lock was working fine (I am able to see the status and able to Lock/Unlock from dashboard) when all my other zwave devices are unresponsive.