About to send the Hubitat back, can you help me salvage?


#1

I'm about ready to return the Hubitat Elevation I just bought. Been playing with it for 3 days and I find it finicky, inconsistent and unreliable.

I have about 40 devices setup on ST and primarily use WebCore. I was lured by Hubitat's promises of fast local execution and customization.

I have mostly Homeseer switches and dimmers (some WD-100+ and WD-200+) and a few GE dimmers (first ones I ever bought) and a few other devices.

I decided to start by moving one of my old GE dimmers (12724) since I felt it was a basic generic dimmer. Took me about an hour to include it, because after I easily excluded it from ST, it would hang upon including it into HE. After I rebooted the hub, I could not find the dimmer anymore, and even though it didn't show up on any hub, I put HE into exclusion mode and reset the switch and finally got it out of limbo. Once I got it included, I added 2 motions sensors and made a simple RM4.0 rule to turn on the lights when motion as detected, "Ok, now we're on our way, just a rough start", or so I thought.

Next I moved 1 of my WD-200+ switches to HE since it had built in native support. Inclusion worked fine. But I wanted to change the ramp rate on the devices since the default is SOOO SLOW. It worked easily on ST with Darwin's drivers. After another 2 hrs of searching forums and monkeying around with various 3rd party drivers on the forums that basically adapted DarwinDen's drivers, finally got it work (and change default LED colors) with codahq's driver. But I had to to weird things like reset the hub, change the driver back and forth between the built in one and custom one until it just happened to work.

Now I made a simple dashboard with just 2 lights, my WD-200+ dimmer and my GE dimmer I included first. GE dimmer tile works like a charm. WD-200+ doesn't respond at all. Whenever I refresh it says the light is on (even though it's not). I tap it and it just shows an hour glass forever (this is on mobile and on the PC on the lan). I adjust the dimmer slider, nothing happens. Tried switching it back between the native WD200+ driver and the custom one, no dice. Reset hub, nothing.

At this point I think I need to cut my losses. If it was this hard getting 2 switches to sort of work, I'm worried about my other devices like WD-100+ that are not natively supported, my smart outlet plugs, door sensors, garage controllers etc.

I'm no software expert by any means, but I feel like I'm reasonably savy with technology. Am I going about this all wrong?


#2

I also find the Hubitat to be finicky and inconsistent. I’ve only owned mine for a few weeks and I’ve discovered many bugs. I’ve gotten pretty good at working around the bugs, and the alternatives to Hubitat would present their own set of challenges, so at this point I’m just hoping the bugs are squashed and the platform becomes more stable with age. It is after all still a relatively young product.


#3

This is literally a perfect example of how ST works. It's a known issue that A ST doesn't exclude correctly (no one knows why) and B when it's still powered, it hinders including it on the other hub (not just HE)
What you ended up doing is the best course of action + another step.

It's best to exclude the device/s from ST.
Then turn off ST
Then open the logs and exclude using HE this correctly wipes the device really for inclusion (your see a confirmation in the logs).
Then include the device in HE through the usual means.
I know it's a bit of a sing and dance but ST seams to cling onto devices so you have to do this to correctly delete it from ST.

For additional parameters that the built on driver doesn't expose there is a z-wave tweaker you can use. Just like you have done before your need to install the driver but it's built by @mike.maxwell once you have changed them (keep logs open to be sure) you just change back to the default driver.

I'm not sure with these as I'm from UK but I think they sound like older z-wave ones? If they are I believe they have issues with polling. As I understand as standard ST does a bucket load of blanket polling to all device to "fix" this. The issue with this is it puts strain on the network if it's not necessary and limits the size of your network. In HE you need to install a the poler app and tell it what device you want it to do it on (i believe, I have never had to use it).

No, just do what your doing and reach out, although ST and HE are similar there are subtle but important differences that you just need to learn, most of it is a straight swap but with 100% local processing. :wink:


#4

Thanks so much for the reply. I will try a few more things but maybe I'm not as much of a tweaker as I thought or wished I was!


#5

I would say im not much of a tweaker, I only really had alexa and a bunch of skills with her. But it got to the point that I wanted schedules and motion lighting and other more powerful automations.

I literally stand on the backs of these guys smarts and ask ALOT of dumb questions, but there is always someone here willing to give me the time of day to help me get it right. Typically cause I haven't read the whole thread and wonder why it doesnt work.

HE takes a while, but once you get a bunch of small things working the rest gets a lot easier. I just took it slow, bit by bit, device by device until it started to click.
Hang in there bud, its worth it.


#6

Keep in mind that you should hit the CONFIGURE button on the device detail page any time you change drivers. Many users forget this.

Personally I think the system should do that automatically when switching drivers, but I do recognize there are edge cases where users don't want that to happen.


#7

As others have stated above you really need to exclude the device correctly. I have 120 devices ranging between zwave, Zigbee and WiFi. Zwave is a PITA because most times you think you excluded correctly but really you didn’t.

My steps for ensuring zwave success in HE:

  1. Open three browser tabs - one in devices, one in logs and one in zwave settings
  2. Go to zwave settings tab and hit exclude
  3. Switch to logs tab
  4. Follow manufacturer exclude directions
  5. Watch the logs. If you see “Home” pop up in the header list then click on it and make sure the list says “device excluded.” If not repeat steps 2-5
  6. Click zwave settings tab. AFTER zwave exclusion is finished (30 seconds).
  7. Go to devices tab. Click pair device, zwave device
  8. Follow manufacturers instructions to add device to hub
  9. If device found but stays on initializing then first WAIT until discovery hits zero. Hit restart for discovery and then turn device on/off. 99% of time this sends the final waked up command to HE and then device is added. If not, refresh page and try steps 8-9 again. IF STILL not working (now we have to go extreme which is rare) reboot HE and go through steps 1-8 again.

To ensure Zigbee success:

  1. Follow manufacturers process to reset device
  2. Open tab to devices
  3. Discover devices, Zigbee
  4. Follow manufacturers directions to pair device
  5. If device found but stays on initializing then first WAIT until discovery hits zero. Hit restart for discovery and then turn device on/off. Should initialize correctly then.

#8

I would have predicted this to be the other way around, ie the GE 12724 is plain-old z-wave and notorious for not reporting status reliably without polling, and the WS-200+ is z-wave plus with a built in driver, so it should work great on all aspects. I dont have one, just speculating. I would just swap out any and all z-wave non-plus devices for plus. Also make sure you have powered z-wave+ devices within easy range of the hub to ensure a good mesh.


#9

Actually it is just like what you expect. But only for devices new out of the box. But for devices previously included in a ST mesh it's a different story because ST is (apparently) not so great at excluding them. And if you don't know that it could all just end up in a "pain in the ass show".


#10

Thanks for the encouragement guys. I imagine quite a few hubitat users have a Homeseer WD200 or WD100 switch in their setup. What extra steps are needed to make a dashboard tile work? Seems silly that just basically adding it as a dimmer won't even get you the most basic functions working. I'm not trying to get the multitap functions on the dashboard yet, which I don't expect will ever work...


#11

@justin.tan, you can link your ST and HE hubs together to make your transition smooth. Also, ST is a straight out of the box solution. There is a reason that there are so many here and most of them jumped from ST. Turning off your ST hub will help with pairing and I had the exact problem you had because ST didn't let go of my GE Light switches. Also keep in mind that you want to create a strong mesh. I've found that pairing things where they are going to be located is important. Also, try pairing your powered things first to create that mesh. Battery operated things don't repeat. Start close to the hub and work away. Probably not a good idea to do too much at once. I transitioned slowly because I could connect the hubs. This was a godsend. I was able to link rules from He to control things on ST. That was what kept me moving forward. Stay away from rebooting all the time. The hub will straighten out your mesh as you add things, but it will take a bit of time. Not days or anything, but add a few things then wait until tomorrow before you hit it too hard. I feel like you had a rocky start, but remember the community. We .. the people here ... are a unique bunch. I've NEVER had anyone be a shit here. It's refreshing. And welcoming. The further down the rabbit hole you go, the more you'll be hooked. Your first network didn't happen over night. Don't rush this. Connect the hubs and slowly move things over.


#12

@justin.tan

I don't think the GE issue is just a Smartthings problem. My Wink didn't "let go" of the GE nicely either.

The easiest way I found to fix the GE was to do a power off reset. Pull the tab on the switch (under the toggle or paddle) for a few seconds before you attempt to do an inclusion. I couldn't pair any of them in Hubitat unless I did this. My Inovelli didn't act like this, nor did my Zooz. That is why I think it is a GE problem.


#13

I've never been able to get to the bottom of the GE unjoin "issue". I have unpaired and paired (literally) >300 GE switches and dimmers. They unpair fine with HE, ST, Home Assistant, Homeseer, and my Aeotec Zstick...

In turn, they pair fine on ST, Homeseer, Home Assistant, etc...

Now, for HE... I have had a general zwave pairing problems in HE for ~6 months (that is not GE device related at all) in which it takes usually 3-5 tries and multiple hub reboots for me to successfully pair anything zwave. But I don't hear a lot of people screaming about it, so I haven't bothered discussing it w/Hubitat. Oh, and it is the same on 2 different HE hubs for me...

Not the end of the world, as eventually it will pair, and I move on with my life. If I were pairing new devices every day, that routine would be super annoying. But I don't.


#14

April is 100% correct. These posts from new users continue to pop up. Accounts of how users have many devices connected to ST working "flawlessly", but none of these users went out and bought 40 devices, as an example, and connected them all to ST at once. If they had, they would encounter a very different experience, not unlike what they are now experiencing with HE.

It's like going to university for four years, working a job for 10, and then calling the new person just starting out, an idiot because they are not established. You have to build slowly. Your devices need to become steady on their feet before they can run, otherwise they're going to fall.


#15

Thanks everyone! Took your advice, restarted going from inside out and things are working better. Still only have a few devices included, but now at least my tiles work (sort of, have some quirks where the dimmer slider doesn't stay on the value I set it to, it reverts back to the previous value even though the light actually dims appropriately).

Gonna play with Rule Machine now to make sure I like it and can do what I want. Sort of feels clunky to me, I like how webCore was almost like programming and laid out that way, felt more intuitive to me.

So far the best thing about HE is the community!


#16

Rule Machine is "different". It's not WebCoRE for sure, but it gets the job done. It's always difficult trying to use a new interface, but you'll start to understand it. If you're trying to do something, take a look, but don't spend your time fighting with something when you can throw your idea out to the community and get it worked out. And don't try to be all independent with it either. We're here to help. Not to judge, so please throw things out to the community. We use these problems to teach and to learn, and you will too. If you have your motion sensors placed to account for latency in ST, be prepared to relocate them. And, now that you have your focus on, I think you're going to enjoy this ride. Don't forget about the ability to use hub link. If something isn't quite there yet, you can keep it in ST until it is and use it from HE. Now that you have your focus on -> welcome to the rabbit hole. We'll see you on the other side.