A tale of two radio channels

Just wanted to share this advice with those starting out in Home Automation, since it can be confusing to have the Zigbee devices you connected to your hub either not work right away, or suddenly stop working. If you haven't reviewed this general information on How to Build a Solid Zigbee Mesh, I encourage you to do so.

It's important to remember that no matter how advanced we think our wireless technology is, they are still all just radio waves. Electromagnetic Waves of energy passing through space and prone to disruption. The electromagnetic spectrum behaves similar to light waves. When EM waves encounter an object, they are either transmitted, reflected, absorbed, refracted, polarized, diffracted, or scattered depending on the composition of the objects they encounter along their path. Yesterday, I was reminded that the 2.4 GHz frequencies that coexist in our dual-band WiFi routers and access points can indeed conflict with the 2.4 GHz global standard frequency of the Zigbee radio in our hubs.

My router (TP-Link Deco M5) is one of the popular Mesh WiFi systems that while simple to use, shields the end users from information that quite frankly most of the general public wouldn't know what to do with. Since I do know what to do with the advanced information, and started experiencing unexpected slowdowns on my WiFi network, I opened the router app to find some answers.

To give you an idea of how unexpected this slowdown was, I cannot recall caring about what WiFi channel my router was using for over two years now. So when I opened the app to find there isn't a place to see and manually change which WiFi frequency my router was using, I wasn't all that surprised to learn that in some update along the way, that information was removed and instead replaced with an automatic network optimizer that looks for issues and offers suggestions. In my case, the results provided a simple message "Your router is using a crowded channel" and gave me the option to fix the issue with just a button press.

So the geeks that feel they have to know what channel their router is using, and insist that the control needs to be in their hands are likely shuddering at this point of my drawn out story. But there are two important points to remember.

  1. It's possible to make the wrong choice in trying to adjust the WiFi channel yourself, so you're often better to just let the router software decide this.
  2. If you do want to know what channel the 2.4 GHz radio of your router is using, this isn't hard to find out with many free apps available.

So after letting the router automatically adjust the channel, but only on my approval (This is a feature I do appreciate), my WiFi speeds dramatically improved. End of story right? What the heck does this all have to do with your home automation? Get to the point man! The point of my tale is that when my wife went to turn on our kitchen lights (Sengled) that have been paired to my second HE hub on Zigbee channel 20 for about a year with no problems at all, they suddenly would not respond. Cycling the power gave control back, but it was short lived and they again went unresponsive when we tried to turn them off a second time.

Here's where you need to go back basics and carefully examine what in your environment has changed that might be responsible for the cause and effect.

  1. How are most home automation devices controlled?
    Answer: Radio waves

  2. What changed in my environment recently?
    Answer: The channel of the radio waves that operate within the same frequency range of the device that I'm having trouble with.

  3. Can the channels of two separate radios operating in the same frequency range interfere if they are overlapping?
    Answer: Yes. Doesn't mean they necessarily will, but it can happen.

Step 1: Remain calm. Your spouse might be giving you sideways looks at this point, but this is par for the course with home automation.

Step 2: If everything was working fine but now is not, Carefully examine what in your environment has changed that could logically interfere with the operation or stability of your devices. Check which frequency your router 2.4 GHz radio is using. If the router software doesn't provide this info, then iStumbler for Mac or WiFi Analyzer for Windows are good and free choices.

Step 3: Try changing the Zigbee frequency of your hub and see if the issue is resolved. You can always change it back if things don't improve or get worse. There's some choices which, depending on your devices you may not want to make. If you're not sure and changing the frequency causes further or continued issues, check with the community. There's a wealth of experience here regarding which frequencies work well with specific devices, and which ones do not.

So after changing my Zigbee channel from 20 to 17, my Sengled bulbs had full functionality restored after a power cycle and all has been well since. For those curious, my WiFi router software chose channel 6 for the 2.4 GHz radio (not sure what it was on before since I forgot to check), but changing it definitely caused the problem. My other hub is on Zigbee channel 15 and was unaffected by any of the changes.

Now there's one final piece to my unexpected puzzle that wasn't a prime cause, but certainly was a contributor. After changing channels to improve my WiFi speed, breaking and subsequently restoring operation to my Sengled bulbs, I was still not getting the best from my WiFi network that hadn't previously been an issue in the more than two years we've own it. The cause was another lesson re-learned. This time of year, you might be tempted to pull out that old unused WiFi plug for the Christmas tree. Yes, stupid as it was, a cheap Switchmate WiFi plug that seemed harmless enough, bit me once again. I had forgotten (yep, again) why I stopped using these, other than they are cloud only. They're garbage! Shortly after removing them, my WiFi speeds returned to normal! :crazy_face:

Wishing everyone a happy holiday season. Enjoy your home automation, but don't forget to stay clam and laugh at your mistakes. It's the best way to learn, even if you later forget the lessons learned and repeat the error. :grin:


I had a very similar experience. I switched my Zigbee to 15 from 20 about 6 weeks ago to see if WiFi interference was causing the Zigbee inconsistencies. and it made it a big difference. Then about a week later, a firmware upgrade to my Deco M5 system touted new "Optimized WiFi" process so I ran it without thinking. The Decos changed the channel right on top of Zigbee 15 so back all of my Zigbee devices went to 20 and everything is running smoothly as ever.

I use Wifi Analyzer app to tell me what channel Decos are using.


Seems an appropriate moment to repost this ...


Food for thought, many using Hue bridge may forget that it too runs on 2.4ghz. This adds another layer of complexity when selecting the right channels. For example my Wi-Fi is on channel 1, my Hubitat is on channel 20 (Zigbee) and Hue on channel 25 (Zigbee).


This. 100% this.

And I agree. Always, and I mean always, stay clam when you make a mistake!