2 Days Into This and Disappointed

Coming from ST. I agonized for months as to switch or not. When the price dropped on the Hubitat Hub I got one. Spent the last 2 days just playing with it to get familiar. I have only connected a couple devices to see how things work. So far been having issues. I had no trouble setting up the hub to start with, or pairing the couple devices. That all went great.

  1. The web interface seems to get slower the more I use it. When I first go into it it is fine. The longer I do things the slower it gets. I can exit out, wait a few minutes and it will be fine again. Not a major issue, just annoying.

  2. Created a Simple Lighting scenario. Turn on outlet at 9:45 PM. Turn off at 3 AM. It Turned on fine. Never turned off.

  3. Created a couple simple dashboards to monitor. Then created links on my phone home screen for easy access. Tried both local and cloud. They work fine at first, then quit updating. I can access them thru the dashboard menu and status is accurate. But the links on the home screen won't update. I tried a SharpTools one for comparison. It works fine.

So help me out here. What am I doing wrong? I'm afraid to go any further till I know things are going to work.

I'm experiencing this also. Trying to pin down what is happening myself. I can make a new link for the home screen and it works fine, but after a few days it is unresponsive. Accessing the dashboard through the dashboard menu always works, but home page links seem to expire.

Welcome! :slight_smile:

Need some more information... What type of devices have you paired to your Hubitat Elevation hub? Did you check the "Past Logs" to see if they show anything at 3am? How strong is your mesh network? With only a few devices paired, your zigbee and z-wave networks are probably weak at this time.

I have a few dashboard cloud links on my iPhone's desktop. They have always worked reliably and consistently. Are you sure you saved the "cloud" dashboard links to your home screen? You can use the "local" dashboard links only when your phone is at home, on the same network as your HE hub.

1 Like

Welcome to Hubitat!

  1. you shouldn't be having inconsistent response times. My web interface has always been consistent - it's not instantaneous response, but it's never been slow. Not sure what the issue is.
  2. Can you please take some screen shots so that we can help you as to why your light never turned off? In general, the Rule Machine is the outstanding feature of Hubitat, so you shouldn't be having any issues with it. Did you use simple lighting or rule machine?
  3. I use sharp tools myself, but I haven't heard that the links won't update. So, I'm sorry I can't comment on this one.
1 Like

So far the only things I have paired is a Sengled Bulb, A Nutone light switch, and an Enerwave outlet. It is the outlet that didn't turn off. I can turn it on/off from the portal no problem. I used Simple Lighting. The logs show That the status of the outlet was checked at 3 am was shown as on.

I have tried both Cloud and Local links. I'm using an Android phone. When I first put them on the screen they work fine. But after an hour or so they no longer respond.

Not sure what screen shots for this. I am using Simple Lighting not rule machine. It's a simple on at 9:45 pm, off at 3 AM. Came on just fine, just didn't shut off. I shut it off at 7 am using the portal web interface and it went off just like it should.

1 Like

I know the hardware between the "old" and "new" hubs is supposed to be identical, but I wonder if it would be helpful for the people posting about slowdowns to distinguish which hub they're using. There were a few complaints on reddit about the hub slowing down, and my hub is kind of all over the place regarding performance. It's completely common for it to take up to a full minute to load the page if I click on device details - even for a virtual device. I replaced the hub once thinking I got a defective one, and while this one has been a bit better than the old one, it's still random.

I see the OP mentioned having z-wave devices. I do think the hub has slowed as I've added z-wave devices. When support looked at my first hub, they said there were some "ghost" devices on my mesh causing issues. Didn't really give much detail besides suggesting to reset/wipe the radio. On that first hub, I had instances of the z-wave radio disappearing, and attempting to reset the radio didn't actually do anything (all the devices remained). I'm kind of wondering if there is a radio issue with some of the new hubs and z-wave. Running a z-wave repair does seem to speed the hub up for a while, but it doesn't make any sense to do that repeatedly when nothing has changed.

My experience across two hubs has been that I just can't believe that anyone would ever gush over how snappy and responsive Hubitat is, so I have to believe there's some kind of issue for some of us.

1 Like

Did you edit the SL rule by chance? Sometimes it can get wonky if you change devices etc and don't save - at least in my experience. Try and recreate the rule. Maybe set up a test one that works for 5 mins or so just to see.

My SL rules are working fine for the most part on both my hubs.

This might actually be a problem with the browser and websockets and not the hub itself. I've written tons of apps that utilize websockets (as the dashboards do) and on some Android devices, the websockets time out due to Android's battery management. In short, if your phone is putting your wireless connection to sleep, that would likely cause the dashboards to not update as the websocket connection is getting closed and not reopening again.


I'm pretty sure the wireless is not going to sleep. What I am trying right now is I excluded Chrome from battery management to see if that is the issue.

My web ui is almost always "slow" compared to other local devices. However, the speed that I "gush" about is local execution of my devices and rules. Does a light come on nearly instantly when I walk into a room or open or close a door? Yes.

Honestly, I could care less if the web ui takes 1-2 minutes to load as I'm not in it enough to really care. On average, I think I spend about 2 hours a week in the actual web ui itself. Once my devices are setup and my rules are created, I don't have a reason to go into the UI to really do anything.


By the way, Please don't take what I am saying wrong. I am committed to making this work. Just trying to figure out how to do it. I have time to play with it as my ST is working ok now. Main reason for switching is not sure where ST is going and want to be prepared.


That may or may not work. I believe what you need to do is go into your WiFi settings and set "Turn off Wi-Fi automatically" to false. But, my phone is running Pie, so they changed all the Wi-Fi power settings (again).

Mine is set to keep wifi on always. So that not the issue.

I did a test one as you said. It worked fine. I changed it back will see what happens tonight.

You might want to create a new one just in case..

1 Like

Well when I excluded Chrome from Battery saver, the dashboard things seem to update. Maybe a coincidence, I don't know. I will continue checking and see what happens.

I think I need to go back to typing school. Had to edit twice to correct my typos..:slight_smile:


Perhaps that might be it. If Chrome is being put to sleep, then the socket connection would time out and might not be able to reconnect it successfully.

@patrick : Crazy question... in the dashboard implementation, are you guys handling ping/pong of the socket connection and or specifying a timeout of the client connection?

The answer is coffee. Always coffee. :smiley: LOL


Those of you with Android phones/devices may want to try using the Brave browser. I have it running and setup to automatically use the desktop version of my dashboard (unlike other browsers, which default to mobile versions). I have zero issues with my dashboard loading or refreshing.


Thanks for the suggestion! I’ve been on dolphin for my dashboard. I’ll give Brave a try.