[] Repair is locking up my hub

Hello, I have updated to .155 and ran a repair on 1 individual device, it locked up my hub and I had to power cycle to get anything back. I waited 1 hour and tried a whole home repair and it locked up again on the 1st device. Both times it said restarting SDK component.

Another build is coming that should fix this behavior.


@bcopeland I am still having the same issue on .156. It no longer says restarting SDK, but it locks up my entire zwave and have to power cycle to get it back. Same thing every time, gets to assigning route 5 on the 1st device and then locks up after that and nothing responds.

What is this node?

Aeon 7 repeater, never had any issues before.

I suggest a reboot..

Then exclude and re-include this node.

I suspect when these nodes get into a state where they can no longer complete a repair, that their resource database entry in the SDK is corrupt.

1 Like

That is the main node in my house, that is going to crash my mesh if I do that. 90% of my devices are routing thru that node.

@bcopeland FYI, I have removed all Aeotec V7 repeaters from my setup. After moving from legacy GE to Inovelli it seems they were made obsolete.

Perhaps the method used to migrate from C5 to C7 might work: swap device w/o loosing automation

These are repeaters only, zero automations.

But they still have to be joined. So I was thinking you might be able to follow the same procedure and not loose your mesh. Not sure, just a suggestion.

I appreciate, but after removing mesh came back in 10 min, just had to refresh each device.


@bcopeland I need some assistance please. I have removed the repeaters, and I have upgraded to .158. I cannot get repair to run properly, it still locks up my hub and I have to power cycle to get it back.

Can you post logs from 158 for this?

Same thing as before it get stuck on assigning route 5 and then locks up the hub. I let it sit for a min before I ended it. But I know it was locked up as all zwave stops functioning.

Ok.. is this every device?.. or specific ones?

That I don't know. I just ran a repair on 1 light and it ran clean, but I could run it on the next one and the hub could lock up. Is totally random. If I run a Full repair it has not gotten past the 4th device.

I have also noticed that my connnection speeds have gone from 100 and 40 to majority 40 and 9.6 since I removed the repeaters. Am I now having a weak mesh issue? Do I need to put the repeaters back?

It’s possible.. I was originally asking for an exclude and re-include as to clear any SDK resource directory issues.

Do you recommend I put it back? What could cause the lockup?