[] HomeSeer 200+ Dimmer Driver LED non function [C7]

I’ll check it out

1 Like

When you look at the driver could you see if/why the dimmer indicator lights are enabled if the statues LED's are all OFF?

  1. When the Preference "Enable Status LED's" is NOT Selected. White lights show the dim level.

  2. When the Preference "Enable Status LED's" is selected. The above White lights show the dim level if all Status LED's are off. Then when at least one Status is set to ON, the above White lights extinguish.

Makes it difficult to meaningfully use the status lights.

This is what drove me to the codahq driver originally and even that there needed to be an additional preference added.

I was playing with that setting. Here's my log when I toggled that setting Off and then on again...

2020-11-20 07:07:02.339 pm [warn]( logging is: true

2020-11-20 07:07:02.335 pm [warn]( logging is: true

2020-11-20 07:07:02.331 pm [info](

2020-11-20 07:06:49.957 pm [warn]( logging is: true

2020-11-20 07:06:49.953 pm [warn]( logging is: true

2020-11-20 07:06:49.949 pm [info](

Notice that there is no log of the LED Status changing. Though, the setting is persistent in the settings UI.

Either way, the white dimmer lights are always enabled on mine.

@JohnRob, why did you switch away from the other driver? Was that because he pulled it from Github? Or did you just want to try the internal one?

Or did they use his code for an internal driver, and the latest update broke something?

I literally just started using this today, so I am not up to speed.

Pulled from github doesn't directly bother me, unless I find out there was a functional reason. Many drivers are put on github and unless there are immediate shortcomings are never updates. Likely many never need to be but if they do the author has already moved on to other projects.

I prefer to use the internal driver if possible. It is sure to survive updates and be maintained.

I have no idea what goes into the internal driver. Likely some of the community code if it follows the style of the Hubitat drivers but I could be a modified existing driver with some function enhancements.

@bcopeland FWIW when I was using the custom command setstatusLED the inputs were strings not numbers. At first I thought it was odd, however not so odd as to look to understand or change.


To add to your post, when I was running v2.2.3 and using the built-in driver, I could change the statusLED from either a Rule or Device page. Now running v.2.2.4, I get the errors in my log when attempting to change the statusLEDs from either the Device or Rule.



If this helps, I turned on the debug logging for the device control.

Here's the entry when I tried to set Lead #4 to blue... The values in the log entry are reversed (for led# and color).

Someone else mentioned that another app was controlling them correctly with the built in driver... So maybe it's just the UI for the device page that's got an error?

2020-11-22 02:50:28.010 am debugled:blue color:4 blink:on

1 Like

@ArchStanton... great catch using debug. For me (as shown in my previous post), both of my errors came from the Device page and one of my Rules and both worked with v2.2.3. So based on that and you debug info, I suspect the issue is with the built-in driver but I'll defer to @bcopeland

Looking into this now.. .while I wait on another device I'm debugging to stop working..

1 Like

Take your time! I appreciate it!

(I'm sorry I'm so new here I don't know where to look to figure it out myself. And I'm still building my mesh!)

1 Like

Well.. Welcome to the community..

From the report this appears to be a driver bug, so nothing you could have done except report the issue.. It’s on us to fix it..

Found the problem on this.. Fix will be in the next hot fix release..


@bcopeland... I just upgraded to v2.2.4.147 but am still getting a error (though it is different) while trying to set one of the statusLED via the Device page.



I just added more info to this post Homeseer HS-WD200+ Issues and have half my problem resolved. Going forward and to avoid confusion, I'm going to post future info on the other post.

There are two threads about the current issue with the HomeSeer 200+ dimmer. This thread and this thread.

You might consider combining them.

Happy Thanksgiving :slight_smile:



Still cannot control the front Status LED's on my HomeSeer HD-WD200+ dimmer. I had control of them a couple of days ago but lost control somehow.

I am currently using and the built in driver.

I have:

  1. used BoristheCat's Clean Driver to delete any status variables.
  2. powered the hub OFF, then restarted.
  3. reassigned the internal driver to my dimmer.
  4. saved and pressed configure.

Not when I try to change an LED nothing changed on the dimmer and I get the below debug message:

This message seems to indicate the command to the LEDs has the variables swapped.

There is no LED named "OFF" I believe the LED number (1 - 7) and Color entries are reversed.

More trials:

The last entry (top row above) was from Green, 1, 0

Also notice the annoying popup hint issue.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.