Homeseer HS-WD200+ Issues

At the bottom of this is a question about getting the LEDs to work in the basic device control.

First off, Just a bit of info... There doesn't appear to be an exclusion for this device. So to join this network, I followed their instructions to reset it... turn it on, they 3 quick taps up and three quick taps down. The light flashes and then it's reset.

I added it in Add Mode and then tapping once on the On side of the paddle. This, however, brings up a security dialog. As this is installed in my wall already and I have no desire to complicate things with heavier security on 2 lights out of 40 at my home, I tried to clear all the entries. But then it never adds the device.

So I used the 3rd option... Which I forget the name of, but it was the low level of security, but un-authenticated. The next screen asked for an ID (presumably on the back of the device in the wall)... I just said NEXT without entering anything and it worked.

Now I can control it as a dimmer. But the Device Control page has options for setting the LEDs. But I cannot get it to use the LEDs for status, let alone set them. They are always set to Dimmer level. IIRC, in SmartThings WebCore I had to run a command to put them in Status mode... and there's a switch on the HE page... but it doesn't seem to do anything.

Anyone have any ideas?

(I see that this might have been based on a device handler that was withdrawn by codahq. If there needs to be some work on this, I MIGHT be able to help.

It sounds like you included the device with S2, which is fine except that I don't know if Coda's driver was written to support that (it's pretty new to Hubitat, and what you'd see are commands failing to send from the hub to the device). Someone asked about this in a thread recently, and I did a bit of work to port a SmartThings driver someone found:

Alternatively, if you don't need all the extra features (e.g., all five taps), Hubitat has a built-in driver that should work for you too. Maybe one of these ideas will help!

Not sure how much help this will be to you. I'm still using the codahq driver and am able to address the status LED's via a custom call. My code is:

image

I've never used the built in code because I have an issue with the operation of the dimmer lights. I wanted the dimmer lights completely disabled.

I will have to try the built in driver.

Regarding S2 inclusion. I recently moved from my C4 to C7. I paired my devices with the "default" security. My 200+ is still working with the codahq driver.

1 Like

OK now that I said my 200+ was working great...... an hour ago it should have turned on (via a RM rule). It did not. Haven't looked into it yet. The only thing I did was update the Hub firmware :frowning:

My HE is brand new, I believe it's the C7.

Brand new would be C7. I just ran another rule that should turn off all the LED's on the 200+ . It did not.
However another rule was to turn on one led Blue. It was successful. I'll have to see what is going on.

@JohnRob... curious if the default driver will support the status LED's like in your rule

It should but currently the internal 200+ driver is broken (at least for me). I can't even change the LEDs from the driver page. bcopeland is looking into it.

I'm confused. Why did you switch from the cohahq driver?

It gave an error in the ON/OFF function. As you told me it was pulled from github I didn't think it was worth troubleshooting. So I went to the built-in driver.

Ah. Yeah, the built in doesn't seem to work on the Leds at all.

I haven't looked at custom device handlers yet on this system. But probably something I'll take a gander at while I'm waiting for my mesh to settle.

@ArchStanton... when I ran v2.2.3, I was able to set/change the status LED from the Device page but now after upgrading to v2.2.4, I get the error below when I attempt to set the status LED using the built-in driver via the Device page. Is this a bug in the latest driver or am I missing something?

Capture

@ArchStanton

I've already notified Hubitat of the issue. bcopeland said he was on it so I'm confident it will get resolved shortly.

Huh. I actually got the same error with one of my simple lighting motion automation (using the stock automation app).

Might be that the new firmware has a bug defining some enums?

I used this and got them working

Hey, thanks for that! Looks like a well-written version of an ugly Webcore piston I have for ST!

But is it working on the 2.2.4 firmware? The notes said it uses the built-in driver, but that's apparently what's causing problems right now. (I could be wrong, I haven't set up a custom app like that yet)

I just updated the firmware prior to installing this. Working as expected so far.

edit:

C-7 on 2.2.4.145
Homeseer HS-WD200+ with the HS-WD200+ built-in driver

Using the Switch Dashboard app and child app from the link by MFornander- I haven't altered them. I actually haven't even looked into the code yet but they are working as expected.

I have what I think is a related issue. I have quite a few of these dimmers. I have a C7 hub and originally added them all w/o S2 as that didn’t work until 2.2.4 came out. Most of the switches are firmware 5.11. I can’t get double or triple tap to register. Nothing shows up in logs, nothing in events tab and nothing when a rule is defined. I’ve tried the following things (it’s pretty central to my set up to get this working)

Update to withdrawn driver (I found it on GitHub)
Switch back to build in driver
Upgrade firmware on switch to latest 5.14 (this was an epic pain, buy software from Homeseer, find a windows machine in my junk closet, set it up and flash them, but I did it)
Readied the switch with s2, tried both drivers again
Removed a switch from my network, added it to openHAB, verified that it sees all tap events right away.
Readied with S2
Try the new driver by @bertabcd1234 (this just this morning)

I swear that one of my switches did double tap at one point, but at this point none of my 2 and 3 tap rules are working. I noticed this morning that led color setting is not working either (which I think is mentioned here that @bcopeland is working on?)

It also seems like I don’t see events for on / off without hitting the device refresh button, but that may be normal and just an artifact of my staring at it too hard. I’m happy to help debug

This is fixed in the next hotfix build

1 Like