[1.2.4 build 126] [2.3.0.112] Dashboard Variables not Authorized

On the local LAN. Get this regardless of the path chosen to get to the dashboard.

Tried looking this up earlier, is there a step to authorise variables, like we do for Devices? I'm asking this without any experience or knowledge myself.

Same place you do the devices - dashboard child app.

1 Like

Only in 2.3 platform version...?

It might be present in 2.2.9 but wasn’t functional.

No worries, just haven't made the leap yet... Can create a Hub Variable in 2.2.9 but can't choose it for a Dashboard in the child app settings. Not related to the issue you are trying to solve.

Seems to work for me, both from Hub admin UI and from mobile app. Here it is on the mobile app, connected to my C-5 Dev hub (2.3.0.112) via the mobile app (1.2.4, build 126) on the local LAN:

When you authorized the Hub Variable for the Dashboard, did you click Done? That’s easy to miss if you have to scroll down a long list of variables.

I set up the variables last night for testing the browser interface under .111 and .112. Browser interface works, but the mobile app not so.

Perhaps it depends on the type of the variable. I didn’t try all the possible variable types, and I don’t have Hub Security enabled on the Dev Hub, if that matters. I just tried a simple Number variable, which showed up on the Dashboard Add Tile screen as an Integer. :man_shrugging:

Now, because I was testing both browser and mobile app use, all testing was done local LAN on the browser, except for the Add Tile, which was done both on local browser and local connected mobile app.

This was an issue when using legacy links for dashboards, but it should work for both now.

1 Like

I can confirm that this is now working.

2 Likes

Download the Hubitat app