Zwave Yale lock - YRD210

I have the YRD446 (keyless) and it sure seems that locks and garage door openers are the trial-by-fire devices. Mine paired effortlessly on ST, which is a common claim. It paired at a distance too. Moving it to HE was torture because it's just as you said.. try this, try that, try 20 different things, it always pairs but never securely. I tried it with the hub a good distance away, just like it was when ST worked and it didn't work. I removed the lock from the door and brought it up next to the hub. Didn't work

Eventually I gave up, mounted it back on the door and moved on to the long list of other devices that needed to be migrated. I guess (no really, just guessing) that the time interval allowed the devices surrounding the Lock to get themselves fully initialized because when I tried it an hour or more later, with the Lock mounted on the door and the Hub in it's normal position, it worked.

My guess is that one of the devices that are under 3 ft from the Lock, got it's "Beaming" feature up and running and was able to assist as intended.

Your Lock supports beaming.

1 Like

Too bad. Yes, I would guess it's not going to work if you have to push on your door at all to lock. My front door is perfectly aligned, so I've never had powered lock issues. The August on my back door struggles sometimes, but has the right gear ratio to push through. Guess the Schlage 469 does too.

1 Like

Where is the hub in relation to the lock? Have you tried bringing the hub VERY close to the lock? Like within 5 feet? I keep a long network cable around just in case i ever have to do something like this. It might just be too far away to get a secure pair.

@stephack Thank you for sharing a couple of trustworthy locks. I'd definitely prefer the free option of using my existing lock, but I'm not completely against buying a new lock and appreciate the suggestions.

@csteele Very interesting. I'm basically giving up for now and moving on to other devices as you did. I'll definitely try again after a few days and hopefully get lucky too. I actually have a Z-Wave switch within a foot of the lock, so maybe it will handle the beaming after the network settles down. When you finally got yours to work, did you simply pair it again, or did you do a factory reset first?

@Ryan780 The lock started out 15 feet from the regular hub location. But I used a long network cable and held the hub within 1-2 inches of the lock a few times yesterday and it still didn't pair securely. Tried the same thing today after reading some of the suggestions earlier in this post, but still no luck.

I don't remember ever doing a Factory Reset on it. It has that menu and won't even offer up an Include option if it's already included. That allowed me to be certain I had excluded it. I'm pretty sure I would have been using my Aeon Z-Stick to that side of the exclude.

My memory of the event is that I a Recessed Door sensor that didn't pair properly and I took my iPad and Aeon Z-Stick to that area. I clicked the internal button on the Recessed door sensor and that got that going and then, since the Yale Lock is on that same door, I just did the Yale menu steps to #7 and started the include via the iPad to Hubitat and then pushed the Gear icon on the Yale. I almost fell over. It worked. So I pivoted and walked over to the OTHER barrier device I was having trouble with: Linear Garage Door Opener, and was hurting myself with grinning too much, because it too worked.

I have a YRD210 deadbolt and I have had a time trying unsuccessfully many times to get it to pair secure until I found your post. I saw you wrote:

I noticed you didn't mention hitting the number 1 key first in that menu. I tried this tonight and finally it paired secure doing this. It's the # key instead of a gear on my older lock but I just pressed it without pressing the number 1 key first. I even did this without removing it from the door and taking it to the Hubitat which is about 15ft away through one wall. So just want to verify that this worked for me as well and hopefully will help someone else.


I’m having the exact same issues with a Yale Lock. This one to be precise:

It seems nothing I do will make it pair. I’ve tried moving the hub as close as I can. I’ve tried factory resetting the lock - I’ve done everything recommended in this thread and the other but ultimately It doesn’t seem to want to pair fully. @mike.maxwell do you guys have one of these devices to test with?

Yeah I had trouble with an older Yale keyless lock AND the YRD256 - ended up changing the radio module to zigbee and things are working much better. Don't think you can do that with the older lock though.

I found a refurbished Zigbee module for my YRD210 on eBay and made the switch, and it has been working fine ever since. Somewhat annoying to have to buy the other module, but $60 was certainly cheaper and easier than a new lock.

No, we don't have this one.

I was pretty much at a point that I was going to replace the lock after several failed attempts before it finally paired secure on that last try. I can't say it was the "key" (no pun intended) to getting the lock to pair, but on the last step after pressing the 7 key to get into the paring menu, I just pressed the # button without hitting the 1 first. From what I had read, the older non Z-Wave Plus locks are hard to pair. I had no issues with my newer Z-Wave Plus lock which is a YRD226.

I thought I would add my experiences here today that I went through with the YRL210. I did not succeed. I'll just get that out of the way right now.

I tried all possible combinations of the following:

  • Excluding the device with Hubitat (doesn't work)
  • Excluding the device with Ring (works)
  • Excluding the device with Zensys Tools (works)
  • Excluding the device with HomeSeer Z-Flash (works)
  • Adding the device with master code, #, 7, #, # (fails)
  • Adding the device with master code, #, 7, #, 1, # (fails)
  • Adding the device to Ring (works... from same location. No movement necessary.)
  • Adding the device from Zensys Tools from 1 foot away (fails S2 but joins insecure)
  • Adding the device from HomeSeer Z-Flash from 1 foot away (fails S2 but joins insecure)
  • Rebooting the hub
  • Repairing the Z-Wave network
  • Disconnecting all of the nearby nodes from power

I have performed all of the above steps in pretty much every combination they could be performed in. Of course I used just one type of action e.g. 1 exclude and 1 include method. I have literally been at this for 7 hours.

Given the fact that it can join Ring's hub instantaneously and that it can't join the hubitat USB stick from any software platform I think this is clearly not a hubitat issue. It's probably still a neighbor issue or something. However, I would love if somebody from hubitat could help me figure this out.

For the most part all of these Yale Real Living locks really only use two different Z-Wave devices, right?

Old AYR200:

New AYR202:

If we can figure out why they won't join we would be covering a lot of ground aka we'd have all of the level, button and touch Yale Real Living locks covered.

What else can I try?

The lock probably isnt S2, but using zensys and homeseer it didn't fall back to S0?
If it fails to join using S0 under zensys or homeseer, then there's something wrong with the device standards wise...

Are they allowed to do things off standards if it is certified? The log message just said joining device insecurely in both and it did so after hitting some time limit. I don't remember the exact message. Right now it's hooked up to the Ring hub but I will try it again with the USB stick and get the messages if you want. It didn't mention S0 specifically but I guess it could mean S0 if the developer of those tools considered S0 insecure. I just assumed insecurely meant without S0 though. I don't have any real experience with those softwares besides what I did today with them to try and troubleshoot this. If I can get more information from them let me know.

Also, since it's hooked up to Ring right now I can see that it is connected directly to their hub and it not going through any repeaters. I'll just dump what I can get about it from the Ring side.

        "address": "${this_nodes_mac}",
        "fingerprint": {
          "extraVersions": [],
          "firmware": {
            "subversion": 32,
            "version": 72
          "hardwareVersion": 0,
          "libraryType": 3,
          "manufacturerId": 297,
          "productId": 1033,
          "productType": 3,
          "protocol": {
            "subversion": 34,
            "version": 3
        "homeId": "${home_id}",
        "nodeId": 39,
        "reconfigureState": "idle",
        "routeSpeed": "40kb/s",
        "rssiTimestamp": 1557186434049,
        "signalStrength": [
            "nodeId": 1,
            "rssi": -73.0,
            "status": "valid",
            "zid": "${the_id_of_the_neighbor_node}"

I omitted the values under zid, homeId and address because I don't know what you might be able to do with them against the private Ring APIs.

What I'm seeing under the certification doesn't match all the way what I'm seeing from the API though.

The cert says it supports S0 but not S2 like you guessed. Is it weird that the module is interchangeable yet they certified the lock as a whole and did it with all of the locks that use the same module?

I can also join this to ST if you want me to get info from there. It's reportedly working without any issue. I will probably confirm that next time I remove it from the Ring. My wife was getting frustrated with me though.

Insecure is insecure, ie not S0 or S2.
Standards compliant?, I'm not sure what that means in the end...

Thanks for trying, but that won't help, this is one of those devices that I would need in hand to sort out...

Oh boy. I just got my Hubitat and I'm about to move my YRD-220-ZW619 (from 2013) lock over from my Veralite. This topic has made me wonder if I'm better off keeping the Vera just for the lock. Is having two hubs an issue besides being really annoying?

I was also hoping to be able to set up the Yale to be able to arm/disarm the Hubitat via a code entry.

I have found that getting a couple (or 3 in my case for 3 locks) has significantly reduced and almost eliminated (only 2 days adding them so time will tell with settling down my mesh) the zwave lock issue. Plus Hubitat's driver guru (the guy in the post directly above) is working on this on their end as well.

I think you have to try it. You can always move it back to the Vera. :slight_smile:

I have a Yale (year older model) and it took some time and multiple attempts, but it did join. And has been 100% ever since. A good Beaming Repeater on a good mesh seems to be the recipe.

The Aeon Range Extenders mentioned are one of many Beaming Repeaters. I actually don't have one, BUT I do have 3 in-wall devices nearby.

1 Like

This! Yale guide specifically says 1 then # which does not work. Good catch.

I noticed you didn't mention hitting the number 1 key first in that menu. I tried this tonight and finally it paired secure doing this. It's the # key instead of a gear on my older lock but I just pressed it without pressing the number 1 key first.

1 Like