Zwave Switch On/Off Status not Updating in Hubitat

I have a Leviton DZ15S switch that has been working fine in Hubitat for several weeks now. Today, I noticed its status was set to "On". I tried turning it off within a dashboard tile and all I get "Sending..." message. Only way to stop this is to exit that dashboard. I tried to turn it off directly from within the Devices menu option and nothing appears to happen. It always shows as being "On"

I checked the physical device and it is responding to Hubitat On/Off commands so it appears it works but Hubitat is not changing or getting a status update.

I have been using the Generic Zwave Smart Switch DH but also tried the Generic Zwave Switch DH. No difference.

I tried a Zwave repair on just that device as well as a hub reboot. No difference.

Other than excluding/including this device, are there any other option I can try?

Hubitat Elevation® Platform Version -
Hardware Version - Rev C-7

As I recall the Smart DH is for Z-Wave Plus, the Generic (w/o "Smart") is for regular Z-Wave. (Not a solution - just information)

1 Like

Yup, this switch is a zwave Plus.

Can you air gap the device?

The Z-Wave Plus switches and dimmers are usually good about reporting status.

Ok, I found a post of someone with a similar problem which (s)he solved by turning off then on the circuit breaker for that switch. What do you know. It worked. Sure like to understand why though and why only the status updates were not working. :roll_eyes:

If more convenient, pulling the air gap for a moment as @thebearmay mentioned should do the same thing.

Not sure what that means??

Some dimmers and switches (GE is one, as I recall) have an air gap tab you can pull that removes power to the switch without having to switch a breaker. The tab is accessible from the front of the switch or dimmer.



Doesnt look like the DZ15S has this tab. Oh well. I have a workaround. Just hope I dont have to use it too often

1 Like

Did you see this thread?

No I did not. After reading through it it apears lots of people had the same problem and most claim a FW update solved the problem. I cant seem to find a FW version number anywhere in the device description so I dont really know if I need to upgrade or what :frowning:

There is a built-in Hubitat app called "Device Firmware Updater" that might let you query the device for FW version. Or maybe even update it, if you can locate an update to download.

1 Like

Yeah, that is a real problem. Tons of posts in multiple forums talk about the update process and different versions but none have a link to a download server. Leviton website seems useless or at last absent of any FW downloads. :frowning: I may have to bite the bullet and talk to them :stuck_out_tongue_winking_eye:

Yup, that worked. Seems I am on V1.18 Most of the posts on this subject discuss v1,4n I even found discussions on latest release o v1.7n but no download can be found :frowning:

BTW: The Device Firmware Updater is a really good tip. Hope I remember it next time I need to find a FW version

1 Like

Yeah, that was a step too far for me, lol. Although maybe they keep the download link private and will tell you it once a ticket is open?

In any case, I am now an Inovelli addict.

Try this link

When I extract that, it is supposedly version 1.20 for the DZ15S. I have none of these switches, so I cannot verify what version this actually is.


Thank you for the link.

Yes, it appears to be 1.20 but on all my research, I am 99% sure there is at least a v1,4.3 out there. I did find a link to v1,4.3 but that appears to be for the wifi devices. If I cant find anything higher I just might try to install v1.2

Wow.. Kudos to Leviton Support. Got an aswer back from them in under 15 minutes. And yes, the file you linked is the one I should be using. I guess the 1.4.3 must be wifi exclusive.

UPDATE: Upgraded to V1.20 using the SW neonturbo linked above. For me, it was a very easy process. Hopefully this will fix my problems.


Clarification need please.
When using the Device Firmware Updater, do you upload the whole zip file? Or do you extract it first and upload only a specific DLL?
I have a DZ6HD dimmer which happily is in that zip.