Zwave replace

I've just ordered some aeotec multisensor 7 to replace my multisensor 6's.
I'm thinking of removing the power to the 6's and waiting for the nodes to fail then using zwave replace to swap the 7's in.
Is this the best way? This way i dont have to edit all my automations.

Or have I got zwave replace all wrong.

That's exactly what replace is supposed to allow.. however, because of the difference with SiLabs certification, I'm not sure how the current replace code will respond when there's such a large model shift. 500 series vs 700 series. S0 only vs up to S2. The Replace process doesn't present the popup for entering the S2 code, thus my hesitation in saying it will work.

Replace is still a big-black-box to me. I use it, used it yesterday as a matter of fact, and while it worked, I only know it did because now I ignore what it says and validate it worked after the fact.

I have a Qubino dual relay device controlling the light and small exhaust fan in a bathroom. It falls off the ZWave network a lot. 3 times a year. Nothing else is like that in my home. I put the hub into Replace and occasionally it tells me Replace didn't start. Refresh, verify Replace is an option, click Replace, now it's running. The Qubino goes into Include/Exclude with multiple on/offs of the #1 attached switch. So I do that a couple of times, no indication of a success or failure on the Hub but eventually it says that Replace has stopped. I go into the Device Info page and I can control the light and fan once again. So.. I know it works, works well, but leaves a lot to be desired in human feedback :smiley:

2 Likes

This may help you: Migrating a Z-Wave Network

1 Like

So looks like suck it and see.... ooo the fun.

I also have a Qubino dual relay and it's the most reliable zwave device I have never skips abeat funny old world

1 Like

It does for me unless something changed in the last release? See Step 6, and I did this multiple times before I wrote that guide. Going from S0 to S2 though, that I have not tried. Replace seems to be most happy when you keep the same security which is unfortunate.

So it worked for 4 of them sort of.
They did replace but with no security and they seem to be confused with the 6's driver details?
The other one just never gave the replace option so i deleted it, it left a ghost node..
When i paired it gave the s2 option so I went with it but it paired as aeotec smart plug ..
Changed the driver to the multisensor 7 but it now has a Component Device : Aeotec Smart Switch 7 US - LED which I cant delete...

Switch to the driver just named "Device" and it has a command "Delete all Child Devices", you could delete all the states from there also to clean out any other leftover garbage if you want.

1 Like

Thank you saved me a couple of hours tomorrow.
Worked a treat

Download the Hubitat app