Zwave On/Off Switch (NZW30) not responding to digital commands

Strange one here, this switch is reporting directly to the hub, has 100kbps connection and the events are being logged in real time from physical switching, however the switch does not respond to zwave commands.

I have tried both the Inovelli driver (which was working until recently) and switching to the generic zwave on/off switch which gives the same result.

Anyone seen this before?

Is there some tap combination that might disable this? My toddler loves to hammer this switch as it turns the fountain on and off haha

Can you post your z-wave details page in it's entirety?

Sure, Ill have to do it in parts though:

This is the device in question:

And it doesn't turn on/off from the device page at all? What driver is it using? I see a few things struggling on your mesh (light switches at 9.6kbs) though that one certainly is attached to the hub direct.

From the device page there is no response to sent commands, however I can see the device state change as I toggle it on and off with the paddle.

I was using the inovelli driver, and I tried the generic zwave on off switch one this morning as a long shot to no avail.

you can see here it updating the event log on the hub:

Is this a new issue or has it always been this way? Is your z-wave stack updated? (separate from the platform update) (Working my way down the list). If this is a new development you can try shutting down the hub via the settings menu, unplug power to the hub (at the wall not the hub) for 5 mins and power back up. This will clear the z-wave radio in the hub. It may or may not help. Lastly you can exclude the switch, do a factory reset on the switch, then re pair it to the hub. What's weird, I usually only see this behavior in bad mesh's but since you're going straight to the hub I have to ignore that.

I'm not familiar with that switch, but if it's like some others, there are indeed some capabilities that can be programmed by various combinations of physical paddle mashes, so I would not rule out reprogramming by your toddler... But check out the manual and see if that's possible (and how to back it out).

Do you have the "Disable remote control" option turned on in the driver? This would do it. I don't think there's way to do it from the switch, but if there is, it's indeed possible a toddler figured it out. If you don't: maybe turn it on and back off to see if that helps?

Yeah these are the ones on the outskirts of the property, they work fine though

If anybody could, it would be my 3 yo hahaha!

So I dont see this options on the driver, I think I have seen it on some of my more advanced Inovelli Devices, but these are the only options I have for this basic switch

Just checked the manual found here and there is no mention of disabling digital controls via key combination

That looks like Hubitat's driver. It should be there in Inovelli's if I'm looking at the right model.

This is a new issue, I know it was working about 3 weeks ago as I cleaned the fountain and tweaked the pistons that control it. Im not saying that it is linked to platform updates but I have installed each update as and when it has become available and the hub is currently on

When you say stack update, are you referring to having the latest firmware on the end device? This unit hasnt been updated since I bought it so will likely be running the original fw.

I have tried several zwave repairs and reboots of the hub, I havent powered it off completely though. I will try it for the process of elimination though

Just installed driver from the Inovelli repository now I see more options:

The option to disable control from hubitat defaulted to No and I have tried toggling it on and off again but it still wont respond to commands sent from the device page :bamboozled

No. On your z-wave settings page do you see a z-wave firmware update button? If not then you've already done it. If you do do it then follow the power cycling instructions i outlined. Though I would also look at the disable remote issue that @bertabcd1234 mentioned. Also perhaps turn on debug logging on the device page. Also again factory resetting the switch is always an option.

Excluded and included again. Its working now. Crazy!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.