Zwave driver updater

I am trying to update a Zen 25 firmware. I uploaded the Z-wave Firmware updater and saved it in the from The built it app. I went to the device an under the Type is where I thought the driver would be. I scrolled down but the file is not there. I thought it might be were Zwave Basic Tool would be but no. What steps am I missing. I have the Zen 25-V2.00 zip file from Zooz support.

If you installed the driver to Drivers Code, it should indeed be listed under Type on the device detail page (which is the driver selector). Let's back up a bit:

  1. Go to Drivers Code and make sure you see it in that list. (You mentioned "app," possibly as part of a typo or copy/paste error because that sentence looks garbled, but it is a driver. It won't save to Apps Code, and you'll get an error if you try. Drivers will also not appear under Apps, as they are not related.)
  2. If you don't, try copying/pasting or importing the code again. You need to hit Save, wait a few seconds for the spinner (top right) to stop, then if you don't see any errors, you can close the page and re-verify in step 1.
  3. If all the above looks good but you don't see it under, Type then: (a) make sure you've refreshed that page (the list is populated on page load and does not dynamically refresh); and (b) ensure you're scrolling all the way down to User Drivers, which are grouped together at the bottom of the list, after all the built-in drivers--or use the search function to find it more easily.

If you managed to do this for Basic Z-Wave Tool, the steps for this should be similar, so I'm sure you can get it to work!

PS - You'll want to extract the contents of that ZIP file to get the actual firmware file before using it in the tool.

1 Like

To find the updater I went to github and found djdizzyd a 24.2 kb file. I copied the raw data. Next step would be to add it to the driver code. I click new driver in Hubitat and it asks for the url not the data. This is where I get confused. So I thought to just paste the code. That didn't work I got an error. Its been so long ago when I did the basic zwave tool like 3 years ago. At 74 I sometimes forget why I got up to go into the other room.

You can either select the Import button and copy/paste the URL, or you can copy/paste the actual code (not URL) directly into the large text field in the editor itself. It sounds like you're maybe combining those two and not exactly doing either. If you pick one method, it should work.

Than you. It is updating the firmware now but it has been 2 hrs, is that normal?

I tried again and it just says downloading firmware. There is no percentage and the cursor is blinking at the firmware otz file.

I would just use the built-in "Device Firmware Updater" app. It requires that you upload the firmware file to the hub directly instead of it pulling the update from the internet. Takes some of the complexity of the task out and has been very reliable for me.

That is a C7 only function. If OP has a C5 or earlier, you either use an external stick, or you use that community app. That community app is near identical to the built-in app by the way, both were written by the same person.

I don't know which hub the OP has for sure, but judging by the age of their account, they have a C5.

1 Like

Good point.

You are correct. I have a C5. The only thing Zooz support gave me was a zip file that contained the Zen25-v.200.otz I did buy a C7 but have not had the patience to convert my 30 or so devices.

If you get the hub protect package, you can backup the z-wave radio to the cloud and restore it to the c7

1 Like

Is it a click and go. Are there step by step instructions?

Yes, go to the documentation link then click hub protect. Easy step by step instructions. Make sure you do a full z-wave repair before backing up to the cloud on your c5

If you are going to do a lot of device fw updates, that is a great reason to have a UZB stick to use as a secondary controller...I've found FW updates via secondary controller are much faster (at least for the ones I've done, primarily w/iBlinds devices) than using the HE FW udpater app.

1 Like

Can you walk me how you use a USB stick? I have tried again the OTZ upgrade and it doesn't work.

See this How-To - follow the steps to get the PC Controller app (part of a larger suite) and then you can use it w/a UZB stick to do your FW udpates.

You can use pretty much any UZB stick - like these:

Download the Ghost Removal guide from the thread below. You're not going to remove ghosts, but info in that guide is useful in getting ready to update device FW:

Follow steps 1-14 in the Ghost Removal guide to pair your stick to your hub.

Then complete the steps below to do the firmware update on your device(s):

  1. Select the device that you want to update, let's say it's device 21 (a dimmer switch). (You can find the device number of your Z-Wave devices on the Z-Wave Details page, match up the device number there w/the device numbers shown in the PC Controller app):

  2. Select the OTA firmware update button:

  3. Select the Get button to load details of your device:

  4. Select the folder icon to browse to and choose the firmware update file

  5. Select the target device in the Firmware Targets section

  6. Select the Update button

The FW update should start, and you'll get a success message in green at the bottom of the screen when the FW update completes successfully. You can then reload device info w/the GET button to see the new FW version.

It could help to do a full shut down and restart of your hub before doing the OTA FW update...

  1. Shut down hub from Settings menu - wait for red light on hub
  2. Pull power at wall (plug on hub can be fragile
  3. Wait 2-3 minutes
  4. Plug in and wait until reboots and green LED/hub comes back up

I got a Zooz zwave uzb stick and downloaded the Simplicity Studio software but I don't see anything about PC Controller tool. Where is that to be downloaded?

Read the instructions in the PDF on installing and setting up the Simplicity Studio (most ironic name ever).

You download/install the PC Controller app from within Simplicity Studio.

Detailed instructions/screenshots in the FAQ section of the PDF.

got to Network Management on PC Controller and when I clicked add after a while got Add Note Failed.