Zwave Device Stuck in Initial Startup

I have a couple of Kwikset HomeConnect 620 locks that I am connecting (new) to a hub. I was able to get the first device connected with no issues, however, when connecting to the second lock I ran into a problem. During the initialization process the device appeared to connect and gave me the prompt to continue with or without security, during this time period I got distracted and the whole process eventually timed out with the inclusion process ultimately failing.

Initially I tried a zwave exclusion and then eventually went to a factory reset on the lock itself (which I had done before starting the entire process so this was the second factory reset), all to no avail. At this point, when I begin the inclusion process it says that it has located a zwave device, but then never goes beyond that point. I went through several rounds of doing a general exclusion and finally factory resets, but never had any success getting beyond the device location process.

After doing some digging on my zwave network I see a phantom node that is labeled as a "specific_type_door_lock" but it is not an active device and under the column where it gives the name of all my devices, this one has a "discover" button. Under the status section it reads as "Ok" and gives me the "repair" and "refresh" button options.

I believe it is this unassigned/unnamed device that it causing issues with adding the new lock, but I cannot figure out how to get rid of it. I figure there is something simple that I am missing, but I cannot for the life of me guess what. I have tried a reboot and a reboot/power down of the hub itself, but cannot get the device removed from the list. I also updated my firmware (post encountering this issue).

It appears to me that the hub is recognizing this as a connected and legitimate device, but it clearly is not. How do I get this "device" removed?

@user3404 Power down the lock. Remove the device from z-wave details. Remove any other devices without routes. These are ghosts and will hamper your mesh as well as prevent devices from pairing properly. Go to z-wave details and click firmware update at the top. Let it update.
Factory reset the lock, pair again. Choose yes when prompted for security. The lock will not pair without it.

1 Like

Failed pairings like this are sometimes tricky to get rid of. If you click "Refresh" a couple times with the lock batteries removed, it should at some point change to "Remove". You might even do a shutdown from the Settings menu, pull the hub power from the wall, and then reboot if it doesn't remove after 1-2 tries of hitting Refresh.

Try all that first, and if that doesn't work we can try further steps.

1 Like

@user3404 My experience has been that it may take a few days waiting time before successfully remove the ghost using HE remove feature.Better to remove it sooner, but it didn't always work for me, when trying remove on the same day.
In some cases I had to let it sit for a couple days, then it removed

2 Likes

Ok, so that fixed the first thing, it did not occur to me that despite the factory reset on the device itself, the hub was still communicating with the lock (at least partly). Removing the batteries and forcing it to lose communication finally gave me the remove option that I had been hunting for. I removed the lock, rebooted the hub, factory reset the lock, tried the pairing procedure again, and still was encountering issues. I repeated this procedure several times and received mixed results.

Eventually, I went ahead and paired another device (light switch) in the same general vicinity to ensure the hub was accidentally picking up this switch during the pairing procedure (I was pretty sure this wasn't the issue, but trying all things at this point). I added this switch after having disconnected the lock and removed it from the device list found under ZWave details (note that I have never gotten the lock to show up in the actual device list). It is also worth noting that when I paired the switch it skipped a node in the sequence, i.e. the previously successfully paired device was 0x22, the failed lock kept trying to pair to 0x23 (however, at the time of pairing the switch this node was not assigned to a device), the switch picked up on node 0x24. When I went back and tried to pair the lock again it would not finish the pairing procedure, as each time before, but I noted that it picked up node 0x23 again, rather than going to 0x25 as I would have expected it to.

It is almost like there is something in the hub that is still associating this device with something, but not anything that ever shows up on the list. I'm going to try to remove the device again this evening and then do another reboot/power down, then I'll let it set for a couple of days like rxich recommended and see if that does the trick.

@user3404 Some locks need to be paired within a couple of feet of the hub due to the low power whisper mode when passing encryption.... This might be the case. Also did you do your firmware update on the z-wave setting page?

1 Like

I actually tried both, the first lock paired where I had it installed, about as far away as I could be and still be in my house, implying that the lock supports NWI. That said, I didn't take it for granted and I did uninstall the lock so that I could place it next to the hub during the pairing procedure.

I did not try the firmware update button on the Zwave setting page, I did not realize that was different from doing it in the hub settings. I will try that this evening as well.

1 Like

Figured I would give everyone an update on where things finally landed. After trying all of the items recommended by this community (including waiting a couple of days after removing the device) I tried pairing things again. No dice, same issue. I had ordered another lock for a different door over the weekend and it came in yesterday. I installed the new lock and went through the pairing procedure; the device paired right away with no issues.

It appears that whatever I did made some kind of connection with the lock that I have been unable to completely remove so whenever I attempt a new pairing it just resorts back to that original connection. Knowing that I was able to pair a new device with no issues I am just going to return the problem device and pick up a new one.

Thanks for all the suggestions. To all future users with this problem, save yourself the headache, just replace the lock. The only thing I did not try was a factory reset of my hub, it is possible that might have worked, but I have to many devices connected and I am worried about breaking other connections in the process of doing so.

@user3404 Can you post your ENTIRE z-wave details page? Something sounds amiss

1 Like

Not sure the best way to post this data, it looks like I am restricted from posting embedded images and I cannot post a link to a location I have uploaded them to. I tried copying just the text but that came across as just a jumbled mess.

Join the owners group then you can post screen shots... click here --->>> Hub owners - Hubitat

Personally I use windows snip (post everything on the z-wave details page)

1 Like

I knew there had to be something simple I was missing!

Take a close look at screen 6, sequentially I added the lock between node 34 and 36. The fact that I was able to continue to pair devices and that it picked up on node 36 leads me to believe that there is still some phantom connection between my hub and the device.






Put a couple of repeaters in to deal with 0x22. One as close to the lock as possible and one next to the hub. Then click repair on just that device. I recommend the ring v2 extenders. No, there isn't a ghost left in there, when you remove stuff the slot just doesn't get reused, I mean look at this section of mine...I can tell you there is nothing else because I've been in there with the silabs software.

1 Like

Interestingly enough, I haven't had any communication issues with 0x22 yet, although my system is relatively new so it may in the future. That is the point in the house that is furthest away from the hub, so it makes sense it might need a repeater.

Also good to know about the node number being assigned and not reused.

The problem still remains with the one lock, I will note that every time I try to re-pair the lock it ultimately fails, but it's semi-paired status (shows up in the devices on the zwave details page) always picks back up on the #35 node.

Whats the firmware on the problem lock?

I can't ever get it to make a full enough connection to determine the firmware (I'm assuming the easiest way to do that is use Simplicity Studio, although if there is an easier way let me know).

That said, it becomes a moot point now. I received a new lock over the weekend and was able to get it paired. Not quite as easily as locks 1 and 3, but I eventually got it there. I ran in to an interesting problem where I think I was telling the device to go into pairing mode too quickly, ie I would tell my hub to start the inclusion process, then immediately (within 2 seconds) hit the button on the lock. The hub would then say that it had located a zwave device but then it would never go to the next step (querying about whether to include security). I tried this several times before letting the hub run its inclusion process for about 10 seconds and then starting the pairing sequence on the device.

When I did that, lock #4 paired with no further issues. Out of curiosity, I went back and tried this with lock 2 and still ran into the same problem of the device not pairing fully.

I returned lock 2 earlier today. It's not really the satisfying solution that I was hoping for, but fortunately Amazon returns are pretty simple. :slight_smile:

1 Like

It's always on the lock itself on the plate where the user codes are. Glad it's resolved though.

1 Like

Download the Hubitat app