Zwave device add stuck in init

Sorry for the newbie here but Im migrating from my Wink hub to the HE. During setup I have 3 Zwave products added but after this any device I try to add (after exclude) goes to initializing and sits there. Now I cant seem to get past the device init screen.
Any ideas would be appreciated.

I've heard rebooting the hub (via the menu, do not just pull the plug!) can help.


Just curious, what version of HE are you running? I used to have this problem a lot but haven't had it with recent firmware. That being said I also added a lot more devices at first (migrating from Smartthings) than I have in recent months.

Factory reset the device. Then do a general exclusion on it. Then power cycle the device for 30 seconds. Then try to include it again.

Do not try to include immediately and exclusion. Always wait at least 30 seconds between steps.

Version is I tried update from app but says it is at newest yet I’m reading this blog where some are saying version 2.22.xxxx is available. Where do I download newer versions ?

Thanks I’ll try this today .
However, This may be a solution for a new start but with many smart devices I wouldn’t be thinking this is a solution after they are all attached.?

You need to make sure Z-wave devices forget their previous associations. Some will do this easily with an exclusion, some will not, even though they are supposed to. Some manufacturers will recommend a factory reset after exclusion, while many will only recommend it if the controller is inoperable or no longer available, because you have to reprogram special device features when you do that

I do it even on a new out if the box device as a matter of course. If you do, you improve your chance of success and smooth sailing. So why not? A bit of device configuration to possibly lose, but a hopefully stable device that joins easily is what you are trying to gain in return. Seems a fair trade-off.

Good advice thanks.
I have factory reset the zwave devices but I still have the HE stuck in init on a device 5. How can I reset this error or can I do a factory reset on the HE to start over?

If you reset the Z-Wave a Radio, you’ll lose all the devices you’ve joined, so don’t do that. If you “soft” reset you won’t, but that’s done typically when there’s a database problem.

Instead, shut the hub down, then when the light on the front is red, pull the plug for 30 seconds. Plug it back in and wait for the light to go green. Factory reset your device again, and then try to join it at least 10 seconds later.

Another question not asked or answered yet is, what device is it? Is it on the compatible devices list? Is it a motion sensor with a tamper switch? Some Z wave devices will not wake up when they’re supposed to, they need a second Node Information Frame. It’s a beacon that they send out during the inclusion process and one is not enough with some devices. So if for example the procedure is to insert the battery to put them into inclusion mode, you sometimes have to hit the tamper switch a few times as well to get them to wake up.

1 Like

Yes it is the GoControl PIR sensor with the tamper switch. I have tried pulling/reinstall battery with multi 1 second toggles of the tamper switch to no avail. I have success with their door sensors but not the PIR.

Ha thanks for the info. I got frustrated (too much self isolating I think ) and did the full reset. Starting over I made sure I performed an exclusion on all my zwave devices and shutoff the wink hub. I have some devs back online now but slow rollout for sure.
In the midst of the discover I have 2 phantom zwave devices that show in initial state and stop there. Any suggest on how I can locate these devices to reset them?

Don't worry about "ghost" devices. They will be cleaned up by the hub during nightly maintenance (between 2am and 2:30 typically. Depends on your database size). Initial maintenance will only take a few minutes in the beginning when your hub database is still small. They may not clean up on the first maintenance, it may take a few, but eventually they will be removed.

Sorry, I missed this earlier. Those are not on the compatible devices list. Do you have a lot of them? I had one of those briefly when I had Wink. I returned it. There are MANY choices of motion sensor and I think they are all better that that one.

Zigbee Motion sensors are much less expensive in general and faster response time usually.

They are on the list - under the Linear brand name. Kind of confusing because GoControl/Linear/Nortek are the same. Supported by the generic z-wave motion /temperature sensor driver.

But I agree with you completely. These are slow.

1 Like

No I only have the one so not a major issue just hoped to reuse from wink.
Do you know if you will be adding support for other products like Honeywell vision pro 8000 thermostats, Sensi WiFi touch thermostats, Meross switches ,smart life plugs,magic home led products,TCP smart and blue iris security?

Oh ok I’ll try from there thanks

Thanks to @adamkempenich ...


Thanks to @csteele

1 Like

What’s on slate is dependent on what devices @mike.maxwell receives on loan or donation from manufacturers or users to test for compatibility, his schedule, and discretion.

Not up to me. There are users and devs that can sometimes help with similar drivers that can be modified. And as I forgot, the go control actually made by Linear as @aaiyar pointed out. So that device should work, but they’re really just for Alarm systems. Not a great device for automation of lights or presence tracking.

1 Like