Zwave and ghosts again

Please, can someone please tell me why every time I go to add a zwave device onto my mesh, its like playing russian roulette. I'm sorry, if I sound rather short right now, but I am pissed. I am angry at myself because I should know better then to have ever tried smartstart,

I was adding aotec contact sensor into my perfectly 100% clean zwave network. Of course, I saw the smartstart there and I tried it. Sure enough on my iphone, after scanning the device, the application refused to allow me to scroll to complete the registration.

Well, guess what, now I not only have 1, but 2 brand new ghost devices in my zwave table.

so, things that I have tried. I have removed the batteries and then done a refresh a couple of times until "remove" appears. As far as I can tell, the remove button doesn't do a bloody thing.
I rebooted the hub, and tried the above step again. No luck, won't remove
I have fired up my zstick which I have already paired in the network. doing an Update from the zstick, the 2 new devices don't appear there. since they don't appear, I am unable to remove them from the network. So, if they don't appear on the zstick, how can I remove them?

I have tried to do zwave exclusion (knowing of course it wouldn't help). All I get in my logs are more of the famous "zwave network responded with busy" messages.

of course, there is probably no reason for me to try to restore the backup I took before this sleigh ride, because its my understanding that does nothing to the zwave radio in the hub.

so, my game of russian roulette was lost. Any ideas?

I have a couple ideas...

False, but you're not to blame for not knowing... All those buttons do is send a message from the Hub to the ZWave Radio... and the ZWave radio does all the work. Thus the Hub's UI returns immediately as if complete. In other words what you see is what is supposed to happen BUT behind the scenes, out there on the ZWave radio chip, it's doing the "Is Failed?" test, and if true, follows with a "Remove" -- which does yet another Is Failed.. before actually removing it from the DB. IF either of the Is Failed fail :slight_smile: Then the process stops. Therefore you must wait for one unit of time equal to the time it takes to complete two Is Failed tests before a) trying again or b) rebooting, because either will stop the process.

Exactly as expected unless you click the Update button to get a new copy of the ZWave DB on the Hub copied to the ZStick. It's a pain that ZWave doesn't keep the Secondary up-to-date. But I suspect that's because a secondary, back when the protocol was invented, was what we might call a "button Remote" today. Whatever the reason, there is simply no built in communications between the two. So click that Update button on PC Controller and it will do just that and your ghost devices will appear. Again, not your fault for not knowing. :smiley:


I should have said. I know about the Update button on the zstick, and have successfully updated.

The devices just don't show up even on the zstick, which is a situation I haven't run into before. Its like the hubitat zwave doesn't know about the devices, but then why do they show up on the zwave details page?


BTW, I tried a database restore (figured I had nothing to lose), figuring that maybe the device was in the database, but not in the radio as the zstick lead me to believe. Nope, ghosts still there.

Just for the sake of argument, have you shutdown the hub and removed power for 30-45 seconds to clear the zwave radio?

1 Like

Maybe the Hub's 1st message to the ZWave radio worked before you managed to get in a reboot BUT before it had a chance to signal back to the hub that the Remove had worked?

Without seeing the messages associates with clicking Update, I can only guess that it didn't. Because if it had, then the DB on the ZStick is correct and you can just wait for the automatic hub process to clear the ghosts out.

1 Like

yep removed power and waited several times

1 Like

I have found that I have had to hit the Remove button repeatedly in some cases for it to in up to 10 times, pausing in-between. May or may not help in your case, but in a few cases sorted it for me.

Sounds like you are remembering to remove batteries on the sensor so that it has no power when you try to do the remove, that should make it possible for the hub to remove the device.

Regarding the Z-Stick, if I had a situation like you where the ghosts aren't showing up on the Z-Stick I would exclude it from the hub and pair it again. One of those "I shouldn't have to do this, but..." situations, where starting over w/a fresh pairing of the Z-Stick may help.


I've hit that remove button so many times on both of those two ghost devices, I've lost count. yep, also remembered to remove the batteries as well.

Its sad to note that I've had to do this so many times with Zwave, I seem to know most of the tricks...

I know what you mean about excluding the zstick. Quite frankly, at the moment I'm just afraid to do it. I just feel right now like that the more things I am trying, I'm just digging my own grave. I'm afraid to unpair the zstick because it has been lifeline, and I'm afraid that I'll just end up turning that thing into another ghost and then I'll be really screwed.

1 Like

Does anyone have a pointer to the original document someone wrote showing how to pair, and unpair the zstick from the controller, as well as removing ghosts? I can't find it right now, and its been so long I can't remember how to unpair the zstick

Short version in HE click on the remove button on the device page, and from PC controller click Classic Learn mode for the stick,


THANK YOU folks. I finally managed to delete these devices. Here is how.

Like danabw suggested, I went and unpaired the zstick from the controller (while holding my heart in my hands), and it unpaired. I then repaired the zstick, and what do you know, my ghost devices appeared in the table (even though no matter what I did before, Update would not pick them up).

After I got the two devices to show up, it was a easy matter of "is failed" and "remove failed" to nuke the two devices.

If I could supply beers to you all, I would. (-: Thank you.

Now, I am going to walk away from this for awhile before trying to add the node back in the old fashioned way.

Yeah.. i didn't. (-: The contact sensor successfully added the old fashioned way. Put hub in inclusion, tapped the sensor, and device discovered without security. Easy peasy. What I should have done in the first place. (-:


That would be me, w/extensive collaboration from @erktrek.

FWIW I've created a thread w/a link to the doc in the Help section, hopefully will make it easier to find/refer folks to.

Glad you got things sorted. And of course you would not be able just walk away, none of us can, that's why we're here. :smiley:

Rant time.

I am just amazed sometimes at the crap we are willing to put up with to make zwave work. (-: When it works, its great, but so help me, every change, every device add, just seems like you're walking naked through a minefield in the middle of winter. The potential for disaster awaits you on every step.

I guess, unpairing and repairing the zwave stick when update doesn't work is yet another tool to add into the basket of required zwave tricks to keep our networks healthy.

Again, thanks for the help

You should count yourself lucky if you weren't here when the C7 first released... :wink:

There is indeed more twitch in Z-Wave than desired, though not all of the responsibility lands on Hubitat. All of us are at the mercy of the SiLabs Z-Wave SDK and it's plusses and minuses.


Oh I was here. I've had to delete and diagnose my fair share of zwave stupidity. What threw me for a loop this time was the fact that not even the z-stick would pick them up. Update has always worked for me in the past without issue. (I don't think I ever unpaired my zstick. There was never a need, I leave the PC on, and update would work flawlessly anyways).

I realize this isn't all on hubitat. The irony that silabs calls that crap "simplicity studio" is not lost on me in the least. :grinning:


Yup, it actually broke the irony meter when they announced the name change. :wink:


Yeah the C-4 was no picnic either - that's why there are a bunch of watchdog apps. There was a time when you had to reboot every few days.. I was a big fan of the rootin' tootn rebootn app... It led me to start using a multi-hub configuration and ultimately to Node-RED...

1 Like

Ironically, I got into this mess because I was trying to replace an older zwave tilt sensor on my garage door with a Zwave+ contact sensor. I've replaced most of the old zwave devices on my network over time with Zwave+ and it really has made a stronger mesh and improved my reliability immensely. One garage door down, next one to do tomorrow.

Only issue is every time I add/delete a device, I go a strolling' through that minefield again. If you can actually make it through to the other side though, you end up in a happy place :grinning:

1 Like