Zooz Zwave Plus Power Switch Zen15 not updating events unless manually refreshed

Here is what I have seen so far. No red flags? actually dont know what to look for. The data in the log only shows when I manually refresh.

It usually automatically does a bunch of reporting similar to the top section you have marked "man". I can't run the washer right now to give you an example, sorry. But from memory, it literally floods the logs with these type reports when I tried it.

You have a C7?

I have an extra one of these plugs and my extra (not quite production ready) C7. Give me a few and I will see if that is different on a C7 than my C5 which does work.


You're awesome to do this. Much appreciated!

I would imagine my report should be flooding with info like yours but it is just not automatically refreshing for some reason. Weird. I will now put my third load of laundry in but first unplug and replug the device to hopefully reboot something.

Wife thinks I'm nuts for doing three loads on a Friday night . Pretty hilarious :slight_smile:

Ok, so I think this a bug of some type.

C5 has been working fine for a couple years now. Can't confirm it is working at the moment, but it did work yesterday with laundry.

C7 does not work no matter how I configure power reporting. No matter how I set things, I have to do a refresh to get changes just like you. The power levels "stick" at the last place you refresh. There are no power events stored unless you do a refresh. On and off work fine far as I can tell.

@bcopeland, did something change where this device won't work properly?

Edit: I even tried a bunch of incorrect drivers that have power reporting, like the Zooz double plug, one of the Aeon ones, and a couple others I could find. They have the same behavior of needing a refresh to get current values. That might or might not mean anything due to using the wrong driver, but at least it is consistent behavior between drivers.

Yup, same thing I'm seeing on my C7. Good to know:
a. I'm not going crazy
b. the device for some reason did not go bad (most likely)

Great catch @neonturbo. Couldnt have debugged without you. Whatever you can help with @bcopeland or get someone on this is appreciated. If you need more data, just let me know and I will be glad to help. Im a recent ST refugee so need to get my stuff all up and running .

Ohh, I think I found something. How did you pair your device? Just plugging it in, or tapping the button 3X?


If you pair the device according to Zooz "securely" you get no reports. That is the 3X button tap method. Funny enough, it didn't show securely paired anywhere in the Zwave settings page, nor in the device setting page.

If you pair by simply plugging it in when doing the inclusion, it reports power fine.

That is why the C5 works, and not the C7 when paired the same way. No security on the C5. It clearly said security "NONE" on the Zwave page no matter the way I paired it.

Manual for reference...

1 Like

I have 2 of these included with no security in my C7 (on and power reporting is working as expected.

Bingo guys! Mine had been included with S0 security. I just went down and redid it all with no security and the power data is coming through like clockwork. Too much actually LOL.

Just for the sake of clarifying because I just got back from my excluding/including the device:

  • Non secure is just plugging in and including OR tapping 3 times and including
  • Secure is holding the button down for 3 seconds and including

I confirmed this because I included by tapping three times and it is without security.

Appreciate everyone's input and help. Especially @neonturbo!

1 Like

The device is sending power data like crazy - probably 10-20 times per minute. I want to configure it so it just sends power data every 30 seconds. Just to keep the network clean. I have set the parameters below but nomatter how I set it, the wattage just keeps coming in every few seconds. Anyone with any idea how to keep that from happening? I did press the configure button after changing parameters but that is all.

@tony.fleisher @neonturbo Pinging you guys to see if you can answer my above question. You were both great in identifying having to turn off security to get the power data to send but now the hub is getting pinged like crazy. I set the power reporting interval to 30 seconds but it does not seem to look at that. Any ideas?

I set the percentage change and value change to really high numbers instead of "no reports" and it cut back the traffic quite a bit

1 Like

I'm glad I did this wrong. I'm doing the exact same thing monitoring my laundry machines for activity, and got lucky that the pairing went insecure.

This S0 thing sure causes a lot of issues. I can't use my inovelli bulbs as a result. Another thread recommended I buy a USB dongle to pair S0 stuff as insecure (if they don't have a insecure pair method). I'm tempted to just get new devices instead, but that would cost more.

Hi Levahj... Just looked at you log and wondered where you are located as the log indicates your voltage to be (nominally) 100VAC. (~98).

I have the same problem with my zen15 flooding my network and bringing it down to no response at all.
I was also getting tons of reports PER SECOND, but had to start over as i couldn't unpair the 15.
Thanks to your post, I will give what you found a try!

Well I be danged.... Never noticed the voltage only at 100v. I just looked and it is still the same @100v. I live in the socialist state of CA so we definitely have 120v...

After 9 months I had forgotten what I did to settle down the amount of data the device was pinging the hub with, but now I remember by looking at the history of this post that including without security fixed it.

Zwave lack of stability and funky-ness, this example being just one, frustrates the crap out of me...

1 Like

I know this is old but I just went through craziness with this Zen15 not reporting anything, and I reset the device. Then I did NOT tap 3 times on the button - I plugged it in and went through "inclusion" with z-wave devices. It still won't update events unless I manually refresh it. did I miss another step??

NVM. Got it sorted! Needed to update the reporting - lol. Thankful for this thread though!!

I have a C8 hub and was unable to get the Zooz15 to report changes. I was also unable to configure the Zooz15 and have preferences stick. I tried the suggestions mentioned above (re-adding insecurely, etc.), but nothing would work.

I switched the Zooz-provided drivers linked in the installation manual and that fixed all the problems.

Are you saying @jtp10181's driver worked or didn't work?

If it did work (it's a great driver!), it's also available in HPM, so you can "match up" there to easily stay current with any future updates.

If it didn't work, tell us more and we can hopefully help get it going for you.

Yes, @jtp10181's driver worked, whereas the ones built-in to Hubitat did not.