Zooz Zen27 unresponsive periodically until air gapped

So this has happened with 2 out of the 3 installed Zen27s in my house. They well... hang for lack of a better word. Become unresponsive to both Zwave input, and button presses until I pull out the air gap tab and give it about 15 seconds or so to get its wits about it, and then it goes back to normal.

I am using the Zooz drivers. Should I use a generic driver on these instead? If so, which one? I am simply controlling on, off, and light level with these.

I would check to see if there is a firmware update.. It sounds like you have a firmware bug..

Tagging @agnes.zooz

I had never had this problem until I updated my firmware last year now I see this randomly on all of mine.

What could be possibly causing this behavior in the device's firmware? We'll be happy to work on it once we know what needs to be fixed.

@dbhosttexas are you using the Zooz Central Scene Dimmer driver or the custom driver?

@agnes.zooz I am using the Zooz ZEN Dimmer Advanced driver as downloaded direct from Zooz and installed in Drivers Code.

What load do you have on the Zen27s that are acting up?

Insufficient loads or some dimmable leds will not allow sufficient current to pass at low voltages when the switch is off.

One way to test if this is the issue is to screw in an incandescent bulb for a little while and see if it solves the issue.

1 Like

I have a few of these zooz dimmers and they worked fine until I upgraded the firmware and now they randomly lock up and the only way to recover them is by pulling the air gap.

deviceType: 40960
zwaveSecurePairingComplete: true
inClusters: 0x5E,0x6C,0x55,0x9F
zwNodeInfo: D3 9C 01 04 11 01 5E 6C 55 9F 68 23 F1 00 86 26 85 5C 8E 59 72 5A 73 5B 70 7A
secureInClusters: 0x86,0x26,0x85,0x8E,0x59,0x72,0x5A,0x73,0x5B,0x70,0x7A
firmwareVersion: 3.1
deviceId: 40962
S2: 1
manufacturer: 634

This is actually firmware 3.01 (driver is not converting it correctly). There is a newer firmware now, not sure if they have fixed any issues that would help this. Also @brianspranger which driver are you using?

@dbhosttexas what firmware are your switches on?

@dbhosttexas and @brianspranger did you add any new Zwave devices recently? Specifically any sensor or power metering devices which may be sending frequent reports back?

Also as steve mentioned above, telling us the load you have on the switches would help. Certain types of loads have been known to cause problems (no load, low load, or fans specifically).

1 Like

I am using the "zooz central scene dimmer" driver.

I had these dimmers installed for a long time, then last year I upgraded the firmware, no devices added. Since the firmware upgrade they started to freeze.

I have several of these all with different types of Leads all driving at least 4 bulbs. They all exhibit the problem.

Like I said they had zero issues before the newer firmware. Nothing changed except the firmware.

When they lock up is it the same as OP, where they do not respond from the hub commands and also the physical buttons? Definitely seems hardware related in that case. I would open a ticket with Zooz and see if they have any other ideas. You might be able to revert backwards and flash the old firmware to see if that fixes it. Could possibly be a new parameters that was added and it needs to be set but that is probably unlikely.

Did you have to re-pair the devices after the firmware update which would indicate they factory reset themselves? Otherwise a factory reset will probably be the first thing Zooz suggests.

Yeah the lose local and remote control.

I think I did have to repair them after the firmware upgrade but that was a year ago so I don't remember.

Sorry about the slow response.

Firmware 1.0

Load is typically 2 60w equivalent LED dimmable bulbs. Not sure of the actual wattage. I think total 14w per fixture.

The master bath light, master vanity light, and living room light switches get boogered up. The Zen 22s I am not sure how to display the firmware version, but no problems with them, only the Zen27s...

So if I get the process right, there is some sort of USB stick I have to get on the PC, remove the Zen27s from my Zwave network / exclude them, pair them to the USB stick, and update the firmware, remove from the stick / exclude / re add to HE... Not a joy filled process to be sure.

If you have a C7 hub there is a built in firmware updater app, anything else there is a custom driver that can be used (a search will turn up info on both). You can also use a USB stick as a secondary controller. Downside is that probably no matter what way you do it the switch will reset itself when done so you will have to re-pair it.

I have been successful using the "Replace" feature in the zwave details to get them to join back into the same DNI. That is possibly only available on the C7 though.

1 Like

Yep, C7 hub, I have the link to the firmware, and a huge nervousness about it all. I will try to update one and pray it works...

Hopefully the Zen 22s don't do this though. Mine are not OTA flashable as they are not a new enough version... Bummer.

Let me know if you have any issues. I have flashed a bunch of Zen27s. If getting them back into the same DNi as to not break automations an dashboards is critical there is another post I could find that covers a couple ways to do it.

A couple additional notes:

After a FW upgrade Zooz recommends resetting the switch using the tap-tap-tap&hold for 10 seconds the upper paddle until the blue light blinks.

The Zen26 and Zen27s use a FET for the output stage. Of course I don’t know the internal design but it makes them more susceptible to this type of behaviour.

I understand you didn’t have any issue with previous FW versions but with only two dimmable leds as a load I am highly confident that it is now the cause of your issue.

If you could stand replacing your lights temporarily with incandescent bulbs I think it would solve your issues and prove the point.

I could also send you a couple load resistor to try out.

So... replace failed. Do I just remove the device, exclude, and rejoin it?

Yes if replace fails that is the course you need to take but you will need to manually edit all your rules.

But I would recommend NOT removing the original device until after you re-join your new switch and edit your rules.

The last time I replaced a device, HE said it failed but it actually worked. Please make sure the device is not really responding.

And you might want to try rebooting your hub and trying replace one more time to see if it works then.

FWIW I have a ZEN27 with ONE 60w equiv dimmable LED on it, which I have the box for and it says it is actually 8w. I have never had a problem with the switch.

I hear what you are saying. But for sure all bulbs are not made the same. Different bulb designs will bleed different levels of current in when the Zen27 outputs this ugly chopped voltage. And Zooz has not spec’ed how much bleed current the switch requires to power itself. But based on different FW in the switch, it could definitely change this requirement.

Another example, using non-dimmable bulbs with a zen26 will cause the OP original condition in 12-24 hours.

Download the Hubitat app