Zooz Zen25 Trouble with S2 Authenticatation

It's at 2% right now and is direct. At the moment the hub and device are physically next to each other as well.

1 Like

Cool. It looks like you have it covered.

It’s been some time since I programmed the zen25. The latest switches I have programmed have been the zen7x series. Possibly the zen25 took longer. As long as it progressing it’s good !!

Since you have just purchased these, I'd recommend considering returning them for z-wave plugs that don't have the same issue that these do. There are way too many reports of these degrading z-wave mesh performance.


This is actually real good advice. I mean I said that I stopped using mine but wanted to support the update process, but @JX22 , you might want to really consider this.

I have replaced my double switches with sengled zigbee plug-ins. Yeah it takes two of them but you can get a four pack for $60 CDN.

1 Like

That may happen.....I've got a question into zooz (besides the firmware one) and the firmware is still updating......

Wow!! That’s after an hour?? Something is making you zwave mesh really busy.

1 Like

Yup. Over an hour for a firmware update is far from usual.

1 Like

I have had to update a few zooz devices. In most cases i have had to exclude them, do the inclusion again without security. Then do the update.

I would suggest trying that. Then if that doesn't work shutdown the hub, unplug it completely from power and Wait a min to ensure the zwave radio is completely off. Then power everything on again and retry the firmware update.


I'm going to wait and see if it completes.

This is a replacement hub as well since my first one wouldn't connect unless it was right next to a device. While the replacement has been acting better it still seems to be a bit quirky (network settings won't load when https only is enabled).

That I can not help you with - I didn’t even know there was an option. I know my router and NAS have the option but never seen it on the hub. I just went looking in the network setting and I didn’t see it there.

Oh. And I don’t have anything connected with S2 accept for my Alfred lock so I’m no use there either.

1 Like

@steve.maddigan That option exists here: http:///hub/advanced/certificate and you would need to provide the certificate and private key. When the HTTPS only option on that page is enabled network settings (at least for this particular hub) stops working but everything else does. I also had to force 100mbps since auto negotiate was failing me with this replacement.

1 Like

That is likely because of something on your switch... Also DO NOT use jumbo frames.

@rlithgow1 I suspected that initially but the switch negotiates correctly with other devices in the same port and jumbo frames are not used.

I've seen some switches not like hubitat (and similarly rpi's) format of auto-negotiation at the hardware level. To confirm this, if you have a cheapy switch laying around, connect it's uplink (or really any port) from it to your main switch and then plug the hubitat into the cheapy switch set at auto negotiate. Setting it to FULL 100 certainly cures it but it's not so much a hubitat issue as a switch issue. I use cisco switches and they adapt to pretty much everything. Conversely I've had people bring in crap to try and integrate into my larger networks and have forced them to yank them because of behavior.... (I'm looking at you nameless piece of Chinese manufactured equipment that wasn't certified for squat that some vendor thought would be great) In this case though hubitat follows proper protocol but something likely in your switch doesn't like that. (My experience as a network engineer)

That makes sense - I have unifi switches and this switch in particular is the EdgeSwitch 8XP (What the hubitat is plugged into).

I have a unifi US-8-150W 8 port poe switch in my office that I test stuff on.... It's always been a little ornery with certain things. (Why I prefer Cisco or HP Procurve switches) I love Unifi AP's though and use them everywhere.