Zooz zen 77 - syncing and delays

Just installed a new Zen77 dimmer. I set it up in HE with the Zen Advanced Dimmer driver. At first it seemed great. I was able to set everything as expected and it all worked. But then as I made some changes, it kept showing Status Syncing or pending changes, and doesn't seem to ever finish. I'm also seeing significant lags (a minute? two minutes? ) to HE actions - and even problems with the switch responding to physical paddle presses.
Most of this started after I set the advanced parameter to disable programming from the paddle - which I thought was necessary to be able to get reports of double, triple taps on the paddles.

The other weird thing - after I set the driver to the advanced one - after a bit of a delay, all the advanced preference settings became visible - which I believe is the expected behavior. But now they've all disappeared again. Hitting Configure, Refresh, waiting a while - none of that has brought back the advanced setting. I switched the driver to the standard Zen77 , saved device, switched back to the advanced dimmer - still not getting advanced settings back.

(Interestingly - I have two other Zen 77 switches - also with the advanced driver. The advanced settings disappeared on those as well - and i never changed the paddle programming setting for those.)

What's going on here? Any thoughts?

I assume by the advanced driver you mean my community driver?

I would pull the air gap or pop the breaker on/off to reset the switch. You may have overloaded it and locked it up changing a lot of settings quickly. Then try hitting Refresh on the driver, which should refresh the version and model. Then refresh the actual web page to see if that helps.

The two things the driver needs in order to show the parameters is mainly the firmwareVersion which should be listed in the "Data" section at the bottom, and also the deviceModel which is in the State Variables near the top. Do you have both of those and what do they say?

image

Yes on both. Model is ZEN77 and firmware is 10.1
I did a Test all parameters, clear hidden and refresh on the parameters - that seems to have restored the advanced parameter settings.
Right now it says 20 Pending changes - that hasn't changed in the last minute or two, despite refresh button and reload page.
I can try resetting switch as you suggested - but maybe I should wait a bit since it says pending changes?

image

Yeah do not use the "Test" setting. That was sort of an experiment and I think I am going to remove it, did not really work out how I wanted. That might be what had them all hidden on you.

Also, if you have the experimental Supervision turned on, turn that off.

Then turn on debug logging and run a "Configure". Watch the logs you should see lots of chatter with the parameters. Sometimes it might not get all of them to sync up on the first try, so give it a minute and then try the configure or save again if needed. If it persists with some pending changes still, just do a normal save with debug logging on and post a screenshot of the log messages. That will show what settings it is stuck on.

Also I have firmware 10.01, they never told me 10.10 came out. There could be something that changed there. @agnes.zooz ???

1 Like

Thanks! I'll get back later when I try this stuff. It's made some progress - 4 pending changes now.

I wasn't clear on what settings were needed to be able to pull things like double click, triple click, etc A few of the settings are a bit confusing.

Scene Control Events has to be enabled for the multi-taps. The programing from the paddle I would also disable, this prevents it from going into inclusion/exclusion mode when you triple tap. Factory reset still works so if you ever get into a bind there is a way to recover it.
image

Ah! I wonder if that's what happened yesterday. I did do a triple tap and might not have had that setting right. Maybe that's why it became unresponsive to on/off at the paddle!

If it goes into inclusion or exclusion mode, the LED will flash. Some of the switches still respond during that but I think the 7x models sort of hang up while they are in the inclusion/exclusion modes. So yeah, first thing I do is turn that off once I get them setup.

Cut power, changed the settings as you suggested, configure, save , refresh. It's all synced now and the paddle works.
Thanks!

I can confirm that all of my Zen77 show firmware 10.10. These were purchased and installed within the past 3 months, so I don't have visibility before that.

This must have slipped through the cracks. We're finalizing 10.20 / 2.0 for the ZEN77 and will make sure to send you the files and detailed documentation for all of the changes!

1 Like

Download the Hubitat app