Zooz motion sensor ZSE29 -- Ignores lux setting, always reports motion

I am trying to use this motion sensor for an outdoor light, but it won't respect its own "lux level motion trigger" setting. It reports motion at all times.

I have not tried adding a lux rule in the motion manager, because I would like to set the lux rule at the sensor in the hopes that it will disable the red LED if there is a lot of light and motion is ignored.

I am using the Hubitat provided driver. The lux knob on the unit is set at default and I have not yet tried messing with it yet... assuming that the Hubitat driver can be made to do what it says.

I am probably making a dumb mistake but I can't figure this out. I guess I can twiddle the knob but if there is a way to make the software cooperate, I want to know!

Edit: I wonder if the device is faulty. I have tried all the light-sensitivity options and it always reports motion. If I set it to use the lux dial, i can even see the values changing in the log... but there is no way to make it ignore motion. Very frustrating!

Are you on battery power? If so, by default, the new configuration parameters (which this is one of) will only get sent at the sensor's next "wake up" time, determined by its wake up interval, which by default is 4 hours (not configurable in this driver but theoretically configurable--but probably not necessary). If you don't want to wait that long, you could force v1 of this sensor to wake up by removing the batteries for a few seconds and popping them back in. I can't find any documentation on how to do it with the current revision, but that's worth trying. Otherwise, you could also wait. If you're on USB power, you shouldn't have to do either of these things, so then I'm not sure what's going on.

If you don't trust that the driver is setting the parameters correctly or want to compare any to what the parameter manual says, the Basic Z-Wave Tool may be of interest if you're not already familiar. But again, if all is well besides the above, this shouldn't be needed--just something you can poke around with if you feel so inclined.

Also after saving the preferences make sure it hit the configure button to send the configuration to the device. It will also take time as mentioned to update after doing so.

I just walked outside and tested mine. I can assure you the device works as you want it to once configured. Mine does not report motion when lux is over 200 as set in the driver.

If you're seeing a red light then it's in test mode and I think that overrides the lux setting, but I could be wrong...

This device sometimes doesn't get assigned the lifeline association on inclusion so if you're having reporting issues you should try removing the device and joining it again.

I ported my SmartThings handler for this device, but I think all that it adds is

The USB powered option for this device is a battery pack so the device doesn't know it's being powered by USB and always behaves like a sleeping device.

That sometimes works for all versions, but you can reliably wake up the device by tapping the tamper switch 3x. It's really odd that it uses 3x because that's also the procedure for inclusion/exclusion, but Zooz confirmed it.

1 Like

Thanks a bunch guys.

I am on battery power. I think I was able to force it to take an update by popping out the battery. In my screen shot above, parameter 4 is the lux setting. If I save a change in the settings area, that value does not change. If I then click Configure and reboot the device, the log suggests settings are being sent up, and then the parameter changes in Hubitat... so I am reasonably sure that the device is taking settings. I will double check with the Zwave tool.

@TechMedX could you post a pic of your State Variables & Preferences area? I can't imagine where else I could make a settings error, but...

I am still suspicious that the device is borked. I did a factory reset which should reset it to using the lux dial, and it was still not possible to get it to ignore motion. :man_shrugging:

1 Like

here ya go

and you can see I have gotten no motion events since 7am

OK I have an update and I think it's fixed... but why doesn't make much sense.

I believe the sensor was in test mode the whole time I was playing with it. The manual says that test mode is active when both dials on the unit are turned all the way to the left. It also says that test mode can only be active when the tamper switch is not pressed--that is, when the device is not mounted. A key hint that I missed was that in test mode, you get a red flash with motion. In normal mode, motion is reported with no flash until batteries are low.

Well just now, for kicks I left the sensor on the wall outside and turned the time dial a little bit. It was originally dialed full left, to the test setting.

As soon as I did turned the time dial a little, the sensor stopped flashing at me and reporting motion.

Test mode should not be a factor since the unit is mounted, and only one of the two dials was in the test position.

But I'll take the win.

Perhaps the manual just sucks. It also includes this text, which is obviously incorrect.

image

1 Like

There are two revisions of the ZSE29, and if you got it recently (and not used/secondary-market), you'd have the v2, where I think all (or at least most of) the Z-Wave parameters were added. My guess is that Zooz accidentally left that in the manual for the v2 as well or maybe wanted to keep the manual the same for some reason and make people work hard to discover that the parameters exist. :slight_smile: Glad you got it figured out regardless! (Shoutout to Kevin for his helpful, in-depth knowledge of so many Z-Wave devices.)

I definitely have the v2. I let Zooz support know what I discovered and included that part of the manual too, and they said they'd "alert the team." :man_shrugging:

Lesson learned: turn all the knobs even if they shouldn't make a difference. :smiley:

2 Likes

Funny (or not so funny) part, is I was going to mention this along with "if you are still seeing red you are still in setup mode, turn dial until you do not see the red LED". When I re-read your edit I was all, nah he turned them both.

Lesson learned here too. - don't delete a decent thought on a bad assumption :wink:

Sorry to hear the manual might have been confusing! I just checked and we have 2 files for VER. 2.0 device manual and neither includes the note quoted above so the printed version that came with the product should have a list of the parameters instead of the above note. Maybe it comes from an outdated version published online?

In the latest production run we also added a yellow sticker on the device itself to emphasize the need to turn the knobs away from the T mark to put the device out of test mode in case it's not clear enough from the manual. Again, I'm sorry the set-up wasn't as smooth as it could've been!

1 Like

I found the manual on the ZSE29 product page on Zooz's website: ZOOZ ZSE29 | Outdoor Motion Sensor, inititally from Gooogling (which I know can sometimes turn up old, undesired content) but later by clicking into it from "Sensors" (or "All Products") on the homepage. I see TheSmartestHouse has the latest, but I didn't think to check there first. Thanks for the link to the latest one!

2 Likes

I looked back over my stuff and understand better what happened now.

The manual that came in my ZSE29 v2.0 box IS the updated version. However, when I was working with the device, I had the manual PDF open on my computer, and I didn't use the printed version... and the manual that is linked on the ZSE29 product page is the old version.

But as far as I can see, the way test mode works is the same in both versions of the manual. Each version states that to activate test mode, the tamper switch must not be depressed and that both dials must be turned full left.

image

On my unit, it stayed in test mode when mounted, and with only the left dial (time) turned full left. That was the part that really tripped me up.

(Nice to see a manufacturer rep, thanks for being here @agnes.zooz. It does make a difference in which products I choose to buy.)

3 Likes

Glad we got it cleared up, we'll upload the latest version of the manual on the website (that place needs some maintenance work while we've been focused on expanding the knowledge base).

And thanks for clarifying the confusing part about the description @Horseflesh, hopefully the new bright yellow label will help address that part!

1 Like

I'm not sure that is the best message to send, please let me explain. I found it very useful to have the device in test mode AFTER mounting to let me fine tune the placement up/down. IMHO a better recommended procedure would be to...

"TURN THE KNOBS AWAY FROM TEST MODE WHEN POSITIONING IS COMPLETED"

We'll try to fit it in there, thanks for the suggestion!

1 Like