Zooz Double Switch ZEN30

I have a ZEN30 that I use to control outlets with the relay so that a hair dryer does not brick the switch. I do not yet have anything connected to the dimmer side. I can turn the relay switch on about 95% of the time. I cannot reliably turn it off. It turns off less than 5% of the time. I have worked with the nice CS people at Zooz. They had me update the firmware twice and it is now on 1.07. I am on the latest Hubitat firmware on a C5. Zooz feels there is an issue with Hubitat's driver for the device and I may see another Hubitat firmware upgrade that hopefully fixes the issue. It has been over 2 weeks since I last spoke to Zooz and have not seen a HE update.

2 questions:
Is anyone else out there having unreliable zwave control of a ZEN30?
Is Hubitat working on a new driver?

Thanks in advance

There are at least a couple threads that popped up when I searched for Zen30, and filter by recent posts. So I believe that there are others.

I thought I saw Agnes say something like they were working with Hubitat to fix some issues. Hubitat doesn't release their roadmap of future updates or improvements. Hubitat has said they aren't doing any more bugfixes for this release, so we won't see any official confirmation of a fix (or not) until 2.2.5, which probably will be out "soon".

Neonturbo, thanks for your reply. I saw a few other threads but did not see my specific challenge with reliably turning off the relay. I hope they fix the driver "soon". I am a fan of both Zooz and Hubitat and will be patient as my application is somewhat unique.

I have a few Zen30s and do not have issues turning them off. The only issue I have was introduced in 2.2.4, which makes pressing up on the paddle generate a digital button press on the relay. It doesn't physically trigger the relay, but it will report to the hub that the button was pressed when it really wasn't. So if you're using the relay button press to trigger a rule, the rule will also trigger when you press up on the dimmer switch. But this doesn't sound like the issue you are having at all.

When I first got my Zen30s, I had 2 that failed very quickly. Here is my post about it. Zooz support replaced both switches and their replacements have been working great.

I'm having this issue with the ZEN30 also. Pressing up on the paddle registers as a press of the relay button. Does anyone know if this is a known issue and being worked somewhere? I was able to implement a partial workaround by driving my rule based on changes to the switch status instead of the button press, but that isn't working very reliably either.

Welcome to the party :frowning_face:. We've all been waiting on @bcopeland for some answers on this as well, as this issue has been going on for months.

TLDR: The button presses on the ZEN30 are a mess, but triggering rules based on changes to the switch state do appear to work as intended.

I know this doesn't solve all the problems that people are having, but I have been able to successfully implement a ZEN30 workaround for my purposes. I have the dimmer portion hooked up to a load and operating basically in the default configuration. For the relay button, it's not hooked up to load, and set to "smart bulb" mode. Creating rules that trigger on the relay button press doesn't work for all the reasons documented in this thread. But even in smart bulb mode, the relay (or HE) does continue to track the virtual off and on state of the switch.

So I was able to create rules in RM and SAR that trigger on change in state of the relay switch rather than the button presses. In RM, that means setting the trigger to "turns *changed*". If you're using SAR to toggle a smart bulb (or similar), you set the trigger to "Switch turned on or off" and then also make sure to flip the "Also toggle when turned off" setting.

Again, this worked for me both with a simple bulb toggle in SAR, and a complex rule triggered by pressing the relay button in RM. Hopefully it's helpful to others.

Download the Hubitat app