Zooz devices

I got my hub up and now want to add devices. I bought Zooz double plugs and switches. I was told to exclude first. So I went to exclude and it said exclusion for 30 seconds. The plug is 5 ft away from the hub but it didn't show the device as being excluded. After exclusion then I would include and the device should be ready to go. I am testing with a lamp. I also noticed Not In Discovery mode in upper right hand corner. Doesn't it have to be in Discovery?

I don't have any of these devices but there will be a switch/pin/hole on the device to put it into pairing/discovery/exclusion mode. You will need to have a look at the device manual for where the pairing switch is and trigger that switch before starting the exclusion or discovery process.

Finally got it to exclude by hitting the button 3 times quickly. Now I tried to include. It says to hit the same button 4-5 times quickly. I have done that several times while in inclusion but no luck.

The above is generally true for Z-Wave devices, though on Zooz products it's usually a button you press in a specific way. The part about checking the manual is key--there are way too many differences between products and manufacturers for me to remember. :slight_smile:

However, I'm not sure that is the issue here. There may be just some confusion over how Z-Wave device pairing works. If a device is new, as yours sound like they are, you usually don't need to exclude them first. (You do if you previously had them joined to another network and they weren't "politely" excluded; it's rare, though not unheard of, for something to come new like this.) You should just be able to put Hubitat in Z-Wave inclusion/discovery mode and do whatever you need on the device to put it in inclusion mode as well (often just removing a battery tab or plugging it in for the first time if new, but again, consult the manual).

EDIT: I see you had some success above with exclusion (something to try regardless if it won't include, new or not). For your new problem, I'd suggest a few things. Try removing power or the battery on the device for a few seconds and try again to see if it helps. Also make sure you're pressing the button firmly and not too quickly (sounds weird but it does help sometimes on these). If nothing works, some people used to have problems joining more than a few Z-Wave devices at a time without a hub reboot in between, but I think those days are past (and if it's all you've done, probably not the issue). Before you do that, make sure you give it time: in my experience, some Z-Wave devices are a bit slower to be discovered than what I'm used to with things like my Zigbee motion sensors I feel like I'm always adding more of. :slight_smile:

Read the manual carefully. You may need to try multiple times to get some things to pair.

I have lots of Zooz battery devices and they all include with 3 quick presses as well as 3 quick presses for exclude. Get within a couple of feet when you do. For light switches it is 3 quick On clicks to include and 3 quick Off clicks to exclude.

I did that but nothing. I am 5 ft from the hub. When I hit the button 3 times the blue lights flash then a solid green for 1 second inclusion timed out. No devices shown.

What a lot of people here recommend is to open another session of the hub and select the Logs. Then try and exclude and you should see an entry for the exclude. Once you see the verification it has excluded then try and include again.

FYI, this used to be more or less necessary since you got no feedback in the UI for when an exclusion actually found something to exclude. With the new "Start Z-Wave Exclusion" button on the device discovery page, you now do. It's not a bad idea (and you can see if something else is going wrong too), but it's no longer necessary just to see if anything acutally happened.

I got them to work. I excluded with button 3 times fast and to include I did the same. I had to do it 3 times on one plug and the other one was on first try. Lesson learned!. I set up a simple lighting rule and it worked fine. I have 2 questions.

  1. I have 3 in wall timers the hub is in office. The first timer is 30 ft away and 2 walls seperating.
    timer 2 is in hallway which is 25 ft away from hub and 2 walls. 3rd timer is in the garage which is 60 ft away and 3 walls. I want to replace timers with Zooz switches so all come on at same time. The Zooz plug is in between the hall timer and garage. If I read it correctly, the plug will act like a repeater or extender so that the garage switch will receive the signal?

  2. When I go away on vacation and if there was a power outage, when power is restored all should work as before?

I am 71 yrs old and would never dream about this stuff. This is fun!


I think I am 72 so you are not alone in the age category. You will find that there are more than a few of us here.
As for the repeating, it will depend on many things. I have a fan controller that is in the same room on the same wall as my hub and about 6 feet away. The fan controller is actually two hops away from the hub and connects through devices in other rooms. Being on the same wall as the hub, the direct radio signal is blocked by all the 2x4s in the wall and likely interference generated by the television which sits between them.

1 Like

LOL! When asked my age, I now respond with my DOB. I'm old. Why should I have to do the math!


I did not know there was a "Start Z-Wave Exclusion" button. All I see on mine is a bunch of Discover buttons, and in Settings under Z-Wave Details is a "Z-Wave Exclude". That just shows a 30 sec. message that it started.

EDIT: I found it and yes I did not know that was there. Much better.

1 Like

Great idea. I will keep that in mind.

One thing you'll want to do to protect your Hubitat Hub from power ouatges, is to plug into a small UPS (uninterruptible power supply). The Hubitat hub is a small Linux computer with a SQL database that contains all of your configuration data, and hub historical events and logs. If the hub gets its power cut off, the database can end up in a corrupted state. So, a best practice is have it on a UPS to prevent issues, and to maintain the clock to keep your automations running on scheduled. If your house has a power blip, and loses the internet connection and kills power to the hub, the hub may actually reboot faster than the internet service can be restored. This sometimes causes the clock in the hub to be incorrect, resulting in automations not running on schedule. So, by having at least the Hubitat Hub on a UPS, you can avoid these problems.

Thank you. Great idea. Another question. As mentioned above I am installing 3 Zooz switches. I have been seeing problems with pairing on the hub if it is too far away. What I am thinking of doing is take 2 extension cords, cut off one of the ends with the receptacle the other with the plug and wire the switch plugging in an outlet near the hub and plug the lamp into the other extension cord. Then pair the switch. Then istall the switches where they need to be.

That is more or less what I did. I took a plastic outlet box and cut a slot on the side. Then I took an extension cord and crimped 3 fork connectors on to the 3 wires. You can then connect the 3 wires from the extension cord to the switch, slide switch into the outlet box, wires out through slot and then place a cover plate over the switch holding the switch inside the outlet box with your hand and now you can toggle the switch in safety.

@mrcorvettegolfer Zwave devices generally want to be paired where they are installed, so as to build the appropriate neighbor links and the like.

Probably the best wasy to do Zwave is build out from the hub. Pair and install the device closest to the hub,and then move outwards. It is also probably a good idea to run zwave repair after each installation so as to update all the routing tables.

Or so I've read on these forums!



I had setup my first Simple lighting task. #1 plug which is 10 ft from hub worked perfectly. #2 which is 35 ft from hub and 2 walls did not. I checked the app and time on and off were correct. What next?

Are you able to control the plug from the hub at all, just by toggling on/off in the interface?

And just to go back to your previous question:

The plug will go restore the last on/off status once power is back. If you'd like it to stay off or force it to on after the outage, then you can change that in the advanced settings.