Zone Motion Controller (built-in) Errors

I’m using ZMC to aggregate ~15 motion sensors into a single virtual whole house motion sensor for a variety of purposes. It’s configured as Motion Aggregation with 5 min activity timeout.

I keep getting this error continuously. Any ideas?

errorjava.lang.Exception: Unable to aquire lock to schedule run once for zoneOff on line 257 (inactiveHandler)

@bobbyD, no ideas from the community as yet. Since these errors are from a built in app, can you help please?

I built a similar set on my production hub with 24 sensors, it's been running since this morning with no errors.
What platform version are you on, and when was the last time you rebooted?

I'm on the latest version -- last time I rebooted was last week. What does the error mean?

It means the scheduler crapped out.
This isn't specifically related to ZMC.

If you reboot does it stop?

I just rebooted the hub again. Give me a day or two to monitor. Will revert.

EDIT: @mike.maxwell, still same errors after reboot.

@mike.maxwell @bobbyD
Guys, I've temporarily disabled this app since it's messing with the hub. But I'm kinda dead in the water without it. Anything I can try?

Have you tried deleting that zone and recreating it?

Will try

Deleted the zone and recreated. Same errors as above, repeatedly.

@mike.maxwell @bobbyD, where to from here?

The same error showed up on an instance of Motion Lighting today:

2020-12-27 11:25:10.221 pm errorjava.lang.Exception: Unable to aquire lock to schedule run once for turnOff on line 1139 (motionInactive)

The hub has slowed to a crawl and is essentially unusable. This hub has little to no custom code.

That error message seems strange for motion. Lock?
Anyway, if the error is easy to produce I would start again from scratch and introduce a couple of sensors at a time.
Wait awhile and introduce a couple more. Keep going until the error starts. Might help pinpointing a device that is causing it.

It does seem strange for motion, but @mike.maxwell confirmed above in the thread that it indicates that the scheduler crapped out -- it's not specific to ZMC. I've even disabled ZMC completely annd I'm still getting the errors and behavior described above. There is something going wrong with this hub. Thankfully it's my one hub that has very little or no custom code. Hoping someone from Hubitat will help.

At least we know it's not ZMC causing it then.

Do you have any locks?

can you post or pm a list of installed apps?

Amazon Echo Skill
Device Watchdog
Groups and Scenes
Hub Watchdog
HPM
Hubitat Dashboard
Hubitat Safety Monitor
Konnected (Connect)
Maker API
Mirror
Mode Manager
Motion and Mode Lighting
Notifications
Rule Machine
Simple Automation
Smart Humidity Fan
Sonos Integration
Average Temperature / Average Humidity

I have excluded from the list custom apps that are currently disabled.

one of these is causing the errors, i suppose it could be a device too, but lets start with disabling these:
Device and Hub watchdog, Konnected, Maker API.
As far as the others, we're looking for apps that are running a pile of schedules, you can see these by clicking the info icon in the apps list...
If still erroring, then please post a list of user device types, or PM me your hub id.

OK, disabled those 4 apps. Also re-enabled ZMC so that we'd have a clean HE install to work with.

It's still throwing lots of errors. Will PM you the hub ID in a sec.

Also FWIW, I use this as my "coordinator" hub---i.e., 4 other hubs have the zwave, zigbee, wifi, and cloud devices which are then hub-meshed to this hub for any cross-hub automation or dashboards. So I have basically no native devices on this hub, only virtual stuff. There could be 1 or 2 zwave devices and that's it. With that said, there are a LOT of virtual devices.

Oic, well that's a different kettle of bits...
What is the hub mesh sync setting Full remote device sync set to on this hub?

Download the Hubitat app