[Zigbee] Visual render for getChildAndRouteInfo

Click on the user icon and follow the links…


Awesome app. I have one question, could you add room name in brackets ()?
I have choice either too long devices names (not fitting in "Lights/switches" in native app) and possibility to indentify devices on graph, or nice names in "Lights/switches", but serious issues, to identify on graph which device where is located.

Dan, if you plan to come some weekend on the other side of the river, opposite of Giurgiu, we can have some beers, and you will get 2 or 3 Z-wave devices that are just sitting in my drawer and I will never use. :slight_smile:

1 Like

Thanks man, you have a kind heart! I don't have anything planned, but will def let you know if the opportunity arrives :+1:

1 Like

This is a great idea and I like it a lot! You are right that my devices list looks messy having the room information in their name. I was actually quite happy with my device naming scheme and now you ruined that for me :slight_smile:

Unfortunately the room information is not present in the incoming data that is used to build the graph; it can be added by the Hubitat devs though. Alternative is to find a hackish/messy way to retrieve this data.

Driver and/or Library:


This just happened to me (on Firefox 114) and in the browser console I found Uncaught NS_ERROR_OUT_OF_MEMORY. Tried to reproduce it for the next 30 mins without any luck.

I assume it's a bug in the underlying graphing library "force-graph", not sure though. Unfortunately there's not much I can do about this bug if I am unable to reproduce it.

Fun fact: while investigating this issue, I realized that the constant redrawing of the graph (for animating it) is pretty heavy on system resources (CPU and GPU) especially when the moving particles are enabled.

1 Like

Yikes... I wonder if you might want to set the default to no moving particles just to save on energy use!

This is from task manager with moving particles:

13.1% of CPU and 14.2% of GPU were being used by "Windows Driver Foundation - User-mode..." when I captured the screenshot. Both would jump up over 15% at times.

After turning off "Show link particles":

0.2% of CPU and 0.2% of GPU being used by the same process. CPU varied from 0 to 0.8%, GPU was pretty consistent at 0.2 or 0.3%.


Added a small release 2.2.0:


  • Add option to display room name in the device name (using Maker API built-in app) - @abraham


  • Show all dates using the "time ago" format
  • Move contents of the "Help" tab inside the "Status" tab

Have fun!


Ran the last update on HPM. Now get a 404 error, tried a delete & reinstall. 404 error. Any ideas?

Be sure you are on the latest version of HPM. A fix was made 2 weeks ago to fix a problem with installing files.

Screenshot 2023-06-23 at 11.32.30 PM

I am, and have been since the update was released for HPM. Still have the issue. I suspect it now can't find the html page, despite it being on the hub. I checked. IP hasn't changed.

  1. Can you find the zigbee-graph.html file in the File Manager (Hubitat UI -> Settings -> File Manager)?
  2. If yes, what happens when you click on it?

Yes, I can find it. Click on it and it runs the application, then throws the same HTTP fetch 404 error.

I've only got zigbee devices attached to the Hubitat and the only thing between it working and not is updating the app version.

File size is 55.62kb

Newer versions of the graph (2.0.0+) use the new JSON endpoint that was introduced with platform version The new endpoint is:

If you get a 404 on that (not some JSON formatted data), and don't want to upgrade your platform, you can use the latest zigbee-graph.html file version that still uses the old endpoint:

On Mac you can download this file to your Desktop using the following command in Terminal:

cd ~/Desktop; curl -OL https://raw.githubusercontent.com/dan-danache/hubitat/zigbee-graph-app_1.4.0/zigbee-graph-app/zigbee-graph.html

Then manually add the downloaded file into the Hubitat File Manager.

1 Like

I don't use anything remotely mac. And I don't see a way to download anything from that site. I just see a code listing - the kind of code listing that causes all sorts of issues being copied and saved and is a genuine PITA that is more than I can cope with right now.

If I clear the html out of the hub memory and then reinstall the app will it upload the correct one to replace?

My Zigbee hub is on platform v2.3.5.152, so it has the new endpoint. My version of HPM is 1.8.9 on that hub, which does not have the InstallFile fix and HPM did install zigbee-graph.html, but poorly:

Screenshot 2023-06-24 at 8.43.18 AM

Clicking on it causes it to run, but there are no log errors of any kind. In other words, I can't duplicate it, even using an out-of-date HPM. You said you're up to date, but I was curious to see the error.

The Repair button in HPM does that.. it pulls in all the files and overwrites them.

I believe the problem is not with the delivery of the html file by HPM. @RosieUK said the file is present in the File Manager and confirmed that it has the correct size (55.62kb) so no problems there.

When the HTML page is starting up, it tries to get the data for the graph. In versions prior 2.0.0, it reads the data from http://hubitat.local/hub/zigbee/getChildAndRouteInfo. Then the Hubitat devs integrated the Graph in the platform and created a new JSON friendly endpoint: http://hubitat.local/hub/zigbee/getChildAndRouteInfoJson (see the "Json" at the end).

Version 2.0.0+ was a major rewrite and the graph now uses the new JSON endpoint that was added in Hubitat version If you run the Zigbee Graph version 2.0.0+ on platform versions prior to, you get the following error:

I think that this is what is happening to @RosieUK.

1 Like

Small release 2.3.0:


  • Add feature to filter the devices list (idea by @jonathanb)
  • On the devices list, click the eye icon to zoom the graph on that device (idea by @jonathanb)

Have fun!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.