ZigBee Pairing Failure?


#1

Working on getting additional types of Securifi devices added to my Securifi Sensors driver. However I am running into problems with a couple and I am not sure what is going on. When I attempt to pair the devices they are recognized by the hub and added however the devices themselves still blink as if they had not completed pairing (when they DO pair normally with another hub the LED goes off almost right away).

Further, the devices never respond to anything they are supposed to and do not provide any status EXCEPT to report ZigBee clusterId 0013 (from what I read this cluster is used for devices to identify themselves to a hub and indicate what they can do). Here is one such log entry from a keyfob:
Keyfob 1, parse description: catchall: 0000 0013 00 00 0040 00 CB8A 00 00 0000 00 00 BA8ACB2DD74F04006F0D0000

So it seems to me like the hub and device are not actually pairing. I have removed them and tried again multiple times. I have tried having them pair again while already paired... Same end results every time.

Does anyone have any ideas for solving this or insights?


#2

I fooled with the Securifi SZ-WTD01 water sensors on Vera, Home Assistant, and Wink and could never get them working so I wasn't surprised when Hubitat couldn't discover them. I suspected that the sensors were not receiving back either a confirmation or configuration details and I just found a work-around solution.

The trick is to exit the incomplete pairing process and send a configuration instruction to the device while it is still blinking. They seem to wait at least two minutes before timing out.

During Discovery, after Hubitat finds the device, name it and save the device. Note that the device will continue to blink and Hubitat doesn't assign a driver type. This is where pairing normally fails.

While the sensor is still blinking, navigate to the Devices page and select the device just added. Change the device type to the closest matching Generic Zigbee device type and save the entry. Once the entry is saved, click on the Configure tile at the top left. The Zigbee device indicator should stop blinking and the device should then work.

I hope this event sequence will help suggest why the discovery doesn't work with the generic Zigbee drivers. Please let us know if you figure out more.


#3

It is as good a start as any to trying to figure this out. Thanks! I will provide any progress once I have a chance to try it out.


#4

Your instructions worked perfectly. Selecting Configure within a Generic driver (I selected Generic ZigBee Moisture Sensor) got things working. It was enough for me to get these other two types of devices added to my driver and have them working properly.

Unfortunately I have not gotten the Configure to seem to work within my OWN driver for this purpose. So that is something I have to work on, figuring out what the differences are.