Zigbee network is a mess...... I think it might be because of "null" devices

My Zigbee network is driving me absolutely crazy. For the last couple of weeks, I have devices that work fine one minute and not at all the next. Then after a half hour or so, the start to work again. I spent a ton of time examining the child devices and routing table and the one thing I keep seeing everywhere are "null" devices. It seems like these are causing problems. I just have absolutely no idea where they came from or how to get rid of them. Any help would be greatly appreciated. I also see devices that are routed via themselves. I don't understand how that is possible or if it is causing problems.

I have about 110 ZigBee devices on my network. Most of them are sleepy end nodes (like contact or motion sensors) but there are plenty of routers as well.

Neighbor Table Entry
[Basement Dehumidifier, 0396], LQI:255, age:4, inCost:1, outCost:1
[Kitchen Wax Warmer, 1C20], LQI:254, age:4, inCost:1, outCost:1
[Tool Room Work Bench Light, 2C53], LQI:251, age:5, inCost:3, outCost:1
[Blue Room Wax Warmer, 3C1F], LQI:254, age:4, inCost:1, outCost:1
[Sunroom Dimmer Outlet, 63A0], LQI:255, age:4, inCost:1, outCost:1
[null, 6405], LQI:255, age:0, inCost:1, outCost:0
[Living Room Wax Warmer, 644E], LQI:254, age:4, inCost:1, outCost:1
[Christmas Tree Lights, 6AED], LQI:254, age:4, inCost:1, outCost:1
[Office Table Lamp, 7F77], LQI:255, age:4, inCost:1, outCost:1
[null, A85E], LQI:255, age:4, inCost:1, outCost:1
[Pool House Speaker System Power Switch, C840], LQI:128, age:1, inCost:7, outCost:0
[Basement Wax Warmer, DC71], LQI:255, age:4, inCost:1, outCost:1
[Garage Air Circulator, F2B4], LQI:254, age:4, inCost:1, outCost:3
[eBay Room Remote Outlet, F55B], LQI:255, age:1, inCost:1, outCost:0
[Blue Room Mantle Lights, FFF2], LQI:255, age:4, inCost:1, outCost:1
[Basement End Table Lamps, FFF5], LQI:254, age:5, inCost:1, outCost:1

Route Table Entry
status:Active, age:64, routeRecordState:0, concentratorType:None, [Kitchen Motion Sensor, B7CD] via [Blue Room Wax Warmer, 3C1F]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Guest Bathroom Window, 3E40] via [null, 8C17]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Logan's Presence Sensor, 46DE] via [null, 86D3]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Tool Room Work Bench Light, 2C53] via [null, 41B1]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Master Bathroom Door, 6246] via [null, 793C]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Logan's Bedroom Table Lamp, DAE8] via [Living Room Wax Warmer, 644E]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Blue Room Wax Warmer, 3C1F] via [Blue Room Wax Warmer, 3C1F]

If you go to the devices page and in the search line put in the alpha/numeric code does an actual device show up?
6405 or

No, they don't show up in my actual device lists. Only in the routing table.

Oh dear.
I assume they do not appear in the zigbee menu either.
I would contact support to see if they can identify what is going on.

I have an email in to them. Waiting to hear back.

Zigbee bulbs acting as repeaters can cause havoc on a Zigbee mesh. The Sengled bulbs do not repeat and are not a problem, but most others do. It's best to put them on their own hub or hue bridge so they are on a seperate mesh.

I represent that comment! Sounds like me a few months ago. I had similar issues from removing devices without excluding them. I worked with support to resolve. I won't say what they had me do because your situation could be totally different from mine. I can say that they'll get you sorted out fairly quickly, though.


On your zigbee network? How exactly do you exclude a zigbee device?

The zigbee bulbs were a big problem for me in the past. I have since replaced them all with either z-wave in wall switches or the Sengled bulbs. My zigbee network was running great after that!

My Zigbee network was a mess until I did a couple of things:

  1. Removed all Hue bulbs and use them through the Hubitat bridge App
  2. Added multiple Zigbee plugs to act as repeaters for the Zigbee network
  3. Made sure Hue and Hubitat were using different channels
  4. Updated all the Hue devices firmware (I have 2 outdoor sensors and a few battery powered remote/dimmer switches)

Since I did all that, I now have 25+ contact/motion sensors that run flawlessly.

1 Like

I believe that "null" that you see, is actuality just a device label. Check all you devices make sure that both name and label are set.

I don't have any Hue devices running on my network. Its mostly Bosh motion sensors, Visonic contact sensors, and GE/Jasco plug in Zigbee dimmers/switches. There are a few Samsung devices mixed in here and there as well. I also make sure that all of my devices have adequate access to repeaters. I only have one device that gets below 240 on the LQI. Odd as it may be, that device seems to work fine..... I transitioned to HE from a SmartThings hub over the summer. Did a lot of research before setting it up and decided that frequency planning was a must based on what I had read in these forums. I keep my Zigbee network on channel 11 and all of my wifi on channel 6 or above. That should have eliminated any possible wifi interference. Also worth noting that everything was running great until a few weeks ago.

This one really has me stumped.

When I look at the devices on the Zigbee Settings page, I see all of my devices with the correct labels. None of the device id's match what is associated to the "null" devices. Are those device addresses hard coded on each device or are they set as part of the pairing process?

I would consider moving the channel upwards closer to or at 20/21. Check your WiFi router and make sure the channel width is at 20 and not 40.

1 Like

I would then try to create two new virtual devices, Make Zigbee addresses 6405 and A85E , then remove devices. That should remove them from Hubitat.

That was an idea I hadn't tried. Started to write down all of the addresses a had associated with the "null" items in the child object page. In just the few minutes that I was watching, (maybe 6 or 7 page refreshes), I wrote down 17 unique addresses associated with the "null" devices including one of 0000 which I though was reserved for the hub. I went back and checked these address against a device list capture I did about 30 minutes ago and found some of the addresses on that list associated with real devices. Only now, when I look at the current device list, those devices have new addresses.

It looks like my devices are constantly changing addresses and the "null" devices are stored routes left in the routing tables until they purged when a device runs a new discovery scan.

This is a new piece to the puzzle but doesn't make me any less confused. How can a device address change every few minutes? It looks like a bunch of my devices are doing it.

@bob5 have you contacted support?

One other thing I do is run a custom app that โ€œrefreshesโ€ all my devices (one every five minutes, in a 60 minute round-robin). Some of the Zigbee devices do not communicate with the hub unless certain things happen (temp change, motion, contact). My window sensors were losing connection all the time and required pulling the battery every now and then. Once I started refreshing devices there were no issues.

I have an email in to them now. Only sent it yesterday so I don't expect to hear back until tomorrow at the earliest.

That's a lot of devices, @srwhite divided the devices between 2 hubs I believe and he got better results