Zigbee mesh

Quick question.
I'm having devices dropping out. I paired them to the hub before I learned about repeaters. I've added some repeaters to try and strengthen my mesh. My questions is, so I need to unpair everything and start over adding repeaters first? I'm still having devices dropping out.

No, don't do that.

The devices should just pick the repeaters up after a time. You can put them into panic mode and reset the routes by doing a shutdown from the Settings menu, unplug the hub for at least 20 minutes.

You can also see if the devices are routing by going to http://(enter your hub IP address here) /hub/zigbee/getChildAndRouteInfo

This isn't a complete table of all Zigbee devices, just the first hop. But it can give some idea. (How to Read Hubitat's Zigbee Routing Table - #4 by njanda)


@user1352 Also what brand/model devices? Some zigbee devices don't follow the zigbee specification properly and will drop without certain reinforcement. (I'm looking at you Aquara!)


They are Iris window and door sensors. Im changing over to sonoff. They seem to be more reliable. Im grabbing at straws at this point.

Which Iris sensors? There are three generations of Iris sensors. All of which should work well with Hubitat.

What zigbee repeaters do you have (brand/model)? How many sensors and how many repeaters?

1 Like

Second generation iris sensor. I had about 15. Im now using sonoff window sensor , but im still having drop outs.
My repeaters are sonoff zigbee plugs. About 8 of them.
Thirdreality plugs. About 4 of them.

I just switched my phillips hue light over to their separate bridge

Put your zigbee mesh into panic mode. That should help the end devices find routes back to the hub through your repeaters.

To put it into panic mode, do a shut down off the hub through the menu. Then disconnect power to the hub from the wall outlet end (not the micro USB end). Wait 20-25 minutes, then power the hub back up again.


Ive unplug several times. I didn't do a shutdown first thought. Ill give it a try.

Always shutdown before disconnecting power. And, removing power for >20 mins is essential for a mesh to enter panic mode.

The disclosure that you haven’t been shutting down before removing power raises another possibility - that your hub’s database is corrupted.


If so. Is it fixable?

Yes. Look at the documentation on performing a soft reset followed by a database restore.


Goto settings>>backup and restore.

At bottom click the download button and save to your local pc

goto yourhubip:8081 and click on soft reset.

Upon reboot when prompted use the backup you made to your pc


Thanks for the help.