Zigbee LED Controller (Tuya) not working

So I had a Zooz RGBW controller, but it kept turning off after a few days and I had to reset the whole thing. Got tired of that, so I picked up this Tuya C05Z Zigbee controller from AliExpress. I managed to add it as a device, but I'm hitting a wall with the drivers. Tried the Generic Zigbee options like Bulb Dimmer, RGBW, and Switch, and even gave the Advanced Zigbee ones a shot. But no luck, nothing's working. Any ideas?

Once you change the driver, do you press the configure button? That can make a difference.

Also, with some Zigbee devices, pairing right next to the hub can help. Not sure if this one falls in that category.

I joined my RGBCCT LED controllers with Hue and that has worked very well for me. Then I use the Hue integration to bring them to Hubitat.

Yeah, I did that but no change. I see NULL on device info as well as logs. I can try to reinstall it close to the hub after resetting it.


That would be the next thing I would try.

If others in the community are pairing it directly to Hubitat, they may recommend a driver that works for them.

Change the driver to the HE inbuilt driver named ‘Device’. Click on the ‘Get Info’ button and copy/paste here the 4-5 lines that will appear in the live logs.

Press F5 in the browser to refresh the device page. Will the Device Details- Data section be populated with the missing now’model’ property?

Stuck at 'getting info for unknown Zigbee device...'

Not much change

Seems like it is not communicating to the hub at the moment..

Delete it “Remive Device “ red button and pair it again, close to the hub.

Just did that, moved it close to the hub and repaired and that seem to have done the trick. Got paired and generic zigbee dimmer driver working now.

This was the device info btw :
fingerprint profileId:"0104", endpointId:"01", inClusters:"0003,0004,0005,0006,1000,0008,0300,EF00,0000", outClusters:"0019,000A", model:"TS0505B", manufacturer:"_TZ3210_ijczzg9h"