Zigbee device won't update their status


Using C8-Pro with firmware
Since updating to 2.3.9.X firmware some of my zigbee devices are not reporting their status after sending command (from hub). The devices change state (light turns on) but the status of the device stays off. commanding "off" turns off the light.
this affects automation that depands on the device state.
If I press "refresh" button the status changes.
Before upgrading to 2.3.9.x everything worked fine.
I tried "rebuild network" and tried re-pair the problematic devices - didn't help.

Please advise what to do.

Did you try pressing the "Configure" button in the driver of the wayward devices? This will make sure the device is working with the assigned driver. Also make sure you are using the "best" driver. In some cases, that might be a community developed driver rather than the one built into Hubitat.

Thanks for the reply.
The weird thing that everything worked fine before. I didn't change anything, juat upgraded the hub to a new version.

It's like the zigbee network is not working right... Is there other troubleshooting I can do?

Use the diagnostic tool to roll back to the prior platform you were running to confirm if that fixes the issue.

I never done rollback - sounds like a risky action...
Do you think I can rollback to 2.3.8.x? There were big changes from this version.

You can roll back to (hopefully its in your list), I would not go back to anything else in 2.3.8 since there was a zwave logging bug which could cause a runaway log file. If its not in your list you can run this endpoint to download it (it will spin for a while while downloading).

If you have added any EZ Dashboards they would be lost when you roll back, if you have added any Z-Wave Long Range devices they would not work.

You can also take and download a backup before rolling back, in case it makes things worse you can update again and restore the backup.

I have done this before to test something, went back to 2.3.8 then updated again. Only thing I noticed was my one EZ Dash I had made for testing was gone.


One simple thing you can try is just shut down your hub and then pull power for about 30 seconds and then plug it back in again. That will clear the radios and in some cases can help.

So I tried both - I reverted back to and tried shuting down the hub and pulled the power off.
It is acting the same - controling zigbee devices with delay and no status feedback from devices...

I am trying to control a device that is 1 meter from the hub - it only turns on if I press multiple time the "on" button and it doesn't update it's status to "on" on the GUI (stays "off").

What else can I do? It is very frustrating...

Could be either channel interference, or on of your devices is hammering the mesh with messages.

What channel is your 2.4Ghz Wifi on and what channel is Zigbee set to?
Also you can open up the Zigbee logs and let it sit for a couple minutes, see if any devices are spamming messages out.

Wifi 2.4GHz channel is 8 (the router is 5 meters from the hub).
Zigbee channel is 20 with power level 8.

I inspected the logs - not seeing a lot of traffic.

Those two channels are right on top of each other.
Wifi should be set to 6 or lower if you want to use 20 for Zigbee, otherwise 25 would be good for Zigbee. Zigbee 26 is not recommended as it is power limited.

I have just found out there has been a rash of issues with channel 20 recently. Try switching to channel 25 and see if that helps, it will also get you away from the Wifi channel at the same time.

It might take some time for the devices to find the new channel, you can test it by resetting and pairing a single device again, which will connect to the same device entity on the hub. If that device then works the others should jump over before long.