Zigbee 4 relay card and sw

Hi, i tried to click on the configure before but nothing happened. When i enter the device now is was charged exactly as you described.
I guess it had some delay?
Anyway i check each channel and it works great!
Thank you so much!

Best regards

I bought one of these on Amazon yesterday, I should have it before the weekend. Here is the Amazon link. MHCOZY 4 Channel 12V ZigBee Relay

I did purchase one too (MHCOZY 4 Channel 12V ZigBee Relay Switch) and I'm configuring it (C7, firmware
I set this device as a generic zigbee multi-endpoint switch: OK
I can manage each relay (latch mode):

If I switch (dashboard) each relay, I have the status of each one,
If I push physically each button on the mobo, I obtain only the status of relay 1, but none of the 3 others,
I have the history on the log of every relay (pushed through a dashboard or by rule) but can't obtain a log if relay 2,3,4 are physically pushed.

incidentally, I don't know how to change the timer for the auto-switch (non latching mode). Not very important but could be interesting.

Btw, never installed any related app and doesn't have any "zigbee hub" except HE

Any clue ?

I had not tried the push buttons until your post. I can confirm that button 1 is the only button that registers status in the log. All 4 buttons trigger the associated relay.

I have not tried to change the timer non latching mode. I did see somewhere it was referred to as "inching mode" I'll try to look through my research and see if I can fine how to change the mode and timer.

Hi Everyone,
I too have purchased the above 4 channel zigbee relay and were been able to get this paired using the latest HE firmware with HE reconising this device with the 'Generic Zigbee Multi-Endpoint Switch' driver (as expected)
My problem is two-fold

  1. child devices (3 other relays) are not showing up within the driver settings
  2. The basic on/off button within the driver is not switching on/off the relay

If l change the driver to the Generic Zigbee Outlet, l can switch on/off 1 of the relays, but again the other child devices/relays are not being displayed

Would anyone please have a driver that works this device or is there some sort of trick to pairing this device in order for the child devices to be recognized?

Thanks in advance!

Mine is and the generic multi end point was OK. (try to update)
I remember it took a while until configuration was correctly defined. (It may need a restart)

Anyway all 4 of the push buttons worked before I configured the device. Did you check it?

I now have a new problem with this board.
After a day or so it freezes and you can't control it via dashboard, also all rolls can't be applied.
After I plug it off and on again it will work again for another day or so....

Did anyone encounter such a problem with that board?

I am getting the same as Carnsew, using firmware

I just can't get the driver to create the child devices!

Hi Everyone,
I have managed to get these working with the child relays being displayed
What l did, was to change the driver to use the 'Nue Zigbee Dimmer' and wait 1 minute which then produced the child devices (relays)
I am currently on and have since changed the driver back to 'Generic Zigbee Multi-Endpoint Switch' which is still working as expected. I suspect the most recent firmware update has fixed this issue.


1 Like

Yeah, there's a bug (failure to create child devices) in the 2.2.9 driver specifically and only in regards to the ewlink/mhcozy brand devices, this is resolved and will release in platform 2.3.0

1 Like

What is the release schedule for 2.3.0? Or is there another work around, changing the driver to Nue Zigbee Dimmer didn't work, presumably that worked on I see references to rollingback firmware updates but I can't the option anywhere?

Rollback option is on the Diagnostic Menu -> http://yourHubIp:8081

1 Like

There were no changes to the Nue driver in 2.2.9.xxx so rolling back isn't going to do anything. 2.3.0 beta just started, so release will be soonish probably.

1 Like

Yer I found the option but the only firmware on the hub was and the Nue driver workaround didn't work.......

I bought one from Aliexpress. It came in a Tuya box. I got the model with the plastic enclosure with the 7-32V AC/DC input and 5V microUSB input.
The plastic enclosure is labeled:
Model: ZG-003-RF

Hubitat reports the following:
model: TS0004
isMultiEP: true
manufacturer: _TZ3000_u3oupgdy

I'm running on a C-5.
At first I paired it and just left the HE self assign driver type to "Device". Which was misidentified. That got me into an issue where it wouldn't populate the children node. Then I saw this thread
and changed it manual to "Generic Zigbee Multi-Endpoint Switch". Hitting Configure and then rebooting my C-5 hub didn't populate the individual endpoint children. What did it for me was to hold down one of the relay input buttons for 10 seconds, and then start another "Add Zigbee Device" config cycle on the C-5 without deleting the instance of the parent device already configured in software as the "Generic Zigbee Multi-Endpoint Switch" so HE would not identify it wrong again. HE recognized that it was already previously paired and gave me a "Dismiss" option. Then I got out the Zigbee pairing mode, and I finally saw HE recognize the other nodes as EP01, EP02, EP03, EP03 and something called EPF2. I have no idea what the heck EPF2 is or what it doesn't but HE thinks its a switch. If anyone has a better clue, let me know.

found another thread which explains EPF2.

Hey guys, I bought this exact same 4ch relay board and Im playing with it a little bit, for me it works ok, Im experiencing something that really dont know if its a configuration issue or more like a driver issue; so, keeping it simple I have configured when door contact 1 opens then close relay 1, and when door contact 1 closes then open the relay 1, same thing with 3 more door contacts and the other 3 relays respectively. The problem comes when I open door contact 1 and then open door contact 2 without closing door contact 1, basically relay one should stay closed until I close the door contact 1 but instead it opens one relay to close another one. I hope I explained it easy enough, any thoughts??? Thank you guys in advance.

This relay board has 3 different relay activation modes, which are switched (rotated) by pressing the push button on the board... Which mode are you using? (Inching, Self-locking, Interlock)

Well, let me tell you I didn’t even know that, how can I verify what mode am I using?

Well, my dear friend, that solved my “issue”. I went and played a little with the switches which I didn’t do in the first place and now I understand better the functionality of the board. Btw, I bought it on Aliexpress for $16 and I got it in 10 days, not bad. Thank you @kkossev and thanks to the hubitat community for helping me out.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.