ZEN30 child device questions

What driver should be listed for the ZEN30 relay child device? The default, based on my experience installing it, is "Generic Component Central Scene Switch" which seems counter-intuitive. I would have expected to see one of the switch drivers there. To validate, I went through a few iterations of factory-reset and reinstall and this is the driver I get every time. Wouldn't care much if it actually worked, but fan works only with manual button push. Programmed light controls work fine, just no fan.

Also, is the device expected to show up both as a child under the parent device and as a primary device in the Devices table?


I’m using @jtp10181 zen30 driver for mine. You can install it from the Hubitat Package Manager app. The relay uses a child central scene switch driver. You could try installing Jeff’s driver for both (make sure you hit “configure’ after the driver change), then deleting and recreating the child device to see if it fixes the problem.

The device should work with the built in drivers, so this is probably a new revision of the Zen30 @bcopeland

If you have a new 800LR model, Zooz had to make some endpoint changes so it would meet Z-Wave specs. That would explain the issues with the relay button.

I am in the midst of overhauling my switch drivers but I did a quick patch for the ZEN30 800LR which is confirmed to work on both the old model and the new ones. This is outside of HPM and my normal github repo for now. Details are here: [DRIVER] Zooz ZEN Switches Advanced (and Dimmers) - #448 by jtp10181

If you dont have an 800LR model you can try my published HPM driver and it should work.

The "Generic Component Central Scene Switch" driver is correct, it is not only a switch driver but the central scene implies it can handle button presses as well. I have a custom child driver in my package as well but the only purpose is to change the capabilities so it shares out to Alexa and Google better (lets you change it to a fan device).

For the duplication you see, that is in the ROOMS page, not the devices list. In Rooms if you have both the parent and child selected for the room, the child will show twice as you have shown. I guess its sort of a bug in the rooms view. @gopher.ny not sure if it would make sense to NOT nest the child devices in rooms and only show if they are also set to that room???


I must have that model since the new drivers fixed it. Thanks!

Now that I have an out-of-cycle driver over top of the HPM version, do I need to take precautions to make sure it doesn't break with an update? My hope is that the next HPM update will include the changes in the beta driver so just update as normal.

The bit about hitting Configure was the magic sauce for me. The beta driver doesn't have an option to delete/create the child device but Configure (and rolling in the HPM-supplied child driver) did the trick.

Thanks, guys! Now I'll go update the other two of these switches. :slight_smile:

Yes, the next HPM update will include the beta fix plus back end updates on my code. I need to hurry it up, I was trying to avoid two quick updates on HPM by releasing that 800LR fix on the side.

I removed the child commands in favor of just having it be automatic with the configure option. If you do need to remove the child and re-create it, you can switch to the "Device" driver, and it has a command to delete all child devices.

1 Like

Perfect, thanks!

It worked perfectly so, no, but good to know just the same.

Thanks for all your work on these and the other drivers, and the support here in the forums. I was a bit hesitant about migrating to Hubitat until I dug in a bit and realized that the community support here is generally better than I was able to get from {insert commercial hub vendor name here}.

1 Like