Zen Thermostat Temperature is wrong after update

Just updated to 2.1.1 and now my thermostat is reporting incorrectly.

Devices view of Zen Thermostat image

It will not accept a normal temperature (72-78*)

that temperature is the temperature pluto

1 Like

If my cryogenic storage fails, I’ll be over.


what app are you using to set the setpoint?
There were no changes to the build in zen driver in 2.1.1, I use a rule to set mine, and it's setting and reporting properly...

I am using the Hubitat dashboard with the Thermostat tile

ok, can you try changing it from the driver details and let me know the result?

I did that and mentioned it in the OP, it doesn't accept/set a temperature correctly.

after clicking "set cooling setpoint"

Hope you get this fixed soon. Temp set for approximate liquid nitrogen. Not my favorite environment.
(sorry, the devil made me do it)

1 Like

pull it off the wall, remove and then replace the batteries, put it back on the wall, then hit refresh in the driver...

It’s powered by the C wire. Both Zen thermostats are reporting crazy numbers.

ok, did you pull it off the wall anyway?, in other words, reboot it

Rebooted it by pulling it off the wall, removed the batteries for 30 seconds, put batteries back in it, put it on the wall, clicked "Save Device" then tried to set the temp to 72, clicked "set cooling point" and same thing -345.7

Very very strange, I can't replicate this.
Can you enable debug logging in the driver then screen capture the live logs for one of the thermostats when you make a cooling set point change?
Once I see the data from the device during the setpoint change, maybe that will shed some light on this...

Thanks, but unfortunatly i cant read the data, i just need a static screen capture of the live logging.

Is this what you are looking for?

1 Like

yes, perfect thanks.

My Zen is reporting -557.8F temperatures right now after updating and rebooting my hub the other day. I noticed on my dashboard that the temperature had not budged from 79.2F for 48 hours, so I tried to force a refresh on the device page. This was the result.

It was reporting regularly before, and had reasonably accurate results, I'd say. Now it's just hung up. Version

this isn't related to the driver or platform version, try rebooting the thermostat, pull it off the wall, pull the batteries wait a few seconds, then put it back on line.

HE approved :slight_smile:

1 Like