Z-Wave security

I am using C-7 and UltraPro Z-wave Plus switches, model ZW4008.
I currently have 4 of these switches. All are working as expected. I've configured C-7 to do what I want with them.
However, if I look at Z-Wave Detail in settings, all four show None in security column. I was expecting to see C2.
I read a post about leaving C-7 powered down until devices panic, did so for an hour, but that did not help.

Any recommendations?

That is advice for Zigbee.

For ZWave... Security None is ideal for most homes. There are several more Security levels, S0 and a couple of S2. You want to avoid S0 if you can, and you have so that's great. S2 is a much better security option, but if you don't need it then your mesh will have more room for the functional traffic and not filled up with security exchanges.


If you really want to pair them with S2 Authentication you’ll need to remove, exclude and re-include them as the security is established at pairing. Having told you this, I’d recommend, that unless there is a strong reason for doing this, that you leave them at security none as they will generally respond quicker and your mesh will have less load. In general, pairing with security is only recommended for border devices like locks, garage doors, etc.

1 Like

Thanks !
Your points and @csteele are taken.
I would like to try to configure a switch with C2, at least temporarily as a learning exercise. When I paired originally I did not see any options for pairing with security. How do I go about doing that?

Thanks in advance.

You mean S2 but if the popup offering the Security offerings didn't appear during an Include, then the device doesn't support S2.

But if you wish to try again, then you will need to Exclude a device, then Include it again. There should be a popup offering Security or "Skip"... click the security you want , but if you click Skip, then it joins as Security None.


The issue with the pairing and enabling S2 security appears to be due to using Windows10 computer/Chrome browser. I had noticed the pop up windows did not appear to allow me to click on the buttons. Using Android phone, the option for S2 does work properly.

Thanks all,