Z-Wave - Replace is NOT Running

I had a Z-Wave switch go bad after a power failure (one of those GE Switches that failed a lot).

In the past I have gone to settings/Z Wave Details - and then "Repair" and then I would get a "Replace" option. And that worked just fine.

So I removed the switch, and put in a new one, went to my Hub and tried the repair/replace and it wont work. Any time I hit "Replace" it says "Replace is NOT running status: failed" I rebooted the hub, I updated to the latest firmware, and I always get the same response.

Any ideas? would moving the hub closer help? (not sure why that would matter).

Any thoughts on how to fix this, or another work around?

Please be gentle, I have not done much in the world of Z-Wave logs or troubleshooting...

C7 Hub ver

Shutdown hub and unplug for 30 seconds. Plug back in and try again. This is the only way to restart the zwave radio.

Another factor is Time. The actions that Replace is built upon exist only out in the ZWave Radio SOC and it isn't on anyone's chart for the worlds fastest computer. If you started a replace, it might not have actually finished because the hub has very little visibility into how far along the communications are between the Radio and the device. Retries, speed, hops all contribute to slow completion. If you then click Repair again, it's been my experience, that it takes even longer to actually complete. I've done this to myself more than a few times and I now have a long pause inserted into my process.

1 Like

I have done replaces 4 or 5 times in the past in hubitat with no issues, so I know how they work (or are supposed to work). I've also done it maybe a dozen or more times on other hubs.

I tried 5 different replaces the other week on my C8. 0 out of 5 worked. It would start, then eventually fail. After it fails you have to shutdown hub and remove power before it will even let you try again.

Never did get the replaces to work. Just removed the old failed devices (pc controller w/zwave USB stick) and paired the new ones (which worked as expected), and then fixed my rules.

1 Like

I did try that already actually unplugged for about an hour, then let it spin up for another hour.... Stil didn't work...

I will try something different and report my results.

I will unplug for 15 minutes then then re-power. Then wait 15 more minutes and hit repair.

Then I will wait another 15 minutes before I try replace...

If that doesn't work, I will try moving the hub closer and try it all again...

and I will report back results.

I am hoping that I don't have to remove and then pair the new one. I have some rules, but I also have Alexa connected up and that just gets ugly and time consuming to keep that clean :slight_smile:

Swap Apps will fix all that with one click if you have to pair as a new node.

1 Like

Is there a way to do that where I can not change the name? For Example, my problem switch is node 16 - Stairway Lights.

If I add a new switch, is there a way to name it the same thing and then still "swap" the old for the new? Or is there a way to do it using the node number as the reference?

Make note of the DNI for both, because that will be what stays the same and links it back to the old vs new device.
Give the new one the same name before you swap it.
Then you can remove the old one, verify it is the correct device entry with the DNI and also the "in use by" at the bottom should now be blank on the old device.

I am pretty sure I did this once with an Alexa enabled device and it didn't skip a beat.

So just to make sure I understand...

Look a the DNI (Device Network ID) of the old device that is not connected any more and write it down.
Then Discover and add the new switch, and give it the same exact name. and look at its DNI and write it down.

And then go to Swap Apps Device -
BUT the problem is that this allows you to pick a device, but only by name - so how do you know if you picked the old or the new for each choice? It doesn't show you the DNI.

I know that I could also just do this manually, but I would like to figure this out and then it will help others too.

Thanks in advance!

Ok yeah forgot about that part with the drop down. I usually just add "OLD" to the name right before I swap it out (or add NEW to the new one, then take it off after swapping). The name change wont propagate over to any other services automatically. Might impact a few log entries between the name change and the swap and not much else.

Just wanted to follow up - your suggestion worked perfectly.

And Alexa never even blinked.

Thanks to everyone for help and suggestions.

1 Like