Z Wave PC Controller No Longer Works


Using a Z Stick as a secondary controller no longer works. I've been using the Aeotec Z Stick for months without issue but since the last couple of updates it no longer works.

I can successfully include the stick as a secondary controller and see all of the node info. However that's about it. Adding a device via the Z-Wave PC Controller app whether by using "add" or "NWI" will only add the new node to the list of devices in the Z-Wave PC Controller app - it will not create the device in the Hubitat so I have to exclude it again. I've used this method so many times I know I'm not doing anything incorrect. I've excluded and re included the Z stick but get the same results each time.

If I can't include the device with HE and I can no longer use Z Wave PC Controller, I can't add any devices.

Edit: The Aeotec device successfully added through HE directly with security "none" as required. Could someone advise whether it's now possible to add a device to a C 7 with security set to none where S0 is available? Thanks

I just tried to use the Z-Stick myself. I had only done this once before and it was almost a year ago, but I could not get the Z-stick to pair correctly. See my post in another thread about my experience. I am pretty sure I was doing everything the same , as I had the instructions I followed last time. Not sure if related but thought I would mention I had issues with the Z-stick as well.

Mine pairs fine. The trick for me has always been to click the settings icon in PC controller app and constantly hit refresh/detect/discover until the detected Z stick shows a version number (usually missing) then click ok. After that click on network management, highlight the entry for PC controller, put hubitat in inclusion mode and click Classic Learn Mode and that’s it

Exactly what I did. HE would discover a device almost immediately. It would show found Z-wave device at ID but that was it. Never would complete. The Z-stick detected discovery, as the PC controller software would stop discovery at the same instant that HE discovered the device. HE would never give me the dialog so I could name the device. If it worked for you then maybe it's something on my end.

I don't think so. I have the 700 series from silicon labs and it used to work but no longer. I can't get any new HE devices to show in the PC Controller software. And the stick is listed in HE z-wave details and appears correctly

From that image you've selected a device driver for the Z stick "UZB 700 Series Stick". It's supposed to be left as "Device" or changed back to "Device" if a driver is selected automatically during inclusion.

That’s incorrect. “UZB 700 Series Stick” is the device name or label that @Rxich has chosen for that device, and does not indicate the driver in use.


Ooops - my bad

Yeah I left at "device", when that didn't work I changed to generic z-wave repeater, that didn't work either. Something is up. I suspect Silabs, in fixing something, they broke something else.
It did however work at removing an older device that had ghosted, but was included some 8 months ago. However any new devices paired to HE will never show up in pc controller despite running multiple updates.

I had something similar where it “seemed” that devices added/removed in were only added/removed where I’d carried out the inclusion (Hubitat or Z Wave Controller)

Where I’d included/excluded using Hubitat - the change wasn’t updated in Z Wave Controller. Update button did nothing. The only way I could force it, was to click the settings icon, refresh the com port until the controller version appeared again and then click ok. That seemed to force a refresh of the device list in Z Wave Controller. Of course that doesn’t help when the issue is in the other direction.

It’s an Aeotec Z Stick (500 series) that I use.