Z-Wave PC Controller App - Where?

Please forgive my stupid question, but I cannot for the life of me find the actual download location for the Z-Wave PC Controller installation files...

I am trying to join a Zooz ZSE40 to my Hubitat without security, so I picked up a Silabs UZB-7 to run as a secondary controller. I am following the PDF guide on setting up the UZB-7, but I cannot find the actual download location for the controller SDK to install on my Windows PC. I'm pretty sure I'm just being blind, but any help would be appreciated - thanks!

You have to sign up for an account first (it's free), but you can get it here.


1 Like

I did previously sign up for the free account, but for whatever reason, I could not find the download link I needed...thank you so much for the direct link and quick response!

Does anybody have the current link? When I follow this link it asks me to download the software first - it doesn't actually have the link. I already have to Simplicity Studio loaded - I just cannot find the Toolkit for ZWave.

On a Windows PC? Or a Mac? PC Controller isn't available in the Mac version.


I assume you mean my guide here?

Can you clarify what you were confused about - want to update the PDF if there is something that needs better clarification.

@quinnjudge The Simplicity Studio software is pretty confusing to be fair. You create an account and install Simplicity Studio 5. During install there's an option of which modules you want to install. I just installed the lot as as I couldn't be bothered sifting through all the options. I think possibly the confusion is how to start Z Wave PC Controller from Simplicity Studio. I located it and created a separate shortcut to the Z Wave PC Controller. Mine is at:


So using explorer you need to locate ZWaveControllerUI.exe in the Silicon Labs folder and create a desktop shortcut to it (I just deleted the Simplicity Studio shortcut as I don't need it)

OK, I'm officially appointing you as genius. I finally found the ZWave tools, but I had to install two SDKs to get something that looked like the PC controller to show up on the list - finally got it late last night. But finding/using the UI directly is great - turns a complex task to the simple. Now if I can only get the migration to work.....



I actually found out the the ZWave tools are not loaded when installing the SS software. During the installation process you have to select the proper SDK package (it's not labeled for ZWave, it's just the most recent GSDK) and the ZWave tools are installed with that package.

So the step from "download/install" the software to "select the ZWave Tools" has an additional step - (1) download/install, (2) select the GSDK package and install it, (3) select the ZWave tools.

At least that's what it made me do. And it's where my frustration (albeit late at night after a long day) because what I initially installed didn't have what I needed!



Odd, did not work that way for me, IRRC. (But my memory is always fragile.) :wink:

Something may have changed. I'll try installing on a spare laptop and see how things come up. Thanks for the additional information.

Oh - one question - did you install SS from the link I provided in the PDF?

1 Like

Yes. Once I got it, it worked exactly as described. That was helpful. If you're updating the PDF, you might also want to include the suggestion from @johnwill1 - find the exact UI tool and just create a shortcut to it. That cuts out most of the extra SS stuff and makes it easier to work with.



That is already in the document...under step 2 on the first page - below is what you are referring to, right?:

• Pro tip from @erktrek: Once the PC Controller app is installed you can create a shortcut to access the app directly from your desktop using this link:


Hi Everyone, I'm new here but trying to do the same as above (update firmware on the UZB-7 with Silicon Labs PC Controller) - I'm really hoping someone can help as I've spent HOURS trying to do this and i'm at the end of my tether...

After many, many steps of trial and error with this TERRIBLE software I've go to the point of trying to upgrade

And I get the error

Can’t open XModem session

I’m assuming that this is because I need the Bootloader and have therefore gone to the ends of the world to download even more silicon labs packages and build the pieces that I need for that…
I have all the files in a folder ready to go

However, when I try and run the commands that they advise, I get the following

C:\SiliconLabs\SimplicityStudio\v5\developer\adapter_packs\commander>commander device masserase
ERROR: Cannot connect to J-Link.
ERROR: Could not open J-Link connection.

I found J-link drivers in the Simplicity package and installed them and still no dice…

Can someone help me understand where I'm going wrong?!
I've literally updated firmware on hundreds of devices in my time and I have never had anything like this mess

I think you are totally in the wrong spot there.

Check out page 9 of this PDF that @danabw made up. You want the section Can I get some step-by-step help installing Simplicity Studio?

Thanks - that's a useful PDF, but I'm doing everything per that (I'm not able to share screenshots yet, but there is a section on updating the firmware) and I'm getting stuck on the step 8 where I get the Xmodem error above

Just to confirm - you want to update your UZB stick to the 7.17.2 FW, and you have the SilLabs UZB stick.

You've selected the OTW Firmware Update option on the main screen of PC Controller:

Then you browse to and select the UZB FW update file (this example is for US region, obviously):

Once you do that the UZB stick should update. I never had to do anything else, and updated to both 7.17.1 and 7.17.2.

You should not need any other files, or have to build anything.

To Update UZB Stick - US region

EFR32ZG14: https://github.com/SiliconLabs/gecko_sdk/blob/gsdk_4.0/protocol/z-wave/Apps/bin/gbl/ZW_SerialAPI_Controller_7_17_2_406_EFR32ZG14_REGION_US.gbl?raw=true
• Aeotec Z-Pi 7
• Aeotec Z-Stick 7
• Silicon Labs UZB7 (SLUSB001A) FYI - Mine is SLBUSB7000A

ZGM130S: https://github.com/SiliconLabs/gecko_sdk/blob/gsdk_4.0/protocol/z-wave/Apps/bin/gbl/ZW_SerialAPI_Controller_7_17_2_406_ZGM130S_REGION_US.gbl?raw=true
• Zooz ZST10 700

From https://github.com/zwave-js/node-zwave-js/issues/3906#issuecomment-1065109783

I'm at a loss then... this is exactly what I'm doing... :frowning:

Join the owners group and you should be able to post screen shots



Weird...I haven't heard of anyone else posting a problem w/the UZB update, but I'm not sure how common this has been.

Possibly the HE Z-Wave expert @bcopeland can help.

1 Like

Okay, lets see...
Here is the error I'm getting

Based on what @danabw said above then this should have just worked...

But because this wasn't working I've tried pretty much everything else I could find to try make this work (full rundown here!):
I assumed that this was because I need the Bootloader (per here) and build the pieces that I need for that…

However, when I try and run the commands that they advise I get the following

I found J-link drivers in the Simplicity package and installed them and still no dice…

I also set up a VM (on a different machine) and attempted update via Linux instructions I found here: 700 series Controller Firmware Updates (Linux) · kpine/zwave-js-server-docker Wiki (github.com) but also hit a dead end

Finally I've tried the TeraTerm bootloader update attempt as mentioned here (Silicon Labs Community) and also hit a dead end with the terminal unable to respond to any inputs :frowning:

1 Like