Z-wave not working?

I'm only posting here because I'm pulling my hair out right now. I had a Vivint alarm system with z-wave built-in. I wanted to switch to Hubitat for more flexibility and integrations. I mistakenly reset the Vivint panel Z-wave before excluding the devices (they call it removing nodes) but I was able to go back in and exclude each devices from the panel using remove all nodes option. the panel beeped for all the devices in exclusion mode and nothing was left connected to the panel according to it lists. I then Went over to each switch and did a factory reset. I have (2) UltraPro Z-wave plus switches and a Yale Real Living Push Button deadbolt with z-wave plus module. They all worked fine on the Vivint panel. But after all these steps the Hubitat hub is not picking up on anything in either Include or Exclude mode. After trying for hours yesterday to get it to pick up on any of the devices, I went ahead and did a Z-wave firmware update on the hub, reset the hub. and even shutdown and unplugged it for 5+ minutes about 3 times. No nodes show up in the device list and its still not registering devices. I checked the Z-wave settings and it is set to USA region and Z-wave is enabled. The logs just show me continuously putting it into include and exclude mode and timing out. Thinking maybe I was doing something wrong I went back to my Vivint panel and was able to include all the devices back on the panel without issues on the first try. So now I am thinking it has to be something wrong with the hub. By the way, the Hub and my alarm panel are within 5 feet of each other and both are within 20 feet of the light switches and deadbolt. My house is only 1300 square feet and everything is right in the middle.

1st Post a copy of your z-wave details page please.

Secondly you can run the exclude on the device itself against hubitat. (don't worry about excluding from the vivant system)

Understood, but the issue is, the hubitat exclude isn't picking up the devices at all. Thats why I did it on the Vivint panel. Exclude and Include are both not working at all.

What hubitat platform are on?

Start with factory resetting the yale assure. Then try pairing that 1st. You may have to factory reset every device..

As stated, I already did that on all devices. According to the manuals they did so successfully. See Attached below:
Screenshot 2022-04-12 at 14-15-34 Hubitat Diagnostic Tool

@bobbyD @gopher.ny

Can you power down the Z-Wave radio portion of the Vivint system?

Misspoke, the deadbolt is a Yale Real Living Push button deadbolt. I edited my OP to reflect the correct device.

I tried looking for any options that would do that but it does not appear that you can. I have the installer toolbox unlocked currently and tried every menu option. I can try powering down the whole panel but I'll have to notify them.

I flagged your post for "PHI" (personal hub information) disclosure. You may want to remove the screenshot as it contains hub ID.

1 Like

Fixed. Didn't realize that information was sensitive.

1 Like

Hub ID and MAC address can identify your hub. They are like your SSN and phone number of your hub :wink:

1 Like

Is your Hubitat hub currently powered on and connected? Being that you haven't been able to include any devices, I'd like to make sure that you are not dealing with a radio malfunction. It is possible that your Hubitat has a shorter range than your Vivint controller and you may need to move the hub closer to your devices, unless you have other Z-Wave devices that are less than 20 feet away.

Yes it is currently connected to my network switch in the media closet. I wish it had built in WiFi so I could move it easier, I can go look for a long Ethernet cable and try moving it over right next to the front door where the deadbolt and first switch are at. But I can't imagine it would normally be an issue, its somewhere between 15 and 20 feet distance direct line-of-sight.

Direct line of sight with nothing obstructing the hub shouldn't be a problem. Adding repeaters along the way, may be more aesthetically pleasing than dragging a long Ethernet cable across the room.

For the sake of argument and to rule out signal/distance issues. I have moved the hub to my computer desk which is right under the second switch. I'll update here with my findings.

Update; I was able to include that switch. but the hub and switch were literally a foot apart. I'm going to be very disappointed in this product if it can't reach a wall switch less than 20 feet away without a repeater in between.

1 Like

Do you have a notification in the upper right corner on your hub saying that is not connected to the cloud? It doesn't look like it is, from our end.

Working on fixing that, I just noticed that and apparently its a DNS name resolution error. When I set it to static IP it had the default DNS of, not sure why that didn't work but I changed it to cloud flare DNS and it seems to be fixed.

Ok, so after moving the hub and getting the Back patio switch to include, I moved the hub back to the closet and then was able to get the Front Patio switch to include. So now it seems things are working. Not sure why that was such a huge PITA but as long as it continues to work reliably I won't complain. I appreciate the attempted help. Seems the Hub has range issues, is that normal?

Is the vivant system powered down?