Z-Wave - No Discover button


Looking for help on this issue.
Migrating to C8, I'm adding some of my devices using UZB Stick to add device with no security.
I'm managing to add devices without security on with the key, but in some cases, devices are not identify in the hub and ZWave Details page does not offer "Discover" button for that Zwave entry.

My hub is up to date
How can I have the discover button displayed to have my device created in the hub.

Thanks in advance for your help

I’ve done this in the past and I seem to recall there was often a delay from the discovery with the UZB to when it was seen on the hub.

I would try shutting down the hub, pulling power for several seconds, then checking if entries appear in the Z-Wave details screen upon reboot.

Thanks a lot Sebastien.
Currently, the entry is here but the "Discover" button is not available
I've tried to full power off the hub but no difference "Discover" button is still not available

Can you explain why you are looking for the “Discover” button? If the device is in the Z-Wave list, does it have a device associated to it?

Can you share a screenshot of your Z-Wave Details screen?