Z-Wave Multi Channel (PE653)

Mine isn’t connected to the 653 but it’s something.


At the risk of being excommunicated from HE, the reference is to the ST DTH it may or may not manifest itself on Hubitat.

-121° is actually +135°. @keithriley has seen it and I think plans on fixing it in the ST DTH. I expect that also applies to the HE device (but maybe not?).

Ha, yeah we don't have that problem, at least with our built in drivers.


It is not a platform issue (common to HE & ST), just a simple Groovy DTH bug where the temperature is returned in a single unsigned byte. I already have it fixed in my new version under test.

1 Like

7 posts were split to a new topic: Is there a community repository for Drivers and Apps?

OK, as discussed (see split thread!) I've created a GitHub repo for this project which has tagged versions. If you click here you can see it:

And all the releases that have been done.

It's based on @JMack89427's repo; all I did was standardize the file name and use releases, rather than multiple files in the same directory, to capture the versions. Now anyone who wants a specific version can find them, and we can track changes to the file easily.

If you're a developer on this please DM or send me your GitHub user name! I'll make you a contributor. @keithriley it sounds like you have something ready to merge.

Do we want to go with PR review? Or just merging? Or a free-for-all on master where anyone can merge at any time?

My vote would be PRs, but no requirements for review. It's what I'm going to do. But I'm also just some guy. My next change will be to add automatic version checking like @Cobra built, and I will definitely ask for review.

I don't want to interrupt any development! If you have something to get into this repo, holler any time and I'll make sure you have access.

1 Like

I have published the latest update to the DTH. This contains the following updates:

  1. Added setSchedule, resetSchedule, getSchedule, and setVSPSpeeds commands. These are still under construction, but will soon allow control of schedules from a SmartApp.
  2. Due to different Intermatic firmware sub-versions of v3.4, alternate Setpoint “scale” if SetPointSet is ignored (“learn”)
  3. Fix negative air and solar temperature display
  4. Fix QuickGetWaterTemp
  5. Fix update of “Set Mode” labels on the UI

This version shoudl already be Hubitat-ready. Please give it a try and post any feedback.


1 Like

To those of you unable to set the temperature, this is the update you’ve been waiting for. Give v3.04 of the DTH a try and let me know if you have any issues. The link above should be HE ready.

3.04 of the DTH is non-functional on HE. I think it is the result of physicalgraph still appearing in the DTH.

Sorry about that. I do not yet own an HE unit, guess it’s about time. This is my first time making the substitutions myself (blindly). If someone can give me a list of the updates I missed I will update my script so I get it right next time. Thanks!

I tghink you simply need to replace all instances of physicalgraph with hubitat

@JDogg016, Looks like I was too specific replacing physicalgraph.zwave. instead of just physicalgraph.

Let's try this again, plus a couple other fixes: (update: DTH version 3.05)

  1. Finish off Schedule functions
  2. Possible fix to set Clock (tap the time on the bottom of display)
  3. Fix Light Color slider (@mswlogo)



@JMack89427, any chance you could help with the remaining ST->HE issues? I know you have done the port before. I don’t have an HE so i’m stumbling in the dark, one change at a time. If you could just summarize what I missed I will create a better update script to speed this up in the future. I think I already got most of it. See post 213. Thanks!

Sorry, I've been kind of out of pocket lately. Let me take a look and I'll get something together shortly.

/* Multi-channel event from the device. Version 3 of Command Class
def zwaveEvent(hubitat.zwave.commands.multichannelv3.MultiInstanceCmdEncap cmd) {
log.warn "multichannelv3.MultiInstanceCmdEncap cmd=${cmd}"

I have that section commented out in the 3.03 version so I did the same in your 3.05 version and it worked straight away. Quick test showed functionality as well but I'll need time tonight to validate everything.

Everything seemed to check out last night and I'm still running 3.05 code without issues.

Me too but I haven’t yet tried setting temperature

1 Like

So I have 3.05 and my z-wave device FW is 3.4 and I cannot control temperature. This is not a deal breaker and I think this is on me and not the device. Perhaps someone can walk me through an answer.

When I was on ST this device behaved a lot like your typical A/C unit. That is to say when I turn the heat up to 85, the Heater would turn on and heat until the pool reached 85 then the heating unit would turn off. If the pool temperature dropped to 83, the unit would automatically turn on.

When I say I cannot control the temperature. My heater says the temperature is at 80 but the pool is at 90.

On HE, to turn on the heater I turn on switch 5. This turns on the heater regardless of temperature and will continue to stay on until switch 5 is turned off. FWIW I can get my pool over 100 (that’s really hot).

Anyway, as versions prior to 3.05 seemed to have issues with the temperature switching I simply wrote RM automations around this (ie. Turn off switch 5 if temperature > 90).

Here is my question: is this my setup? Screenshots attached.