Z-Wave Lock Stopped Talking to Hub Suddenly

Updated in comments, may be a hub issue.
I've been using a Kwikset 888 (z-wave) for several years with no issues. I noticed yesterday that the lock was no longer responding to requests from the hub. Sure enough, it just didn't seem to be communicating. I replaced the batteries (though the motor was moving strong) to no avail, and then tried rebooting the hub. Nothing.

I ran a z-wave repair and it failed on three nodes...including the one associated with the lock. The hub and lock are close (and always have been), so I figured I'd factory reset the lock, run a z-wave exclude, and then re-add it. Unfortunately, when I go into inclusion mode and hit the pairing button, it never pairs.

Anything I should try before simply concluding that the z-wave radio in this lock has failed and I need to replace it?

To add to the above, it now seems my scene selectors aren't working - so something more seems afoot. This may have happened after updating to .124. I rolled back to 116 but the problem persists, so I'm now thinking it's actually an issue with the z-wave radio in the hub. Not ideal.

Highly unlikely.

Have any line-powered zwave devices been moved recently? Or removed from use?

Have you tried shutting down the hub, removing power (from the plug side, not the microusb), waiting a couple minutes, and starting it back up again?

5 Likes

To add to what @aaiyar wait about 20 mins. This will clear the z-wave radio. That said, can you post a copy of your z-wave details page?

3 Likes

This is so uncanny.. I was just fighting my own similar Z-Wave issues.

Having been around the block, I knew of shutting down the hub and restarting. I did it a few times yesterday, but finally today got it working by waiting long enough before starting it again.

This was all done remotely btw. I have my hub in my holiday home, and in front of the hub PowerSupply, I have a Tasmota plug which I can remotely accesss. So shutdown the hub, turn off the Tasmota and wait to turn on power again. This setup has worked well for working remotely.

3 Likes

Download the Hubitat app