Z-Wave issues on Hubitat C5

Hello there,

Hoping to get some ideas to resolve the numerous issues I'm having with my zwave network and hubitat. I have a c5 which I bought in Dec 2019, the first 6 months or so everything worked beautifully minimal delay processing commands and all devices were responsive and checking in regularly. But slowly over the last 3 months or so devices have fallen off the network or fail to send updates to the hub at all, I've rebuilt the network, added more powered switches/repeaters ran network repairs nothing improves.

Infrastructure explanation:

1400sqf house
5 x Inovelli LZW30-SN all switches are with 25ft over each other and no more than 1 interior wall between each neighbor switch.
8 x Inovelli LZW42 Color Bulbs
1 x Honeywell T6 Pro Z-Wave Thermastat
2 x Schlage BE468 deadbolts
5 x HomeSeer HS-DS100+ Z-Wave Door / Window Sensor
4 x Inovelli LZW60 Multi Sensor
2 x First Alert ZCOMBO

Mains powered devices such as switches generally have no issues, bulbs work but commands can sometimes be delayed 15-20seconds. Sometimes bulb commands have to be resent due to failure to process.

Battery powered devices by and large don't work, I can typically send commands such as set point to the thermastat and the device will apply it. But the thermastat never updates the hub with temp/humidity/fan/running status.

Door/windows sensors just no longer send updates.

Smoke alarms fail to send their weekly battery %.

Door locks are stuck "unlocked" and won't send commands back to the hub.

Multi-sensor will periodically send temp reports but nothing else(1-3 times a day).

I've exclude and re-included basically every device, I've moved the hub closer to the devices I'd be testing with(such as the thermostat or locks) and that device will start responding after some arbitrary time frame(1-3 days). But then other devices will just completely drop off/stop responding.

I've updated the FW of all my switches to latest beta(think it's Stable now) and bulbs. With no improvements.

At this point I'm kinda at the end of my rope, I've invested too much money and more importantly time into this project. Maybe this community will have some off the wall ideas I could try before I give it up and try a hub from a different manufacture(before just selling off this stuff and going back to dumb infra).


I think there were issues with these bulbs "overwhelming" z-wave networks. I think this was addressed in a bulb firmware update. Do you have the latest firmware on iNovelli color bulbs?

1 Like

All bulbs were updated in July to 2.30 which appears to still be the latest beta.

Thanks for the idea though.

Also look in the history log for error just incase there's something weird with your database.

Only errors reported are:

"java.lang.NullPointerException: Cannot get property 'currentSwitch' on null object on line 154 (indicatorHandler)"

Which is on a hubitat app group/scene of 4 bulbs.

If it worked fine for many months, may I suggest that you go back to a working backup and firmware from that period? Thereโ€™s no reason, unless you need some recently-added feature, that you update firmware every time a new version is released.

I can confirm that my locks quit working above 135. I have working locks on 135. I have a Schlage BE469 and two Alfred DB2's. Try rolling back to 135. You'll probably have to run a repair and spin your locks manually a few times to get them going again. Maybe reboot locks before repair.

Thanks for the info, I'll roll back to 135 and see if I can get them working.

@672southmain I unfortunately don't have a backup from that far back(probably closer to 4months ago now) . I was under the impression that Hubitat updates were more stable, if this rollback works I'll be sure to be much more cautious in the future.

Thanks for the ideas everybody!

1 Like

Me too, but this past few months has seen a lot of turmoil with the introduction of the C-7 and its different Z-Wave radio protocol stack. I believe that the Hubitat staff has been working very hard to address all the issues while preserving a common code base with the earlier hubs and drivers.

1 Like

Since 2.2.3 came out there has been a lot of Z-wave related issues/fixes. That release was around 3 months ago, which may not just be a coincidence. Check to see if you have a pre-2.2.3 firmware to test.

Nope, I have on a C-7. My difference may be that Iโ€™ve only got about a dozen Z-Wave devices, 4 of those are Ring Extender 2 devices, and only 1 non-plus Z-Wave device. Everything else is Lutron (51 devices) or Hue (on the Hue hub), pretty much. Very light load. But I have turned in a bunch of bug reports on the buggy new Aeotec Door/Window 7 Series driver. Also, as urged by April Brandt (@april.brandt), I have a beaming repeater next to each Schlage BE469ZP lock.

Yeah I rolled back to the farthest release I could which was else was later than .135), I went around airgapped my switches, rebooted the locks, and ran a zwave repair. It's been 2 days so far and all my battery devices have been reporting pretty reliably, much better than they were before.

Thanks @april.brandt and @672southmain for the ideas, I rolled back in my testing before but obviously it wasn't far enough.

Only consistent issue I'm having now is a bulb group, 1 out of the 4 bulbs will take 30-45 seconds longer to turn off or on(all bulbs are in the same fan fixture) and it's random which of the 4 is delayed. But this isn't a huge deal, I think I'll delete the group in hubitat and manage the bulb group in homekit via homebridge instead and see if the response time improves.

As far as BE468/9 I remember reading @april.brandt's posts about them when I first got my c5. So I made sure to place a switch next to each to hopefully ensure I wouldn't run into any issues.

1 Like

Good to hear things are working better for you, yeah I hope these Z-wave issues are fixed in the next release. Right now my issues were not as bad as yours so I stayed on the latest release. I still get random slowness and event storms with Z-wave devices.

1 Like

Hey everyone,

Just wanted to follow up and see if these Z-Wave issues have been fixed in a recent release?

Still running as I'm afraid of updating to an unusable version, this is also the only rollback release I have access to before 2.2.3 issues.

There were several recent posts from @bravenel regarding the issue of addressing a group of Z-Wave devices. I believe he has identified one issue and may have a "fix" in the next release.