Z-Wave Issue - Cannot add devices after reset

I have been having a lot of issues with Z-Wave devices recently. The hub was not able to control them. Z-Wave devices started having issues one-by-one. So I decided to exclude all the devices, reset Z-Wave and add them back in.

Well I excluded all the devices, reset Z-Wave with the reset command, and tried to then add (include) the devices back to the hub. Well now nothing will add (include) back to the hub.

The hub will exclude those devices. Even used another old controller I have which will also exclude and, by the way, include those devices (then I excluded again), but when I try to add them to the Hubitat, nothing.

Any suggestions at this point to get the Hubitat to be able to include them again?

Thanks!

@duffy

What platform are you on? There was an issue a bit back where it wouldn't allow you to add z-wave. Solution upgrade to current version.

That said, that's a heck of a thing to do...Likely there were either ghosts or a rogue z-wave device causing your headaches. At this point, aside from exclusion you should factory reset every device. If you have a failed pairing, stop everything and remove the ghost it likely created from your z-wave details page. Exclude and factory reset the device and then pair again. Pair any lock right next to your HE...

1 Like

I have a C7 and always have updated to the latest firmware. All devices (really just switches and a thermostat, no locks) have all been excluded or factory reset.

If Z-Wave is reset, my understanding is that no ghost should remain if there ever were any. It will just not add any Z-Wave device.

I have also tried pairing devices right next to the Hubitat. No luck. But it will still exclude any device.

I would do the soft reset and restore to ensure that isn't the problem

2 Likes

So this is a listing of what the hub see as Z-Wave devices after I excluded all and did a z-Wave reset. I thought the reset was a deletion of everything to allow you to start again.

Are all these remaining devices the issue? If so how do I delete these from the web interface? So far I am unable to delete.

All of those are ghosts. They were not created by the radio reset; most likely, every attempt you've made to pair a device after the reset has not gone to completion resulting in the creation of ghosts.

2 Likes

@duffy yeah all those need removed. They are ghosts and will prevent you from adding anything.

2 Likes

You will probably have to re-exclude all those devices again. Then reset the radio a second time. After the reset, shutdown your Hubitat and remove power (from the wall-end, not the Hubitat-end). Wait at least a couple minutes before restarting the Hubitat and then pair your z-wave devices - it should work.

2 Likes

How do I remove? I have had some success, but it does not work all the time. Sometimes I hit refresh and it gives me the option to delete. Sometimes it works sometimes it does not inspite of repeated attempts. Is there something I am missing it trying to get these all easily deleted?

Might also do a soft-reset just in case..

1 Like

Like @aaiyar is recommending - probably good idea to do a radio reset again. You aren't losing anything at this point right? As he also notes you will have to exclude all your devices and probably do a factory reset as well.

When adding them back in I would not attempt to do the locks until the other stuff is in place first. Start from the closest to the hub migrating out. If you get a device that does not pair, stop - don't move on to the next one.

2 Likes

:point_up_2:

This. Also be sure to completely power down the z-wave radio after the reset and before trying to add any devices.

1 Like

First, no locks involved. I somehow got all the ghost deleted. Then did a reset. Then 10 or so ghosts reappeared. Frustrating.

Power the hub down. Repeat the radio reset. Power the hub down again. Then boot it - do the ghosts reappear?

2 Likes

Powering down means pulling the plug (from the outlet side!) and waiting 20 seconds.. before starting up again.

3 Likes

Thanks, that seems to have done the trick and I am now able to start adding devices. First device added and it is the ONLY one is the device listing.

Many thanks folks for all the help!!!!!!

3 Likes

Go slow. If you get a failed pairing, stop and check for a ghost. Remove ghost, reset device before trying to re pair.

2 Likes

Yup, I made sure there were no ghosts after each include. Almost all devices added back in and all seems to be working great....maybe better than before the reset.

Thanks again everyone!

3 Likes

likely you had a ton of ghosts in there and that's what was farking everything up

2 Likes

Download the Hubitat app