Z-Wave inclusion issues

Hubitat version 2.1.3.128, I know this is a version back but when I updated to the latest version last week my Z-Wave devices where extremely slow and reverting back to 2.1.3 resolved that.

Last night I tried to add a Sensative Strip Guard to my system which I had finally managed to exclude from SmartThings (exclusion and pairing requires moving the magnet over an unmarked area so your never sure it will work). I joined it to Hubitat but it got stuck saying Found device with ID 37 initializing but after 5 minutes it hadn't finished and I've had this happen many times in the past so I went to the devices page and looked for the device and it wasn't there so I tried again, immediately upon starting the z-wave include it saw the device and got stuck again, I tried this about 10 times and tried to exclude it again but couldn't get it to see the exclusion so I decided to pair it to my SmartThings hub to get Hubitat to stop seeing it and leave it for now but after finally getting it paired to SmartThings again Hubitat still shows the same message each time I start a Z-Wave inclusion. I also tried a Z-Wave repair hoping that would clean up whatever is happening but this morning I still get the message that it found device 37. Any ideas? I have seen many others with devices stuck on initializing but have not seen support talk about it, and I haven't seen it get stuck detecting a device that shouldn't be discoverable any more. I will probably try bringing that device someplace far away so it can't be discovered just to make sure it isn't something in the DB.

Also no matter which browser I use (iOS Chrome, Safari, Firefox, Edge or Windows IE, Firefox, Edge) I cannot stop a Z-Wave include or exclude once they have begun without going back to another window and back, neither of the stop buttons does any more than saying stopping for a second but the timer keeps counting down.

Thanks.

You might want to contact support@hubitat.com
The inability to stop the inclusion/exclusion process is odd. I have no problems.

Thanks I did send an email to support now as well.

If you're seeing that, that's because the device is still in Inclusion mode. Which means it's probably not properly paired to ST. I would try doing a general exclusion and repairing to ST if that's where you want it paired. Remember, you can't pair it to both.

If I remember correctly when I had devices get stuck on initializing in the past the number of the device changed each time I would try again, but this device is always 37, normally I'd pull the battery to verify it stops being detected but this is the only device I have without a user replaceable battery. Tomorrow I'll try to bring the device out of range and make sure the hub stops seeing it. I know the device is paired to ST right now because I can put the magnet on it and remove it and see it change from closed to open, and I'm fine not using it at this point I just would like to get this to device 37 to go away. I have a backup I can go to as well but would like to figure this out without reverting the DB if possible.

The Strip Guard is now 11 miles away and still it shows it found device 37 when I start a Z-wave inclusion, seems to be stuck in the DB, I'm guessing I'll have to revert to a backup but I'll wait for support to respond first in case they want to see anything to see what happened as it isn't impacting anything that is currently connected.

In my experience, you need Reboot your hub whenever a ZWave inclusion fails. Then exclude the device, and then start inclusion.

3 Likes

I feel stupid, didn't think to try a reboot. After the reboot the device no longer shows up and I can stop Z-Wave includes again, both issues resolved.

Thanks!

1 Like

And I feel doubly stupid cause I assumed you had rebooted. Sorry!!

i've spent about an hour now trying to include a Sensative Comfort strip with hubitat. The most miserable part of it are the instructions. For example, the reset instructions:

Sentative's instructions


shows moving from the middle to the curved end 3 times, then letting it remain at curved end for 10 seconds

Reset instructions from thesmartesthouse.com where i bought it:
https://youtu.be/_vlJTY7DNOY
shows putting magnet 2cm from curves end, waiting for a blink, then moving it back and forth between curved and and logo twice, then rest it at curved end for 10 second until long blink

Then, when I actually try it, I don't get one blink, I usually get two, sometimes three! WTF?

Not sure which set of instructions is correct, or if either work.

I THINK i'm ultimately able to get the thing reset. Then, when I start zwave inclusion on hubitat after manually waking the strip, it will SOMETIMES show up as a found Zwave device, but shortly after hubitat says that it is initializing, the LED on the strip gives 5 short blinks, which I presume means failure.

I've reset the strip (i think) about 10 times.

Each pairing attempt shows a device with an id number 1 higher than the last. First attempt was 81- I'm now at 96!

To ensure its not a distance thing, I am trying to pair this in the same room as my hubitat.

I've rebooted my hub.

I've tried exclusion several times.

I've tried running inclusion from both an ipad and my computer.

FINALLY, I restored my database from prior to all this garbage. Reset device, included it, and it finally worked! what a PITA

FWIW. I think it would be immensely helpful to ditch this stupid magnet thing and just put a button on the thing

I completely agree those devices are miserable to mess with. Give me a button to push or hold any day.