Z-Wave going Bezerk - Unexpected fix

I have had a repeat of a past Z-Wave issue today, so I decided to do a write-up in case it happens to others.

Several months back, I was noticing some issues with my Z-Wave devices being slow or non-responsive. At the time, I had some Z-Wave mesh issues, so I figured that it was related.

At that same time, my Ring Alarm Z-Wave locks and keypad started to drop-out of the Ring Z-Wave mesh, so I called Ring support for assistance. After spending some time unsuccessfully debugging with their first tier of support, I got connected to a higher tier associate. He remotely connected to my Ring Alarm hub and was able to see a lot of noise on one of the Z-Wave frequencies. (I asked if I could have access to see that too, but could not unfortunately...). He suggested that some of the devices on my other (Hubitat) Z-Wave mesh were being noisy, and that I go to all my switches and air gap them one at a time. Alternatively, I could just power-down my house (shut down the main breaker) which is what I decided to do. Everything critical is on UPS, so it isn’t a big deal for me.

After shutting down my house breaker and turning it back on again, I was able to re-connect my Z-Wave Ring devices and the Z-Wave devices on my Hubitat mesh also came back to normal.

The same thing happened to me starting last night after I tried to update the firmware on a couple of Inovelli switches - Slow / sporadic response on devices and first the Ring keypad going offline, then during the night the locks dropped out.

I recently got a Z-Wave toolbox and could see that there was a lot of traffic on my mesh, lots of sensors sending multiple copies of the same data. I could also see that there was more noise overall on my network. The 916MHz frequency which is typically very quiet was extremely active.

As a comparison, you can see the difference below before/after I “rebooted my house”...

Unfortunately, I still don’t know for sure the cause of the issue, but I suspect some of my Inovelli switches disrupted the mesh. I’ll update this thread with future conclusions!

(I’m sure there are things I could figure out with my Z-Wave toolbox, but I’ve had it for less than a week now, so still learning!)

Have you had something similar happen to your network? Have you implement similar or different fixes that worked?

1 Like

908.4Mhz is North American Z-Wave, 916Mhz is a bunch of other stuff, but is not zwave in US.
So it would appear that you have some other device using the 916Mhz frequency band that is causing interference with your zwave

1 Like

cordless phone maybe?

1 Like

916 MHz wireless spectrum usage

1 Like

I made the assumption that both were used by Z-Wave because Ring’s upper tier support said their sensors were on a different frequency band than their locks. (The sensors worked, but just the locks didn’t...) And then in the toolbox, it shows both of them as Z-Wave frequencies.

I got curious and did a Google search which brought me to Silabs.com who have the following:


Maybe I am not reading this correctly, but it leads me to believe that in North America (USA & Canada), both are used...?

Is it possible that it is a shared band for Z-Wave and other stuff as well?

Well I don't know what that listing is all about, but our hub operates in the US at 908.4.

If the locks are Bluetooth they could run in the 916 spectrum I guess.
I might pull all the batteries in them and see if the 916 band quiets down.

1 Like

Maybe Ring operates at both fore some reason? That would explain with 916 is typically that quiet where 908.4 is a bit noisier.

The locks are Z-Wave - One of the locks that was linked to my Ring hub is now linked to one of my Hubitat hubs.

Ring support has no idea what they are talking about..

Their ring alarm stuff is US Z-Wave..

Their lighting, used with ring light bridge, uses LoRa at 916Mhz

3 Likes

Maybe that’s what the guy was thinking of. Who knows! I don’t have any of the light bridge devices though... so it eliminates that for me. :slight_smile:

Now I wonder what was shut down when I powered down the house that uses that frequency... I do have some wireless phones that we almost never use, but maybe one of the base stations was going bezerk? It shouldn’t have impacted my Z-Wave networks though, should it?

:man_shrugging: Without having the specific details of the devices .. I have no idea..

Just looking at your charts, you can clearly see the average 908 transmit power increasing over time, is it trying to overcome the higher levels of 916 traffic?
If so, it's only doing this in an attempt to overcome interference being generated by the 916 band.

2 Likes

That makes sense! I’ll be keeping an eye on it.

1 Like

I see occasional huge spikes in the 916 MHz signal. Once every 10-15 minutes.

While the signal is pretty steady at 908 MHz.

Several months ago, I found out I could get the 916 MHz spike to correlate with using the Harmony remote, which I believe communicates with the Harmony hub by BT. But today that didn't work.

I have DECT phones (I thought they used ~1900 MHz), a cell phone, and a microwave. The microwave wasn't running when this happened, so maybe the cell phone.

Strike what I said earlier.. Looks like:

9.6/40kbps is 908.4
100kbps is 916

Although the actual breakdown of these channels, I haven’t found in official documentation yet..

Also in case y’all are interested..

912/920 is the new Z-Wave Long Range

8 Likes

Learn something new everyday, interesting that zniffer doesn't make that distinction...

8 Likes

I'm sorry to revive this old thread, but, there were just too many juicy keywords that relate to my situation here to pass up.

I've been running an HE and RING Alarm system quite happily for about a year. I've got my RING alarm hub tied to my zwave locks, First alert smoke/co, leak sensors, along with ring motion and door sensors. Everything else I have, about 10 or so Zwave paddle switches/dimmers, loads of Hue, and other Leviton style plugs, Ecobees, etc are all running in HE. Everything has been quite happy. Until I decided to add a couple more zwave switches. It hasn't been the same since. I've even excluded the new switches back out to try and trace the problem and I'm still losing connection to two switches in particular that had been working fine forever. I've excluded and reincluded these Jasco Zwave paddles a few times now, repaired the network, and all seems well. Then about a day later, those switches become unresponsive again.
My question is how to further diagnose these issues? I'm not sure why after a year, things have deteriorated so much. Also not sure how adding "more" powered Jasco Zwave plus devices can impair the mesh? Finally, I'm unclear how "2" Zwave mesh networks might interact (Ring and HE)? I've moved the two hubs about 30 feet apart. (when they were working fine they were within 5 feet of each other!) Does the RING Zwave repeater also repeat HE Zwave signals? I just don't know who the culprit for my messed up mesh is!

I'm open to any and all suggestions as I really want to get things back to normal again, and ideally expand my small Zwave network on HE. It's not like I have a complicated system compared to others right?
Thanks for any thoughts,
Doug

Hi, I suspect this issue is not related - I would recommend creating a new topic to ensure it gets due attention.

Probably a Z-Wave mesh issue - could be that ghost nodes were introduced when adding the new switches. When you create the new post, add a screenshot of your Z-Wave Details page. There are a lot of people very knowledgeable on this forum about Z-Wave.

2 Likes

Thanks Sebastien,
I'm going to work on it this weekend since it's too cold to do anything else. Should I create a new topic in the Lounge for this do you think? or Developers or ?

1 Like

I would recommend using “get help”, and adding the “Z-Wave” tag.

2 Likes

Download the Hubitat app