Z-Wave failures increased, now devices are all unavailable

OK, thanks. I'll give a new one a shot tonight. But, I am seeing more situations pop up like mine while browsing here and elsewhere.

Occasionally I see pairing issues when people are slowly building out their mesh but at some point it reaches critical mass and everything just starts working better. I don't really have a feel for your layout or whatnot but generally you need a device or two within a few feet of the hub and then build out from there. After the first couple of devices range shouldn't really be an issue anymore as the newly added devices can repeat for the hub, which is why I suggested pairing in place. Newly added devices will join their partners and map out the mesh as you go. Bench pairing while making it easy initially has the added headache of screwing up your mesh. You can just as easily open the app on your phone and pair the device as you go around to each device and just use your PC to monitor the logs.

Check with your device type and see if there are known issues with them. Zooz, and Innovelli come to mind as devices that recently had firmware issues and needed to have their firmware updated to play nice with the new C7 stack.

When things were good, which covers the past several years prior to November 16, 2020 - The layout ws fairly densely packed with Z-Wave devices close to the hub, as it is centrally located in my house, and there were 20+ Z-Wave light switches installed across 3 floors, perhaps 6+ of them within 10 feet, line of sight. As you get farther away, there are fewer devices, and I have random Z-Wave outlets in locations I don't really need them just to serve as repeaters, like on the outside of the house. Once you are outside the house, I have a few things that are farther away, and these always worked well, and many of these items were the last things standing when Z-Wave went bad on the bulk of the items in the house. For example, two pool pumps (@ 40-60 feet from the house with GoControl FS20Z-1 fixture modules), a Zooz valve used to open a chicken coop door (@ 75 feet from the house), and a shed with a GoControl door switch (@ 75 feet from the house) - all worked until the end, even though they should have had no devices to repeat through any more.

When I switched from SmartThings to Hubitat, all existing devices were left in place while pairing. When initially paired with SmartThings, many were done right at the hub inside the house. When new things were added to Hubitat, like light switches in the backyard, they were done inside and then moved out. (all outdoor items are in weather resistant plastic enclosures for protection, and signal had never been a problem).

It is just frustrating that now my whole Z-Wave ecosystem is in a 10x10 room with line of sight to the hub and each of the 2 connected devices, and I have probably spent 15-20 hours trying to get more items excluded/included to no avail. Items from a variety of manufacturers, and all of which I have verified the reset, include/exclude procedures for in the past few weeks.

I get the frustration but the other hubs aren't having to deal with bootstrapping issues since they ignore any of the 700 series stuff. Hubitat is the first hub using the 700 series chipset and it's taking a while to work through all the issues that have been lurking around for a while now such as the S2 bootstrapping issues.

My best suggestion is to make sure you factory reset each device and then exclude it before attempting to join. Leave a tab up and watch the logs for busy messages. If the hub starts getting these, safely shutdown for a minute and power it back up. Then continue on joining the devices.

If you get a security message uncheck everything unless it's a lock or garage door opener. If it's a Zooz device, they seem to like S2 unauthenticated. GE/Jasco/Honeywell seem to prefer no security. Innovelli Red Dimmers seem to prefer S2 authenticated if you are running at least firmware 1.48 for the dimmer otherwise nothing.

Also seen some posts where the zooz sometimes prefer a tripple tap down instead of up.

Keep an eye out for failed pairs as you go. These can also trigger the busy messages and much easier to address when you see them than having to track them down after the fact. They'll show up in zwave details as a device with nothing in the clusters column.

I highly recommend the Z-Wave Mesh app. It will help you spot issues as you go.

2 Likes

Hubitat Z-Wave Mesh Details app can also be installed by Hubitat Package Manager.

I'll put that app on there, but it doesn't have much to see right now. Thanks.

Looking at old screenshots of the Z-Wave settings page I see my Zooz switches and multirelay for the garage doors were S2 unauthenticated, and the GE switches had nothing.

I just scrolled through the last few nights of logs and there are 0 busy messages. There are also no ghost nodes, as my two device mesh is looking good, as far as my understanding goes..

I have been trying to think outside the box for why things might not come back, including interference with other systems (disconnected the new wireless subwoofer since I don't know the technology), malware, power surge damage, bad firmware push to devices, etc, and none fit. But, could some of the devices orphaned by the reset that are still powered up possibly be causing problems? For example, could a switch that functions as a scene controller being confusing things?

Installed the Mesh Details app - looks mostly like the Z-Wave settings page - But what is LWR RSSI?

The devices will hear the other devices that haven't been reset yet and will introduce noise until they are reset as well. It's like having two wifi networks on the same channel. Not an issue if the signal is strong but as the signal attenuates, the more impactful it will become. Most digital signals aren't in the same range so other outside interference shouldn't really be an issue. For outside interference, baby monitors, microwaves and old school wireless phones are the typical culprits.

1 Like

Was just getting the generic Google definition of RSSI, but your link clarified it for Hubitat. Ran again, after toggling the two devices...

The benefit in this app is the ability to quickly see repeater pathways and neighbors in a friendly name instead of device id. The filter options are also very useful for quickly running down a list of devices based on a particular stat.

image

image

image

2 Likes

Looking at the Mesh app details I see the following:

Device is a slave (non-repeater) is shown for both. Both devices are supposed to be repeaters / extenders. Is it saying they are not?

That's a footnote. If one of the nodes was actually a slave, you would see an asterisk following its name.

1 Like

You can see the * on my slave devices in this screenshot...

Still going very poorly over here. I have spent way too much time since last posting trying to get things back online. Two Z-Wave contact sensors that were on Hubitat prior to November 16 when all hell broke loose (and coincidentally the hub started doing its series of updates) came back with minimal effort somehow. A reset, an exclude, and an include and they were both back in.

I then tried a new in the box Zooz ZEN22 dimmer that came in after about 30 minutes of trying. I was honestly giving up for the night when I got my first authentication screen and chose S2 unauthenticated. Was so excited I stayed up a bit more and got a Zooz ZEN 21 switch to include with far too much effort as well.

Get up the next morning, trying toggling both switches from the app and only the ZEN21 is functional, despite both saying OK. I leave them both for two days, perhaps meshing, repairing, doing whatever on their own and the ZEN22 still said OK but didn't respond. The ZEN22 would not exclude either, so it was force removed and disconnected electrically.

So, per the screenshot below I have 5 Z-Wave devices online and functional after hours and hours of trying. At this many hours in, I'd expect to have all of my devices in, automations configured, dashboards built, and just be back to enjoying the convenience. :disappointed:

I read of others in the same boat, that things were OK and went bad around the same time when updates were applied. Any updates coming soon that might help?

So right now pairing (some) Zooz devices with any S2 security can be problematic. All my Zen23/24s (V2 thru V4) have successfully paired with no authentication (uncheck all the boxes). They have been functioning normally for weeks. I did try and pair S2 unauthenticated as a test and it failed. I understand that driver updates are coming though so this problem may be resolved at some point in the near future.

The other issue I had was older door sensors pairing via S0 which is a less desirable security protocol as it is very chatty. The HE will force pair certain devices as S0 whether you want it or not (and even if they are NOT in S0 pairing mode). I had to use a secondary controller to pair my non-s2 aeotec gen-5 recessed door sensors as unsecured.

This has only been my experience so ymmv.

OK, thanks. If I get that far again on a Zooz switch I will uncheck all. I have tried a handful of GE switches during this time, as well as all sorts of other devices too, and for the most part nothing is even detected by the hub during including or excluding despite doing it all the same way as I always have.

Sometimes you have to do the whole "shut down/pull the plug/wait 15+ seconds or longer/plug back in" thing in order to get it to start. The other issue you could be facing are ghost devices - devices that are in the Z-Wave table but not in HE or show up as blank entries on the Z-Wave details page.

But it is so satisfying unplugging it and tossing it in the box after they way they shafted all of us power users.

I have one v2 avail if anyone wants a spare.. I suppoed i would have to plug it back in and reset it .. I only deleted the location.

3 Likes

Download the Hubitat app