Z-Wave Distance Getting Worse with More Devices

I am using a Hubitat C7 with and Inovelli Red Dimmers ("RD"), Black Switches and the Fan+Lights.

As a test I started with 3 RDs back in February. 1 is in the hall right outside the room where my hub is and the other 2 (for the kitchen and dinning room) are down a hall and around the corner from the hub. All 3 got a green light when I added them and there were no problems. They all continue to work with the Hubitat Button Controller rules I created for them. The kitchen and dinning room RDs are in the same 2 gang box.

I was able to exclude/include the kitchen dimmer to remove security. But, I was unable to exclude the dinning room, even with hub reboots (which is another story). So, just for the heck of it I did the range test and the dinning room dimmer is now failing (LED turns red right after a 5 second hold of button C (the config button) has turned green. The kitchen light continues to be green. While literally in the same box, the dinning room one is actually the one closer to hub.

Since originally adding those 3 I've added 6 other dimmers (4 RDs and 2 fan+lights) between the hub and the kitchen/dinning room gang box, so the mesh should be stronger not weaker.

Likewise I can't exclude an Inovelli Black Switch and I'm getting a fail on the range test on it as well even though it closer to the hub, passed the range test when originally included and has a RD in the same gang box that passes the range test, but is on the far side of the hub.

Any ideas of why this is happening? Other than to get a freaking long RJ45 network cord to physically bring the hub closer what can I do?

Pull the air gap at the bottom for 30 seconds, then try exclude again. This works every time with my two LZW36. Works for inclusion too.

I'd definitely try the above idea first (I only have one LZW36 but occasionally had to do this on either the LZW30-SN or LZW31-SN). However, if you did want to move the hub closer, since you're on a C-7, could use the Wi-Fi options under Settings > Networking instead of a long Ethernet cable. This requires a compatible dongle, three of which are listed on that page (though I previously used a "Wi-Fi to wired" bridge on older hubs when I had tricky devices like locks that required the hub to be nearby--with no need for any hub-side configuration, so that remains a versatile option, too). When you're done, you can remove it, and it will default back to wired.

But I wouldn't recommend this (moving the hub close) in general, since a Z-Wave Plus device that won't pair in place is unlikely to work in place, either. Pairing near the hub shouldn't necessary--but I suppose there's no harm, especially if your goal is troubleshooting. Or maybe you meant permanently, to move your hub to a more central location. That is generally a good idea, but unless you have a really large house and a long distance from the hub, Z-Wave's regular mesh capabilities should be able to handle this, so I'm not sure what's going on. But again, the idea above may help with the "problem devices.

Also, I'm not sure if this describes any of your devices or not, but I'm pretty sure Inovelli's range tester only works when you're currently paired to a Z-Wave network.

1 Like

Pulling the air gap didn't do anything for any of them as far as an exclude went. One of them, the dinning room, did show green one time on the range test, but then failed to exclude. When I went back and tried the range test on it again it failed. All 3 of them are now failing the range test every time. I did try pulling the air gap multiple times. (BTW, how how out is it supposed to come? Is it just beyond the paddles so I can see the 2 holes? Also, with it pulled should the power still work?)

I keep hearing very mixed things about whether or not one should ever do a Z-Wave repair with a C7, especially with all my devices being long range (the Red Dimmers and Black Switches) or Series 7, i.e. Z-Wave long range with the fans.

Just wanted to let you know I may have spoken too soon as my hub is down, yet again. (I can tell as anything that isn't directly wired to a load has stopped working). So I have to reboot it yet again (even though I have already done that once this morning already).

That's typically caused by a ghost device on the mesh (failed pairing). You can find out by going to settings, zwave details, and look for a device with nothing but in:out: in the clusters column or sometimes nothing in the route column. Before going any further you should try to get rid of this ghost. Power down the hub and remove power by pulling the plug from the wall. Leave it unplugged for about 30 seconds, then power back up and try to do a repair on the device. Do this twice and it should give you an option to remove it. Click remove and if it goes away then you're done. If not then the hub can still ping the device and you'll need to air gap the switch that it is a ghost of or flip the breaker to the switch and try to repair twice and remove again. Don't disconnect from the hub side, the connector can break easily. It causes all kinds of problems for the zwave radio, including locking up or slow mesh.

I did have ghosts, but have gotten rid of them. After shutting down the hub from inside of Hubitat I've always pulled the plug from the hub itself due to how hard it is to reach the plug where it goes into to. But, I can start doing that now - although I've had to pull the plug probably close to a good dozen times by now since this has been happening, sometimes multiple times per day, since this past weekend.

BTW, I usually couldn't tell what it was a ghost of so I wouldn't know what device to air gap. Even if I did, it's been days since that happened so I don't remember which devices they were. While I usually got the classic ghosts, as you described, I had one that seemed fully formed and could never find out what it was a ghost of. After rebooting the hub and doing a remove twice it finally got rid of it the other day.

I have experienced the same thing with Z-Wave Plus devices manufactured by different suppliers...this is definitely an issue with how Hubitat works with S2 capable devices, as I never had an issue with SmartThings prior (same devices).

If you have a "stuck" device and pulling the air gap does not work, then I would recommend:

  • manually resetting the device...it's different for each manufacturer, so you will have to go to their directions
  • For GE/Jasco devices, just the device reset (3 quick taps up and then 3 quick taps down) was all that was needed
  • For Zooz devices, they needed to be manually reset and then excluded again (the hub will say an unknown device was excluded)
  • For GoControl, they needed to be manually reset and excluded

It seems like the initial stage of pairing (looking for security type) does not propagate well through the Z-Wave mesh. ALL of my S2 capable devices could not be paired with the hub unless they were able to directly connect to the hub.

In all circumstances, I moved the hub in close proximity to the device and it paired right away. I would then shut down the hub (gracefully) and move it back to it's regular location.

In order to have the Z-Wave plus mesh "learn" after moving the hub back, I would manually go through and activate/deactivate (turn on then off) the Z-Wave devices through either the device page or the dashboard. If a device couldn't work through the hub, a manual activation of the device would establish the new Z-Wave route.

I have one Z-Wave Plus tilt sensor and it just worked properly after moving the hub back.

So - it seems like now the S2 capable devices bring us back to the old Z-Wave (non-plus) where the controller needed to be close to the device in order to pair.

Thanks. That's why I'm trying to exclude these devices - to get rid of security.

Now that all of my devices have been installed I'm going to run a Z-Wave repair and see if that helps.

That's why I'm trying to exclude these devices - to get rid of security.

It not just having the security turned on or off, if it's the device is capable of higher level security...which is pretty much any newer Z-Wave Plus device.

I have older GE/Jasco Z-Wave Plus devices that cannot do security, and they paired just fine from a long distance. The newer ones (included newer GE/Jasco) capable of security needed to be paired in close proximity to the hub. It took me a few "ghost node" creations to figure this out...where I had two switches in the same box...one was 3 years old and one was brand new.

For me personally, I have Ethernet drops in every room powered by a PoE switch. I purchased a PoE adapter for the hub, so moving it to different locations for pairing was simple.

All I can say is I've never had to bring my hub close to a s2 device to pair it w/S2 security. I've paired 100% of them in place, and a number of mine don't have direct hub connections.

So I'm not sure what is happening in your scenario, but I don't think those issues are universal.

For me personally, this was the case for GE/Jasco, Zooz, and GoControl devices.

I paired all of my newer ge/Jasco devices in place, and with s2. :man_shrugging:

Just looked, and out of the 5 I checked real quick, 3 are repeating through 2x devices before getting to the hub.

Again, I don't doubt your experience. I'm just saying it is not universal.

Until just the other day I didn't have any problems pairing. I'm having problems now doing excludes and with the hub stopping to communicate with all of my switches, no matter how close or how far unless I do a shutdown/restart at least once per day. I'm going to try a Z-Wave repair now

I hadn't thought of it, but I have a pair of MOCA devices so I can try that to get the hub closer if the Z-Wave repair doesn't work.

For Z-Wave repair, I found the best results by doing devices individually...working from the hub to the outer devices.

Thanks. I think I might as well do the whole net repair first and go from there.

Just a little tip
I've had problems with not being able to pair/unpair S0/S2 devices in the past, I've actually had to pull airgaps/ turn off breakers on repeating devices that are close to the device I'm trying to include/exclude especially with zwave plus door locks. Then the devices pairs instantly. try it you might be amazed, I was the first time I figured this out. :crazy_face:

I did a Z-Wave repair about 2 hours ago. How long should I let the mesh settle before I start trying to do the excludes/includes again?

hmm, I would just go for it Stu!!! or I guess you could wait 30 days :crazy_face: Did some one tell you to wait a long time before excluding/including after doing a zwave repair? that sounds strange?? What's going to happen while you wait?