Z-Wave devices stopped working

Hubitat version: C-5
Elevation version:

This afternoon I noticed that the batteries were low in my GoControl Z-Wave thermostat. Changed the batteries but had to reset the thermostat to get it operating. Could not get the thermostat to communicate with Hubitat. Tried excluding and including 20+ times with no success.

I then decided to try a z-wave repair. Normally a repair takes several minutes and you can see entries in the log as it works its way through the devices. The z-wave repair now finishes in seconds with nothing in the log.

All of my z-wave devices are now non-functional. Zigbee is working fine. I’ve tried restarting the hub but I haven’t tried to exclude any other z-wave devices. I have only tried the gocontrol thermostat at this point.

Any ideas on what to try next? I am dreading having to exclude all of them since I have 20+ devices that were all working well prior to today.

Thanks for your help!

1 Like

What does your Z-Wave devices table look like? Have you tried shutdown, power off for a minute or so, then power on? The reason it may be repairing so fast could be that there aren’t any devices in the table. Shutdown, power off, might bring things back.

Oh, welcome. Sorry under such circumstances.

The z-wave table was empty prior to the power cycle. I pulled power for a couple of minutes, and the z-wave table is now populated after the reboot. The devices are not working however so I am running another z-wave repair. I will update when it’s finished.

Thanks for the suggestion!

Are you seeing Busy messages in the log?

Shutting the Z-Wave Radio off doesn’t remove power, so, if it’s messed up, you have to remove power. Looks like you are in better shape than you were, glad you didn’t have to start over. Have you tried rolling back to an earlier firmware from the Diagnostic Tools menu (your hub IP:8081 )? Or restoring an earlier backup?

Zwave repair has been running for over an hour, but I am not seeing the normal repair messages in the log. Not sure if it’s working. I am seeing a bunch of strange error messages that I will post below.

I can see log entries when a device is manually turned on or off. I am unable to control the same device via Hubitat however.

Here is the error message from the log:

pp:472020-08-27 07:21:00.097 pm errorjava.lang.RuntimeException: java.lang.RuntimeException: java.sql.SQLException: A problem occurred while trying to acquire a cached PreparedStatement in a background thread. Query: SELECT D.ID, D.VERSION, D.DEVICE_TYPE_ID, D.DEVICE_NETWORK_ID, D.LABEL, D.NAME, D.CONTROLLER_TYPE, D.ZIGBEE_ID, D.ENDPOINT_ID, D.PARENT_INSTALLED_APP_ID AS parentAppId, D.PARENT_DEVICE_ID, D.IS_COMPONENT, DT.NAME AS DEVICE_TYPE_NAME, D.CREATE_TIME, D.UPDATE_TIME, D.LAST_ACTIVITY_TIME, D.DISABLED, DT.TYPE AS driverType, D.LAN_ID, D.DISPLAY_AS_CHILD, IFNULL(NULLIF(D.MAX_EVENTS, 0), ?) AS MAX_EVENTS FROM DEVICE D JOIN DEVICE_TYPE DT ON DT.ID = D.DEVICE_TYPE_ID WHERE D.ID = ? Parameters: [100, 101] on line 783 (periodicHandler)

Update: So things are working now, but very slowly. For example, I have a lamp plugged into a GE zwave outlet. Has worked reliably for a couple of years. The lamp was on and I turned it off via the dashboard. From when I pushed the button in the dashboard, it took 2 minutes 41 seconds for the light to switch off. It did eventually turn off, however, so stuff is working just very slowly. Not sure what is going on.