Z wave devices not working anymore

Start with the obvious things. Look in logs for devices reporting stuff a lot
Turn off power reporting on any devices that support it. If you have a device you need to report power, turn it down to once a minute.

Do you have any zooz products in your mesh?

Can you post your z-wave details page in it's entirety for us to look at?

1 Like

Post your z-wave settings page. We may be able to spot something there as well

1 Like

Hi. I still have the same issue. My z-wave breaks down overnight every day. I checked the logs and I havn’t found anything. I also disconnected all z wave and zigbee devices since the issue occured. I am not sure where to look further to solve the issue. Any idea?

That is a worrying statement, can you clarify what you mean by that? Disconnecting or unplugging devices is the opposite of what you should be doing.

Could you please post a screenshot of your Z-wave details page as requested a couple times directly above your last two posts?

1 Like

I disconnected devices which I have added since the error occurred in order to be sure that its not them causing the issue.

Can yo tell me what I should be looking for on the device details page?

We're looking at all the data. Use the windows snip tool to post the z-wave details page in its entirety...(it is not a security concern)

1 Like

Disconnecting devices without properly removing them from the mesh can effectively bring down the entire mesh. Disconnecting a device from a mesh is like taking out the bricks from the bottom of a wall. Taking too many bricks out will result in collapsing the wall.


Again clarify if you mean disconnect as in unplug? Or disconnect as in you did a Z-wave exclusion?

We would like to see a screenshot of everything on that page.


The zwave devices I have recently added and which I thought could be the reason for this issue I have just disconnected (not excluded) from their power suppy and they are not in the mesh (the two on the right without activity). To be 100% sure I have rebooted the hub by unplugging and plugging the power supply.
To sum up the issue: Everyday I loose the connectivity to all zwave devices overnight. I can still see all the devices as per above in the morning but they are not reacting to any commands on the dashboard. When I do a reboot (and just a reboot) the zwave device details page is blank! When I do a reboot by unplugging and plugging the device they all appear again properly and everything works.

When I do a reboot (and just a reboot) the zwave device details page is blank! When I do a reboot by unplugging and plugging the HUB they all appear again properly and everything works.

I hope anyone can help.

From the table you posted, it looks like you have an older model - a C-5 (or perhaps a C-4 or C-3).

The z-wave settings page is of less value in these models to diagnose the issues you describe because ghost nodes are not displayed (even if they exist). You will have to use a secondary controller (like PC Controller) to determine if you have ghost nodes, and also remove them.

This is a terrible idea. Those devices are still on the mesh. Disconnecting power does not inform other devices on the mesh that these devices can no longer participate in routing z-wave packets. So your mesh will suffer from devices repeatedly trying to communicate via the devices you have unpowered but not excluded. In contrast to just removing power, exclusion informs the mesh not to use these two devices.


Meme Reaction GIF by Robert E Blackmon


I have a c-5 and there is a button to enable or disable hub mesh which I did prior. how to disable ghost nodes?

Hub mesh is a protocol for one hubitat hub to use devices paired to a second hubitat. Pertinently, it has nothing to do with z-wave or zigbee mesh networks.

They have to be removed. The only way to do it with a C-5 (or lower) is to use a secondary z-wave controller, like a UZB stick, and PC Controller from SiLabs.

@danabw has documented this process in detail. Here is a link to his instructions:


seems to be pretty tricky. do you really think this is the problem because acually it only stops working at one point during the night

wouldn't the problem be persistent then

Likely. It matches my experience from several years ago.

Yes. And that is what you are observing. The situation is alleviated by reboot, which clears the z-wave radio queue. And then over the course of the day (and depending on device usage), the queue gets filled again with transmits and re-transmits

The C-7 provides greater visibility of mesh details along with some approaches to remove ghost nodes.


GIF by Giphy QA